Jump to content


Photo

bootloader, root and cwm errors.

- - - - -

  • Please log in to reply
11 replies to this topic

#1
yoccoio

yoccoio

    Newbie

  • Members
  • Pip
  • 8 posts
  • Devices:Huawei ascend g300
hi everyone, this is my first post here and i have to thank you all for the help you made after i bought my g300. i rooted and installed everything and for 5 months it was beautiful.... BUT....
yesterday, i tried to update my ics to B952 and by the explanation i went into cwm and install zip BUT (second But)
i didnt had cwm installed... installed many times and.... nooothing.
tryed to instal zip for other way and booom... lost root and everuthing.
my phone works very well, i have android 4.0.3, baseband 2030 and kernel 3.0.8- perf-00240-g6df6f4c and i am at B934
when i try to root, instal cwm or anything else that needs to connect by bootloader, my pc keeps saying "waiting for device". always i connect my g300 throw boatloader, my vista makes me instal all the drives, and it takes for less than 1 min to finish..
can anyone help me.... i would like to root (again) instal cwm , and update for B952 but i have that problem....
sorry my english, im portuguese

  • 0

#2
andy/newbie

andy/newbie

    Enthusiast

  • Members
  • PipPipPip
  • 176 posts
  • Gender:Male
  • Location:barnstaple/north devon
  • Devices:huawie g510,rk3066 tablet
Make sure you have internet on PC as I think it needs to download when waiting for device that's all I can think of.why I say that is a friend of mine made that mistake

Edited by andy/newbie, 06 December 2012 - 12:56 AM.

  • 0

#3
yoccoio

yoccoio

    Newbie

  • Members
  • Pip
  • 8 posts
  • Devices:Huawei ascend g300
im sure i had internet. other ideas???

  • 0

#4
andy/newbie

andy/newbie

    Enthusiast

  • Members
  • PipPipPip
  • 176 posts
  • Gender:Male
  • Location:barnstaple/north devon
  • Devices:huawie g510,rk3066 tablet
U could try doing an other official update download folder on root of SD card and force update that will put u back to full stock so you can root and install cwm again,did you have cwm installed and when u tried to flash zip you lost cwm?

Edited by andy/newbie, 06 December 2012 - 12:54 AM.

  • 0

#5
yoccoio

yoccoio

    Newbie

  • Members
  • Pip
  • 8 posts
  • Devices:Huawei ascend g300
I thought I had cwm instaled. but when i tried to upgrade to B952 with the zip, i saw that it was on recoverymode and not at cwm... by recoverymode, when i try to instal zip (b952) it gives me an error.
as i said later, when i (re)instal cwm and tried to open it, it open again recoverymode and not cwm.
For last, i tried update via and app i thought it could help me, and now i dont have root too!!!! :S
im trying to root and my pc only say "device not found" or "waiting for device".

what do you mean? i didnt understand what you said. how can i come back to fulll stock?
and other question: could it be, problem of my sdcard? i have there cwm folder and some other things....

  • 0

#6
pepdavies

pepdavies

    Newbie

  • Members
  • Pip
  • 42 posts
  • Devices:Huawei G300
I had the same problem where it got stuck on waiting for device. I seem to remember using a different usb port made it work. Don't ask me why!

  • 0

#7
luvvt

luvvt

    Enthusiast

  • Members
  • PipPipPip
  • 180 posts
  • Devices:G300
Waiting for device means either

1. usb debugging on your ph is not enabled and/or
2.you havnt installed the huawei device drivers on your pc

Seeing as you flashed a rom by the update method you will have wiped root and cwm.

You now have to unlock the bootloader and reroot using one of the two tools on this forum. Then reinstall any version of cwm (recommend a flasable version)

Then when you try to install another rom make sure its a repacked rom that you can flash via cwm.

Use this link for the entire process from the start:
http://huaweig300.co...rkmod-recovery/

Edited by luvvt, 06 December 2012 - 09:21 AM.

  • 1

#8
yoccoio

yoccoio

    Newbie

  • Members
  • Pip
  • 8 posts
  • Devices:Huawei ascend g300
welll... this is the pointo of the situation now.
i have root. i have already unlock the bootloader. but when i try to instal cwm... still waitting for the device. isn't there other way of installing cwm without being via bootloader??? via bootloader, my computer keeps waitting...

  • 0

#9
luvvt

luvvt

    Enthusiast

  • Members
  • PipPipPip
  • 180 posts
  • Devices:G300
Do you have sdk installed on your pc

usb debugging checked

have you installed the huawei device drivers on your pc

Edited by luvvt, 06 December 2012 - 05:43 PM.

  • 0

#10
yoccoio

yoccoio

    Newbie

  • Members
  • Pip
  • 8 posts
  • Devices:Huawei ascend g300
huawei driver- check
usb debugging- triplecheck
sdk? fist time i did all this steps, i did not needed that...

  • 0

#11
yoccoio

yoccoio

    Newbie

  • Members
  • Pip
  • 8 posts
  • Devices:Huawei ascend g300
welll i used unlockbootloader.exe (http://community.gif...nd/ba-p/5781620)
apparently, it worked.
next i tried to instal cwm and by the cmd- all worked fine...
pulled the batery of.. 5 sec... volume up and power bottom.. and again no cwm... only recoverymode.
I DONT KNOW WHY BUT I CANT INSTAL CWM!!! PLEASEE HELP MEE

  • 0

#12
yoccoio

yoccoio

    Newbie

  • Members
  • Pip
  • 8 posts
  • Devices:Huawei ascend g300
the problem must be of the bootloader. i think that this is not unlocked. i tryed this http://www.modaco.co...he-ascend-g300/ i saw on other discussion, the Chinese bootloaderunlocker, but didnt worked to. could it be because i didnt rooted by that exe too? i already had root so i didnt rooted with that bootloaderunlocker.
Any help!?

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users