Jump to content


Photo

Why does my Wireless not connect in G300 U8815!!!?

- - - - -

  • Please log in to reply
3 replies to this topic

#1
riadtaihi

riadtaihi

    Newbie

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Lithuania
  • Devices:Huawei Ascend G300/KK/4.4.4
Hello everybody!

I have noticed some 2 months ago that i can not connect to wireless on my Huawei Ascend G300 U8815 , but i didnt care.
It was originally on GB 2.3.6 B885 then i upgraded to B895 then ICS B927 but wireless didnt work even before upgrading.

Yesterday i bought a TP link Router WR740N and setup my internet on it making it as an A.P, so i was sure that setting were correct since i connected with my laptop and another phone which is Nokia Xress Music 5530, but not on my G300.

So, my problem is that the phone recognize Wireless connections and when i try to access with or without password, it just says that my network is registered and keeps on trying to connect but unsuccessfully.
I tried all securities on my router from non to wep to wpa to wpa2 psk and still the same...
i even checked in some forums that some people experienced this problem, so they proposed :

-to reset phones setting to factory which didnt work
-use wifi fixer which didnt work
-upgrade to ICS which made me happy but still no wifi.
-use static ip address but also refsued to connect.

my self i downloaded WIFI MANAger Premium which is a very good soft but still knowing all networks but keeps turning and then stops.

Please find below my router settings:

LAN MAC Address:
64-70-02-55-4F-F8 IP Address:
192.168.1.1 Subnet Mask:
255.255.255.0 Wireless Wireless Radio: Enable Name (SSID): Meganet Channel: Auto (Current channel 6) Mode: 11bgn mixed Channel Width: Automatic MAC Address: 64-70-02-55-4F-F8 WDS Status: Disable WAN MAC Address: 64-70-02-55-4F-F9 IP Address: 88.222.160.212 Dynamic IP Subnet Mask: 255.255.248.0 Default Gateway: 88.222.167.254 DNS Server: 88.222.0.1 , 88.223.0.1

So, on the phone when i used static IP i did like this:

IP: 192.168.1.101
Mask: 255.255.255.0
GW: 192.168.1.1
DNS1: 192.168.1.1
DNS2: 192.165.1.1

Can any body help me please because i have tried all solutions and i think that the wireless driver is corrupted or something like that, so can it be replaced or flashed somehow because im using G internet now and it's exensive.....

Please i need your expertise!

  • 0

#2
riadtaihi

riadtaihi

    Newbie

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Lithuania
  • Devices:Huawei Ascend G300/KK/4.4.4
Hi again, i'm online on skype if anybody can help?
my skype is : riadtaihi

Thanks in advance!

  • 0

#3
putbinoot

putbinoot

    Diehard

  • Members
  • PipPipPipPip
  • 481 posts
  • Gender:Male
  • Devices:Huawei G300, Jiayu G3.
Can you turn on wifi tethering on your nokia and see if your G300 can connect to it or check if your g300 can connect to any network, coffee shop or free wifi etc. Did you set your correct location in the wifi settings of the router and set it up with just the basic settings, ie ssid, location and try changing mode to G only and save without any security to test.


http://www.joiku.com...joikuspot_light

Edited by putbinoot, 23 December 2012 - 10:12 PM.

  • 0
Posted Image

#4
riadtaihi

riadtaihi

    Newbie

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Lithuania
  • Devices:Huawei Ascend G300/KK/4.4.4
Hi, putbinoot!

Thanks for your answer! not fixed yet :)
I tried to connect from o the Nokia and nothing again, it recognizes the network but just registeres it and keeps on trying as if it couldnt get an IP address.
So, i put a static Address on the phone in the same range of the modem again as i did on my previous message and also nothing.
Last thing i did was to reset oruter settings all over again so i tried only B then only G then chose a channel to avoid automatic and also removed security but still the same.

Can it be a kenel problem? because when i changed from Gb to ICS i didnt change Kernel logically

so my actual kernel is 3.0.8-perf-00213-g8dfa62b
ICS version 4.0.3
Base band 2030
Buiild C00B927

Somebody told me that my wifi drive may have broke so how can i restore this driver or upgrade it?
Thanks a lot.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users