Jump to content


Photo

[DEV][ROM][17.9.] CyanogenMod 10.1 (Android 4.2.2)

* * * * * 11 votes

  • Please log in to reply
971 replies to this topic

#781
RobbieM

RobbieM

    Newbie

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Serbia
  • Devices:ZTE Blade III / CM 11
Well, as far as I`m concerned, Skype worked flawlessly for some time, then it quit on me for no reason... But there were no audio issues similar to Viber...

  • 0

#782
razjaren

razjaren

    Newbie

  • Members
  • Pip
  • 35 posts
  • Gender:Male
  • Location:CROATIA , SLAVONSKI BROD
  • Devices:ZTE BLADE III
  • Twitter:@razjaren

Could someone test if mic works in Viber with this patch? How about other VoIP apps?

works Viber .. You are a very capable man .. thank you very much

Edited by razjaren, 27 August 2013 - 07:34 PM.

  • 0

#783
RobbieM

RobbieM

    Newbie

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Serbia
  • Devices:ZTE Blade III / CM 11
You sir, are a Level 9000 Wizard in my book! :D

Viber works as it should as of this patch!

  • 0

#784
odmetnik81

odmetnik81

    Regular

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
  • Devices:zte blade 3

Could someone test if mic works in Viber with this patch? How about other VoIP apps?


Bless You, my child...

  • 0

#785
odmetnik81

odmetnik81

    Regular

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
  • Devices:zte blade 3
Is the updated build from the first page OK with Viber?
Is the patch for Viber implemented inside this updated build?
Thanks

  • 0

#786
ProCro

ProCro

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:ZTE Blade III
+1 confirmation

  • 0

#787
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 3,044 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio

(OFFTOPIC) I o not on a blade anymore but I remember konstaT is an awesome dev. So my new device is Galaxy Mega 6.3 I9200 and so far no cyanogen for it. the thread on cyanogen bringup on the device has hit a dead end:
http://forum.xda-dev...2397325&page=10
KonstaT is there a way to debug a kernel port?

It's a Qualcomm device, shouldn't be too difficult to get CM up and running if you know what you're doing. The fact that they can't even get kernel booted with stock ROM (from stock kernel source) tells that they're doing something very wrong. :P

I have little problem with bluetooth A2DP playback. My device connects just fine to my bt-audio receiver, but seems that sound doesnt get routered to the receiver, just to the phones speaker.
I decided to take some logs, if KonstaT could try to take a look to the issue. I started logcat from bluetooth start, and stopped after I turned bt off, because routering doesnt work. So the the whole "session" should be in attched log ;)

Bluetooth A2DP works just fine with my Blade I running cm10.1, and with Blade III running cm10.
If more logs/details are needed, I will post them there.

CM10.1 for Blade III is the only one of the three that has a 'wrong' bluetooth stack. Nothing too interesting in the logs though.

The problem with VoIP is that by audio HAL doesn't support anything above 16khz as VoIP input. That hack indeed fixed Viber. That was a quick implementation, maybe you can do it cleaner. Anyway, do you also have graphical corruption in the latest Google Maps ?
About some apps crashing (Hill Climb Racing, Busy Beaver, for example), it happens also on Mini 2, dunno why.

Texture corruption on latest Google Maps has been reported on several devices and on several ROMs. Never seen it myself though.

I saw some logs about the crashing games earlier and I can't see how it would be a device (or even family of devices) specific issue. Either the apps are not up to date for Android 4.2+ or there's something wrong in CM10.1 in general.

Is the updated build from the first page OK with Viber?
Is the patch for Viber implemented inside this updated build?
Thanks

Huh, what? What updated build?

Install 14.8. build from the first post, install patch from post #780. Can't be that difficult...

  • 2

#788
tibisir

tibisir

    Newbie

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Devices:ZTE Blade 3
  • Twitter:@yuyop
thanks good work but

Hill.Climb.Racing.v.1.10.2M.apk does not work

  • 0

#789
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 3,044 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio

thanks good work but

Hill.Climb.Racing.v.1.10.2M.apk does not work

Internet message boards never seize to amaze me. Last time this was discussed was on the post above yours!

Now that I actually bothered to install one these games on CM10.1 myself, this took like two minutes to debug and fix. :P Notification sounds in WhatsApp should also be fixed afaict (didn't test it though). I'll make a new build sometime later this week. I've got couple of other small things as well.

  • 0

#790
bamdad

bamdad

    Regular

  • Members
  • PipPip
  • 124 posts
  • Devices:zte blade 3

I'll make a new build sometime later this week. I've got couple of other small things as well.


are you planning on updating cm10 too?

  • 0

#791
Zsebes01

Zsebes01

    Newbie

  • Members
  • Pip
  • 29 posts
  • Devices:ZTE BLADE 3
Hello KonstaT. I have a question.(sry for my english)
Can you somehow make a patch?
I need the original lock screen,like in the blade 3 ICS.
Áhhhh i have bad english i hope you can understand...
I dont know how can i upload picture here so i copy the link here.
http://img.ibtimes.c...3/19/354996.jpg
Its possible??
Very thanks your answer and thanks for the ROM.
You are the best :-)

  • 0

#792
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 3,044 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio

are you planning on updating cm10 too?

Meh, not in current plans. There's practically nothing to update in CM10 anyway. I can do a separate patch for the Viber issue if someone needs it. Most people have now moved on to CM10.1/CM10.2.

Hello KonstaT. I have a question.(sry for my english)
Can you somehow make a patch?
I need the original lock screen,like in the blade 3 ICS.
Áhhhh i have bad english i hope you can understand...
I dont know how can i upload picture here so i copy the link here.
http://img.ibtimes.c...3/19/354996.jpg
Its possible??
Very thanks your answer and thanks for the ROM.
You are the best :-)

Eww, not going to happen. This is an AOSP based ROM and objective here is to get rid off all ugly vendor/carrier customizations - not to add them! That would be one of the first things I'd remove on any ROM...

There's plenty of lockscreen replacement apps on the Play Store though.

  • 0

#793
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 3,044 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio
New build. Please test any games/apps that you had problems with in the previous build and report back (Hill Climb Racing, WhatsApp notifications, etc). A2DP audio and music controls needs to be tested again as well.

cm-10.1-20130830-KonstaKANG-atlas40.zip
https://hotfile.com/...tlas40.zip.html
md5:a6f1470e454dd7f6da48bc5a7e26021f

-fixed muted mic in viber
-fixed 'Can't create handler inside thread that has not called Looper.prepare()' that caused issues with several games/apps
-added option for vibrator intensity (Settings -> Advanced -> Vibrator intensity)
-button backlight delay equals screen timeout (if button backlight not disabled from the settings)
-CM10.1.3

  • 2

#794
navuhodonosors

navuhodonosors

    Newbie

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Location:Belgrade, Serbia
  • Devices:ZTE Blade lll
Wow! Thank you man for update, you made my phone usable with your rom, stock was laggy like hell. Thanks!

  • 0

#795
Otila

Otila

    Regular

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:Finland
  • Devices:ZTE Blade III
08-30 13:12:33.740 I/am_crash( 475): [4092,0,com.merriamwebster.premium,8961604,java.lang.RuntimeException,Can't create handler inside thread that has not called Looper.prepare(),Handler.java,197]

also the game Compulsive crashes the same way.

I am using self-built version of today's CM, it should be fresh enough (I have the option for Vibration strength).

  • 0

#796
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 3,044 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio

08-30 13:12:33.740 I/am_crash( 475): [4092,0,com.merriamwebster.premium,8961604,java.lang.RuntimeException,Can't create handler inside thread that has not called Looper.prepare(),Handler.java,197]

also the game Compulsive crashes the same way.

I am using self-built version of today's CM, it should be fresh enough (I have the option for Vibration strength).

This fixes it. I've squashed it into the bluez patch. I guess you didn't update that.

And please, bug reports only using nothing but stuff from the first post.

  • 0

#797
Something Wierd

Something Wierd

    Enthusiast

  • Members
  • PipPipPip
  • 180 posts
  • Devices:ZTE Blade III
Tried one of the games it runned normally.The issue is seems to be fixed on my phone.Tnx konstat.

  • 0

#798
Otila

Otila

    Regular

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:Finland
  • Devices:ZTE Blade III

This fixes it. I've squashed it into the bluez patch. I guess you didn't update that.


Of course I didn't, how could I have known that? I even checked the manifest files (no change), but didn't really guess that fix was hidden in those old links.
Could you in the future, when releasing a new build, also mention this kind of changes (and updated manifests) in a new post so people get all the fixes when building CM.. thanks. :wub:

  • 0

#799
jakonicki93

jakonicki93

    Newbie

  • Members
  • Pip
  • 22 posts
  • Gender:Not Telling
I just have quick question. Why are YouTube and normal (that I download) videos not as smooth as on the stock ROM. It's noticably(?) laggier, also the Camcorder.

  • 0

#800
peetu20

peetu20

    Addict

  • Members
  • PipPipPipPipPip
  • 929 posts
  • Gender:Male
  • Location:Finland
  • Devices:Zte Blade, Zte Blade III

I just have quick question. Why are YouTube and normal (that I download) videos not as smooth as on the stock ROM. It's noticably(?) laggier, also the Camcorder.

Yep, I dont know whats the problem, but for me 480x800 mp4 videos lags bit. Using sw-decoder removes lag, but sound doesnt seem to sync with video :(

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users