Jump to content


Photo

MMS problems on Orange UK anyone? (Jr10)

- - - - -

  • Please log in to reply
13 replies to this topic

#1
professordes

professordes

    Regular

  • MoDaCo Gold
  • PipPip
  • 67 posts
  • Gender:Male
  • Location:Scotland
  • Devices:Nexus 4, JiaYu G3S, Moto G
  • Twitter:@professordesJ
Has anyone else experienced problems with MMS (picture messaging) on Orange UK?

I noticed I didn't get a picture message recently - and as far as I could see the APN orangemms settings were correct for Orange UK. I got them to resend the settings via SMS, but no change: I can neither send nor receive MMS. Everything else, phone, SMS, internet is fine. Orange were a little perplexed as the phone came as an upgrade via the Carphone Warehouse, so they couldn't be sure the "standard" settings were correct.

I'm running a Modaco JR10 ROM with a Franco kernel (r111), but the problem may have been present with earlier ROMs (even stock) - I don't get many picture messages... :)

There are some threads on XDA about MMS problems but the suggested fixes there (tweaking APNs for other networks, or using only the stock messaging app) don't apply. I can't send or receive MMS with either the stock app or others such as Handcent SMS.

  • 0

#2
cmberry20

cmberry20

    Diehard

  • Members
  • PipPipPipPip
  • 352 posts
  • Gender:Male
  • Devices:San Franciso
I had this problem with GiffGaff when I first got my phone & using GO sms Pro.

I was pulling my hair out trying to get the MMS to work with my GO SMS Pro messaging app. Internet (3G) was fine but for some reason MMS wouldn’t work.

After trying several methods & edits of the APN & searching the GiffGaff message board for help (loads of tips but nothing worked) I managed to fix it myself - here's what I did....

I copied the APN settings from my old Android phone & entered them into my Nexus 4, the settings were:

Name: Giffgaff
APN: giffgaff
Proxy: <Not Set>
Port: <Not Set>
UserName: giffgaff
Password: password
Server: http://mmsc.mediamessaging.co.uk:8002
MMSC: http://mmsc.mediamessaging.co.uk:8002
MMS Proxy: 193.113.200.195
MMS Port: 8080
MCC: 234
MNC: 10
Authentication type: Not Set
APN type: default,supl,mms

Now even though these settings worked for MMS on my old phone, they wouldn’t work with my new Nexus 4.

However, I found that if I manually entered the MMS settings into my messaging app then MMS would work.
For Go SMS Pro, open app, select settings, select advanced tab at top, select 'MMS Settings', then select 'Fill APN configuration manually'

For MMSC enter: http://mmsc.mediamessaging.co.uk:8002
For MMS Proxy enter: 193.113.200.195
For MMS Port enter: 8080

Once I entered these values, MMS started working - happy days!!

Of course the APN settings will be different for Orange but the principal should be the same.

Edited by cmberry20, 01 April 2013 - 09:19 AM.

  • 0

#3
professordes

professordes

    Regular

  • MoDaCo Gold
  • PipPip
  • 67 posts
  • Gender:Male
  • Location:Scotland
  • Devices:Nexus 4, JiaYu G3S, Moto G
  • Twitter:@professordesJ
Thanks for the pointers - but even copying across the (correct according to Orange...) APN settings into GoSMS doesn't do the trick. GoSMS bounces to a webpage that can be accessed with one click, which is an improvement
on the standard messaging app, which bounces to an Orange page that requires a different id and password for each MMS to be entered.

I've gone as far as getting a replacement SIM from Orange, but even after that there is still no MMS. I guess there must some non-standard permutation of the APN settings required on the N4 to get it going. I'll report back if I find it :)

  • 0

#4
professordes

professordes

    Regular

  • MoDaCo Gold
  • PipPip
  • 67 posts
  • Gender:Male
  • Location:Scotland
  • Devices:Nexus 4, JiaYu G3S, Moto G
  • Twitter:@professordesJ
Aha - if I uncheck "auto-retrieve" in the standard message app MMS settings I can _send_ MMS via GoSMS, but messages to me are still bouncing to the Orange webpage.

Getting warmer.....

  • 0

#5
Stuart_f

Stuart_f

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 440 posts
  • Gender:Male
  • Location:Englandshire
  • Devices:Google Nexus 4
I had something which sounds a bit similar to your issue but I'm with T-Mobile, however, since the 2 brands are effectively the same now through EE perhaps you might get lucky.

You seem to need to show the EE network that your phone is MMS capable before it'll send you anything other than a link to your message. The way you do this is to send yourself a MMS message from your own phone. I know it makes no sense at all, but give it a try. I was a sim-only customer, perhaps they are sent out provisioned for voice and data only until it receives the "secret signal" that the phone it's installed in is MMS capable.

  • 0

#6
Inkleach

Inkleach

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Nexus 4
Any luck with this? I'm having the exact same problem with orange (ee)

  • 0

#7
Stuart_f

Stuart_f

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 440 posts
  • Gender:Male
  • Location:Englandshire
  • Devices:Google Nexus 4
Did you try sending yourself an MMS?

  • 0

#8
Mike Rew

Mike Rew

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:London, UK
  • Devices:Google Nexus 4
  • Twitter:@iwasonlysaying
Try tweaker on the play store. I've yet to find a network where it doesn't sort out apn settings

  • 0
Nexus 4 - MCR
Archos 70b IT2 - LeTama Root rom

#9
Mike Rew

Mike Rew

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:London, UK
  • Devices:Google Nexus 4
  • Twitter:@iwasonlysaying
Try tweakker on the play store. I've yet to find a network where it doesn't sort out apn settings

  • 1
Nexus 4 - MCR
Archos 70b IT2 - LeTama Root rom

#10
professordes

professordes

    Regular

  • MoDaCo Gold
  • PipPip
  • 67 posts
  • Gender:Male
  • Location:Scotland
  • Devices:Nexus 4, JiaYu G3S, Moto G
  • Twitter:@professordesJ
Still no joy :(

Tweakker's suggestions for Orange UK are the default ones which don't work for me, so I still can't send or receive MMS on the default messaging app.
Attempting to send an MMS to myself just stalls, unless I do it through one of the other apps which uses non-default routes....

  • 0

#11
The Soup Thief

The Soup Thief

    Hardcore

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 1,040 posts
  • Gender:Male
  • Location:Dublin
  • Devices:Nexus 5 (N4 etc retired)
  • Twitter:@TheSoupThief
I've never managed to receive a picture message with any smartphone I've owned, from my Xda ii on orange uk 10 years ago, through my ZTE blade & xperia ray on Vodafone ireland and my N4 on O2 ireland. Never bothered trying to send them cos I assumed didn't work for anyone else!

I remember struggling (fruitlessly) to set it up on the xda ii before deciding to skip this particular technology.
I took the same stance with the Breville Pie-Magic and Squariels. Worked out fine

Edited by The Soup Thief, 18 April 2013 - 12:18 PM.

  • 0

#12
pjaj

pjaj

    Newbie

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Devices:Google Nexus 5

Still no joy :(

Tweakker's suggestions for Orange UK are the default ones which don't work for me, so I still can't send or receive MMS on the default messaging app.
Attempting to send an MMS to myself just stalls, unless I do it through one of the other apps which uses non-default routes....


I don't know if this will help, but I tried Tweakker on a giffgaff SIM in a fully jail broken Orange ZTE Blade I and it worked.
It creates a new APN named Tweakker which seems to have all the same settings as the ones recommended by giffgaff except the APN type is set to
default,supl,mms,dun,fota*
Rather than giffgaff's setting of just default.
Maybe you could manually edit your APN type setting to match?
Of course it could have changed some other setting I didn't notice and it may not work for Orange.

It's worth noting that, up till a couple of weeks ago I was with Orange, and before I jail broke it in January, the basic San Francisco would send and receive MMS on Orange.
I didn't try to send any MMS in the next 3-4 months, only once I'd switched to giffgaff, so I couldn't say if it was the jail break or the giffgaff SIM that caused the problem.

Edited by pjaj, 18 April 2013 - 12:45 PM.

  • 0

#13
Holehouse

Holehouse

    Newbie

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:England
  • Devices:Motorola Moto G
I know this thread is a few months old but I was having problems receiving MMS (and sending but I haven't tried sending since changing my settings so don't know if it's fixed it), and fixed it so this might help someone else.

MMS APN settings were as follows by default on my ZTE v970, and not working:

Name = Orange UK MMS
APN = orangemms
APN type = mms
Proxy = 192.168.224.010
Port = 8080
Username = Orange
Password = Multimedia
Server = Leave blank
MMSC = http://mms.orange.co.uk
MMS proxy = 192.168.224.010
MMS port = 8080
MMS protocol = WAP 2.0
MCC = 234
MNC = 33

After fiddling around for a while it turned out I got the settings to work by editing "Proxy" and "MMS Proxy" fields from 192.168.224.010 to 192.168.224.10 - so dropping a zero. Then I could receive the MMS I was trying to. Hope this helps someone having the same problem.

  • 0

#14
Stuart_f

Stuart_f

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 440 posts
  • Gender:Male
  • Location:Englandshire
  • Devices:Google Nexus 4
Actually I had some MMS issues myself the other day that I think are related to the Orange/T-Mobile conversion to EE. The fix was to go to Settings > Under "Wireless & Networks" hit "More..." > Mobile Networks > Access Point Names > Hit the 3 vertical dots in the top right corner > Choose "Reset to default".

When I did the the old general.t-mobile.co.uk APN vanished and was replaced with two entirely new entries: EE Internet and EE MMS. Since then I've had no issues at all. Hope it works for you too.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users