Jump to content


Photo

Camera App crashes, barely works anymore

- - - - -

  • Please log in to reply
4 replies to this topic

#1
dmrtn

dmrtn

    Newbie

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Devices:Huawei Ascend G300 ICS notroot
Okay so that title is basically the problem. The camera app hardly ever works now. It started crashing occasionally a few months ago but now it is more likely not to work.

Bought the phone last September, it's still running stock 2.3.6. with ADW Launcher so not "messed with" and should still be under warranty. I was just about to root it and start messing with it properly.

Basically my question is, is there anything I can try, software-wise, to sort this out or am I better just bringing it back to the shop and letting them deal with it?

Cheers.

  • 0

#2
sharkyo01

sharkyo01

    Enthusiast

  • Members
  • PipPipPip
  • 286 posts
  • Gender:Male
  • Location:Walsall
  • Devices:Raised from the Dead G300 :P
What I would do is find another Camera app on the play market and see what happens. Try FxCamera then comeback and let me know I'll if it needs taking back I'll run though the does and the dont's of returning your g300 if it fails.


  • 1

#3
dmrtn

dmrtn

    Newbie

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Devices:Huawei Ascend G300 ICS notroot

What I would do is find another Camera app on the play market and see what happens. Try FxCamera then comeback and let me know I'll if it needs taking back I'll run though the does and the dont's of returning your g300 if it fails.


Thank you for that advice. I installed FxCamera. Initially it worked perfectly when installed and so did the normal camera app. I restarted the phone and then the same issues kicked in.

I called into Vodafone today and they told me the camera was under a 2 year warranty so I could return it to them. I've got my contacts, photos, sms, etc backed up so I just need to disconnect any of my email accounts that are installed? Anything else I should look out for?

Thank for the help.

  • 0

#4
sharkyo01

sharkyo01

    Enthusiast

  • Members
  • PipPipPip
  • 286 posts
  • Gender:Male
  • Location:Walsall
  • Devices:Raised from the Dead G300 :P
If your on a contract with Vodafone your be fine. Just if you have unlocked the phone there go all funny about it. Plus other pieces of software (e.g. CWM) as you mentioned you have not rooted it or installed custom recovery your be perfectly fine!

So let us now if there find and fix the issue and what it was. Always useful to know!

  • 0

#5
dmrtn

dmrtn

    Newbie

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Devices:Huawei Ascend G300 ICS notroot

This happened quite a while ago so not sure if this is relevant to anyone but just to clear it up ...

 

Eventually left the phone back into the shop, was sent away, fixed and sent back within a week. All I know now is that there was a mechanical fault and it was fixed. Probably not relevant to anyone else but just wanted to leave a record here that it happened.

 

Cheers for replies.


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users