Jump to content


Photo

huawei screen problem

- - - - -

  • Please log in to reply
7 replies to this topic

#1
denio7

denio7

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:g300
Hi
after my phone dropped i noticed it has broken lcd. That's not a problem for me because i can replace it but next day something like this appeard but without jumping and the "second display" was upside-down i think. Now the problem is i don't know should i replace just lcd or something else is broken too.
Thank you for help

  • 0

#2
jwkk

jwkk

    Newbie

  • Members
  • Pip
  • 24 posts
  • Gender:Male
  • Devices:Huawei Ascend G300
  • Twitter:@jwkkbiz
As seen at the start so it's cool and it will be the software in ROM. My advice is to reinstall.

  • 0

#3
sharkyo01

sharkyo01

    Enthusiast

  • Members
  • PipPipPip
  • 286 posts
  • Gender:Male
  • Location:Walsall
  • Devices:Raised from the Dead G300 :P
Have you tried putting it in to recovery? See what the phone does then...

  • 0

#4
denio7

denio7

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:g300
Hmm i have to say that the problem with the display has gone by itself, of course the crack is still there. My question is if this problem may come back after i replace the lcd
' of course i will reinstall os

Edited by denio7, 25 May 2013 - 05:39 PM.

  • 0

#5
sharkyo01

sharkyo01

    Enthusiast

  • Members
  • PipPipPip
  • 286 posts
  • Gender:Male
  • Location:Walsall
  • Devices:Raised from the Dead G300 :P
It could be a crack in the board, lose connection, anything so that is a hard question to answer.

  • 0

#6
denio7

denio7

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:g300
i disassembled and reassembled it today and to be honest i didn't noticed any cracks or stuff like this but i don't really know what to look for. For me everything looked just fine.Is there any way to check is there possibility of this issue coming back?

Edited by denio7, 25 May 2013 - 06:38 PM.

  • 0

#7
sharkyo01

sharkyo01

    Enthusiast

  • Members
  • PipPipPip
  • 286 posts
  • Gender:Male
  • Location:Walsall
  • Devices:Raised from the Dead G300 :P

i disassembled and reassembled it today and to be honest i didn't noticed any cracks or stuff like this but i don't really know what to look for. For me everything looked just fine.Is there any way to check is there possibility of this issue coming back?


Most cracks in boards are not bigger then a hair hence the name (Hair line crack). So many variables for what could of happened its hard to say...

  • 0

#8
denio7

denio7

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:g300
Ok thank you all very much for help. I think i'll take it to the service and let them check what is not working

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users