Jump to content


Photo

Blue screen and update failed on G510-0200...


  • Please log in to reply
13 replies to this topic

#1
chasser

chasser

    Newbie

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Devices:G510-200 (LewaOS 5)
I was playing with Swapper 2 and it did something to my phone's partitions so now all I have is blue screen when i boot it. I can't enter recovery or fastboot mode. All I can do is try official firmware update with volume+- but all the stock roms I try just fail to update. The Update_log looks like this:

filename = /mmc1/dload/update.app
call RCV_MODULE_END_EVENT failed,module = OEMSBL_VER_LIST
CMD=0xf,moduleaddr = 0xd2000000, len_tmp=0x4000

Did I just brick it or there is some way to bring it back to life? The last rom I used was Lunatic Pandora 2.1. I tried every possible stock rom I could find out there and none of them worked.

  • 0

#2
ZolaIII

ZolaIII

    Addict

  • Members
  • PipPipPipPipPip
  • 892 posts
  • Devices:Huawei Y300-100
Can you connect it to the PC? First to correct the partitions & then to do the update through adb!

  • 0

#3
chasser

chasser

    Newbie

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Devices:G510-200 (LewaOS 5)
My PC recognizes the phone as a Huawei Device but drivers can not be installed so I don't think i can do anything with the partitions.

  • 0

#4
Hassams

Hassams

    Regular

  • Members
  • PipPip
  • 106 posts
  • Gender:Male
  • Location:Pakistan
  • Devices:Huawei G510-0200
What firmware are you trying to flash. You can bring it back to life by flashing the proper official firmware

  • 0

#5
chasser

chasser

    Newbie

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Devices:G510-200 (LewaOS 5)
I bought it at Vivacom in Bulgaria. I tried all the EU firmwares i found (normal ie, orange, vodafone etc...), also tried stock chineese and singapore version but none of them worked :(. I really don't remember the stock version of the phone but the last rom that was installed was v178 based. I'm not sure if it's possible to flash lower version of stock rom or the chinese MIUI that I tried did something to mess with the phone. Belive me I tried all roms from v168 to v180(cn) but no luck. I'm losing hope here and think to get it back to Vivacom.

  • 1

#6
ZolaIII

ZolaIII

    Addict

  • Members
  • PipPipPipPipPip
  • 892 posts
  • Devices:Huawei Y300-100

I bought it at Vivacom in Bulgaria. I tried all the EU firmwares i found (normal ie, orange, vodafone etc...), also tried stock chineese and singapore version but none of them worked :(. I really don't remember the stock version of the phone but the last rom that was installed was v178 based. I'm not sure if it's possible to flash lower version of stock rom or the chinese MIUI that I tried did something to mess with the phone. Belive me I tried all roms from v168 to v180(cn) but no luck. I'm losing hope here and think to get it back to Vivacom.

Well did the phone tray to update firmware at least?
What method did you tray to update?
If it did then did you tray original 178b?

  • 0

#7
chasser

chasser

    Newbie

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Devices:G510-200 (LewaOS 5)
Well it begins the update process but after unpacking it says "update failed". Actually I called a friend of mine and asked him to see the software version of his phone. Then I searched it by G510-200V100R001C00B178 and found exact match at a chinese forum. I'm downloading it and will try it later.

  • 0

#8
radu_sergiu

radu_sergiu

    Regular

  • Members
  • PipPip
  • 97 posts
  • Devices:Huawei G510
did you try the firmware from huawei device site? it is for g510 0200.

Edited by radu_sergiu, 02 July 2013 - 12:52 PM.

  • 0

#9
chasser

chasser

    Newbie

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Devices:G510-200 (LewaOS 5)
Guys I think I fugured it out :P ... none of the firmwares worked with me because you have to find the exact firmware for yr phone. You can find it in the settings menu -> all about phone. It looks like this:

G510-200V100R001C00B178

Now type that exact code in google and hopefully you'll find the firmware you need. Like I said I found it at a chinese forum (if i spoke chinese probably I would find it myself) :D so google is your friend. My phone is installing right now (hopefully to the end of course). Now after trying all kinds of firmware (including couple versions of MIUI downloaded from a chinese forum) and thinking that i bricked it many times finally I'm begining to think that this phone can always be ressurected from the death :). Thank you all nad I hope this will be helpfull to all that are facing same problems.

  • 0

#10
hamidmaster

hamidmaster

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:g510-0200
Hi, I'm from Iran and I have exactly the above problem if there is a possibility of a link to download the Chinese forum, please let me

  • 0

#11
Souldefiler

Souldefiler

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:Huawei G510

Guys I think I fugured it out :P ... none of the firmwares worked with me because you have to find the exact firmware for yr phone. You can find it in the settings menu -> all about phone. It looks like this:

Now type that exact code in google and hopefully you'll find the firmware you need. Like I said I found it at a chinese forum (if i spoke chinese probably I would find it myself) :D so google is your friend. My phone is installing right now (hopefully to the end of course). Now after trying all kinds of firmware (including couple versions of MIUI downloaded from a chinese forum) and thinking that i bricked it many times finally I'm begining to think that this phone can always be ressurected from the death :). Thank you all nad I hope this will be helpfull to all that are facing same problems.


Man where did you find that link i need that rom so bad. i have same problem. Pls give me a link if you can.

  • 0

#12
nesho82

nesho82

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Huawei Ascend G510-0200
  • Twitter:@mojsoneso

Where did you find that link i need that rom so bad. I have same problem. Pleas help me and guys before me. Thanks


  • 0

#13
aghahadi

aghahadi

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:b7300

hi man why did you leave your thread

i have the same problem please give me the link of that rom or at least that site.


  • 0

#14
chasser

chasser

    Newbie

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Devices:G510-200 (LewaOS 5)

  • 1




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users