Jump to content


Photo

Help needed on es file explorer

- - - - -

  • Please log in to reply
8 replies to this topic

#1
Roger Barnett

Roger Barnett

    Regular

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Devices:Pulse 8220, OSD
I want to access my network at home and outside so I installed es file explorer v3.0.4. I remember having issues with a previous version but after googling I managed to set up my laptop and hard drive as visible from the osd.
The new version seems very limited ; it says "use add new server" but I can't find that option.
Can anyone help, or point me in the right direction?

  • 0

#2
DaveSimonH

DaveSimonH

    Regular

  • Members
  • PipPip
  • 85 posts
  • Gender:Male
  • Location:Scotland, UK
  • Devices:Orange San Diego
Hopefully your laptop and hard drive directories are still set to visible in w7, OSX etc. For guide to enabling folder sharing in windows7 look below for blue text

Open ES File Explorer then hit the menu button on your phone (or the Globe/Phone icon in top left). Now click Network, then LAN which will open the LAN window***.
On the bottom bar hit New, then type in something like;

Posted Image

Figures will vary depending on the IP address range of your router. If you haven't changed it I think the default range is 192.168.1.100
I have only enabled access to my Videos directory on my D: Media drive, so is set to 192.168.1.100/Videos

I only have read access to my Videos folder so I set it to anonymous, but you could easily have a username and password if you granted write/read permission to the directory.

***You can change which windows appear when you start up by pressing phone menu button, Settings, then under Tools Settings click Window Settings and then Set the Default Windows. Now just tick all the windows you want to appear, press OK and now you can swipe between them.

__________________________


Windows 7 Folder Sharing Short Guide

In Windows 7 navigate to a folder you want to access via ES FIle Explorer, right click and select Share with..., then Specific people...
Now press the drop down box, and select Everyone, then click the Add button. The default permission is read only, you may want to leave it at that unless you want "everyone" having Write/read permissions.
OK so click the Share button (may take few minutes).

Now you will be able to acess the folder via ES FIle Explorer

.

Edited by DaveSimonH, 12 July 2013 - 02:29 AM.

  • 0

#3
Roger Barnett

Roger Barnett

    Regular

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Devices:Pulse 8220, OSD
I tried enabling the windows folder sharing, then scanning the LAN option.
It only comes up with 192.168.0.1, which is my router address; it doesn't see the shared folder(s), which I just enabled 'sharing with everyone'.

Any further ideas?
This is really frustrating because I know I had it working previously (I seem to remember having to supply my windows user / password, but maybe because I wasn't 'anonomous')

  • 0

#4
DaveSimonH

DaveSimonH

    Regular

  • Members
  • PipPip
  • 85 posts
  • Gender:Male
  • Location:Scotland, UK
  • Devices:Orange San Diego
Couple of things you could try.

1.First you could re-do the folder sharing process (on your laptop).
2.If that doesn't fix it you could try accessing your router by typing the IP address into a browser window, and look under DHCP Server Setting (on default page that loads if you are using a Linksys router, under LAN Settings on a Belkin router). Is it enabled? What is the start IP address, mine is 192.168.8.100 which is the server I'm connecting to via ES File Explorer.

.

Edited by DaveSimonH, 16 July 2013 - 11:14 PM.

  • 0

#5
Roger Barnett

Roger Barnett

    Regular

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Devices:Pulse 8220, OSD
I should have added that my laptop is set up with a static ip address. Could this make a difference?

  • 0

#6
DaveSimonH

DaveSimonH

    Regular

  • Members
  • PipPip
  • 85 posts
  • Gender:Male
  • Location:Scotland, UK
  • Devices:Orange San Diego
Try running cmd.exe, then typing in;
ipconfig /all

Under, "Wireless LAN adapter Wireless Network Connection:", what is the "IPv4 Address"?
Try that ip address.

  • 0

#7
Roger Barnett

Roger Barnett

    Regular

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Devices:Pulse 8220, OSD
I tried that; the IPv4 address was 192.168.0.7 (the static address as set by me).
I then tried to connect to 192.168.0.7 in the 'LAN' section, entering no username and password and checking the 'anonomous' box.
I got "error cannot find the server"
Also tried smb://192.168.0.7 which didn't work.

If I were to enter a username and password, what would that be ? My windows username and password?

Edited by Roger Barnett, 25 July 2013 - 02:18 PM.

  • 0

#8
Roger Barnett

Roger Barnett

    Regular

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Devices:Pulse 8220, OSD
I've made it work, by turning off windows firewall i can see my laptop :D
But this is obviously not ideal. Any ideas on how to make it work whilst the firewall is still on?

Edited by Roger Barnett, 25 July 2013 - 10:18 PM.

  • 0

#9
DaveSimonH

DaveSimonH

    Regular

  • Members
  • PipPip
  • 85 posts
  • Gender:Male
  • Location:Scotland, UK
  • Devices:Orange San Diego
You could maybe try adding an IP address exception to the windows firewall, adding your phones ip address or the range of ip addresses that your router uses (shortcut you may find useful - wf.msc).
The firewall blocking it didn't occur to me, the windows firewall doesn't block ES File Explorer connecting to my w7 laptop.

Edited by DaveSimonH, 27 July 2013 - 10:56 PM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users