Jump to content


Photo

Incoming callers not recognised


  • Please log in to reply
21 replies to this topic

#1
Dan Mullen

Dan Mullen

    Addict

  • Members
  • PipPipPipPipPip
  • 605 posts
  • Gender:Male
  • Location:Durham, UK
  • Interests:Football (Sunderland AFC), snooker, tennis and darts. Also, PS3 games, creating dynamic websites and watching films.
  • Devices:Nexus 5, Cube U30GT II
  • Twitter:@danmullen
I've got an issue with incoming calls. Even if the number is in my contact list, it's coming up with just the number - it doesn't match the contact.

All of my contact numbers are formatted using the full international format, e.g. +447777123456. When I receive a call, it just comes up as 07777123456 and doesn't match any contacts with that number. If I dial out to a contact, it comes up correctly with their name.

My contact list has been formatted that way since I started using Gmail years and years ago! Every phone I've had and every ROM has worked fine, but there's obviously something up with the Vowney firmware. Any ideas please?

  • 0
Dan Mullen » http://www.mullen.org.uk
Stunshot - Web Hosting and Development » http://www.stunshot.com
Simply Dial - Cheap International Calls » http://www.simply-dial.co.uk

#2
Rico_89

Rico_89

    Addict

  • Members
  • PipPipPipPipPip
  • 767 posts
  • Gender:Male
  • Location:London, UK
  • Devices:Huawei Ascend G300, Vowney V5.
  • Twitter:@Rico_89_
If anyone knows of a good solution to this issue then I would be interested to know too.

What I did was to just add a second number to everyone in my contacts list and leave out the international +44 prefix. That way I get caller id for incoming calls and the international numbers to dial out with.

  • 0

#3
Dan Mullen

Dan Mullen

    Addict

  • Members
  • PipPipPipPipPip
  • 605 posts
  • Gender:Male
  • Location:Durham, UK
  • Interests:Football (Sunderland AFC), snooker, tennis and darts. Also, PS3 games, creating dynamic websites and watching films.
  • Devices:Nexus 5, Cube U30GT II
  • Twitter:@danmullen
I wonder if it's something to do with the system country? What I mean is, there are various places where it's obvious the phone is set with a US system locale, most notably in date and time settings. The date format defaults to US style, even when it's set to "regional default". If the dialler thinks we're in the US, maybe that's what's causing it to not match numbers that come in without the +44 prefix?

  • 0
Dan Mullen » http://www.mullen.org.uk
Stunshot - Web Hosting and Development » http://www.stunshot.com
Simply Dial - Cheap International Calls » http://www.simply-dial.co.uk

#4
bryfly

bryfly

    Addict

  • Members
  • PipPipPipPipPip
  • 613 posts
  • Gender:Male
  • Location:portsmouth
  • Devices:coolpad F1 8297w & redmi note2
Both of our V5 phones had the same problem and yes the +44 causes it for some reason, we went though our google contact lists and removed the +44 and callers identify ok since........

  • 0

#5
Dan Mullen

Dan Mullen

    Addict

  • Members
  • PipPipPipPipPip
  • 605 posts
  • Gender:Male
  • Location:Durham, UK
  • Interests:Football (Sunderland AFC), snooker, tennis and darts. Also, PS3 games, creating dynamic websites and watching films.
  • Devices:Nexus 5, Cube U30GT II
  • Twitter:@danmullen

Both of our V5 phones had the same problem and yes the +44 causes it for some reason, we went though our google contact lists and removed the +44 and callers identify ok since........

It's such an annoying problem! My contacts have been stored in that format since around 2004! Last night I tried changing the system locale - I downloaded an app and it said it was set to English (US), so I changed it to English (UK), but it hasn't fixed it. I also changed the country and region in the build.prop to en_GB, but again no luck. SMS work fine, so the incoming sender is identified fine with the +44 prefix. I'm reluctant to change my 900+ contacts as it shouldn't be a problem, plus I like them in the international format for when I travel.

  • 0
Dan Mullen » http://www.mullen.org.uk
Stunshot - Web Hosting and Development » http://www.stunshot.com
Simply Dial - Cheap International Calls » http://www.simply-dial.co.uk

#6
bryfly

bryfly

    Addict

  • Members
  • PipPipPipPipPip
  • 613 posts
  • Gender:Male
  • Location:portsmouth
  • Devices:coolpad F1 8297w & redmi note2

It's such an annoying problem! My contacts have been stored in that format since around 2004! Last night I tried changing the system locale - I downloaded an app and it said it was set to English (US), so I changed it to English (UK), but it hasn't fixed it. I also changed the country and region in the build.prop to en_GB, but again no luck. SMS work fine, so the incoming sender is identified fine with the +44 prefix. I'm reluctant to change my 900+ contacts as it shouldn't be a problem, plus I like them in the international format for when I travel.


Not sure what it does but if you press the phone symbol, then bottom left menu button, then settings, then other settings, there is something called "international dialling assist" you can select on or off, wonder if that affects it.

  • 0

#7
Rico_89

Rico_89

    Addict

  • Members
  • PipPipPipPipPip
  • 767 posts
  • Gender:Male
  • Location:London, UK
  • Devices:Huawei Ascend G300, Vowney V5.
  • Twitter:@Rico_89_

It's such an annoying problem! My contacts have been stored in that format since around 2004! Last night I tried changing the system locale - I downloaded an app and it said it was set to English (US), so I changed it to English (UK), but it hasn't fixed it. I also changed the country and region in the build.prop to en_GB, but again no luck. SMS work fine, so the incoming sender is identified fine with the +44 prefix. I'm reluctant to change my 900+ contacts as it shouldn't be a problem, plus I like them in the international format for when I travel.


Wow I don't even think I know fifty people lol..

One solution might be to use a third party caller id app, like this one: https://play.google.....callerid&hl=en . Now I haven't tried it or anything and there might be better caller ID apps for android, in the app store, but the one I posted just came up in a random search so I'm using it as an example.

Here's another one that looks pretty good: https://play.google.....callerid&hl=en

Edited by Rico_89, 29 July 2013 - 07:36 PM.

  • 0

#8
nsmacd1

nsmacd1

    Diehard

  • Members
  • PipPipPipPip
  • 346 posts
  • Gender:Male
  • Location:Croydon
  • Devices:Vowney (Verne) V5 & G300
I have the opposite problem - All my contact numbers are 077... and all incoming calls and texts are showing up as +44 so are not recognised

Anyone found a way round this yet apart from editing and adding a +44 to all existing contacts?

I am on the stock ROM which came with the phone, rooted and Playstore installed (by Merimobiles not me!)

Edited by nsmacd1, 31 July 2013 - 02:21 AM.

  • 0
Currently using:-

Posted Image

#9
Dan Mullen

Dan Mullen

    Addict

  • Members
  • PipPipPipPipPip
  • 605 posts
  • Gender:Male
  • Location:Durham, UK
  • Interests:Football (Sunderland AFC), snooker, tennis and darts. Also, PS3 games, creating dynamic websites and watching films.
  • Devices:Nexus 5, Cube U30GT II
  • Twitter:@danmullen

I have the opposite problem - All my contact numbers are 077... and all incoming calls and texts are showing up as +44 so are not recognised

Anyone found a way round this yet apart from editing and adding a +44 to all existing contacts?

I am on the stock ROM which came with the phone, rooted and Playstore installed (by Merimobiles not me!)

I ended up downloading an app called Number Fixer (https://play.google....pps.numberfixer) and using it to remove the +44 from all my contacts and replace it with a zero. This means the dialler is working correctly but my incoming and outgoing text messages don't appear in the same conversations, i.e. when I text out, it goes to the '0' number, but incoming texts and replies come into a '+44' number, so they appear in a different thread :/

  • 1
Dan Mullen » http://www.mullen.org.uk
Stunshot - Web Hosting and Development » http://www.stunshot.com
Simply Dial - Cheap International Calls » http://www.simply-dial.co.uk

#10
nsmacd1

nsmacd1

    Diehard

  • Members
  • PipPipPipPip
  • 346 posts
  • Gender:Male
  • Location:Croydon
  • Devices:Vowney (Verne) V5 & G300

I ended up downloading an app called Number Fixer (https://play.google....pps.numberfixer) and using it to remove the +44 from all my contacts and replace it with a zero. This means the dialler is working correctly but my incoming and outgoing text messages don't appear in the same conversations, i.e. when I text out, it goes to the '0' number, but incoming texts and replies come into a '+44' number, so they appear in a different thread :/


Does it work the other way round though? ie Can it add a +44 to all contacts instead of the '0'?

  • 0
Currently using:-

Posted Image

#11
Dan Mullen

Dan Mullen

    Addict

  • Members
  • PipPipPipPipPip
  • 605 posts
  • Gender:Male
  • Location:Durham, UK
  • Interests:Football (Sunderland AFC), snooker, tennis and darts. Also, PS3 games, creating dynamic websites and watching films.
  • Devices:Nexus 5, Cube U30GT II
  • Twitter:@danmullen

Does it work the other way round though? ie Can it add a +44 to all contacts instead of the '0'?

Yes, it can :)

  • 1
Dan Mullen » http://www.mullen.org.uk
Stunshot - Web Hosting and Development » http://www.stunshot.com
Simply Dial - Cheap International Calls » http://www.simply-dial.co.uk

#12
nsmacd1

nsmacd1

    Diehard

  • Members
  • PipPipPipPip
  • 346 posts
  • Gender:Male
  • Location:Croydon
  • Devices:Vowney (Verne) V5 & G300

Yes, it can :)


Thanks for the tip - Have given it a go and all contacts are now +44077.... Shouldn't it be without the '0' at the start?

Ignore me - After a bit of playing about I've worked out how to remove then re-add! - Thanks again!

Edited by nsmacd1, 31 July 2013 - 11:48 PM.

  • 0
Currently using:-

Posted Image

#13
Dan Mullen

Dan Mullen

    Addict

  • Members
  • PipPipPipPipPip
  • 605 posts
  • Gender:Male
  • Location:Durham, UK
  • Interests:Football (Sunderland AFC), snooker, tennis and darts. Also, PS3 games, creating dynamic websites and watching films.
  • Devices:Nexus 5, Cube U30GT II
  • Twitter:@danmullen

Thanks for the tip - Have given it a go and all contacts are now +44077.... Shouldn't it be without the '0' at the start?

Ignore me - After a bit of playing about I've worked out how to remove then re-add! - Thanks again!

Glad you got it sorted :)

  • 0
Dan Mullen » http://www.mullen.org.uk
Stunshot - Web Hosting and Development » http://www.stunshot.com
Simply Dial - Cheap International Calls » http://www.simply-dial.co.uk

#14
Northstandhero

Northstandhero

    Regular

  • Members
  • PipPip
  • 118 posts
If anyone's still struggling with this problem there's a build.prop hack in Tillaz's Custom Rom for it.

  • 0

#15
Rico_89

Rico_89

    Addict

  • Members
  • PipPipPipPipPip
  • 767 posts
  • Gender:Male
  • Location:London, UK
  • Devices:Huawei Ascend G300, Vowney V5.
  • Twitter:@Rico_89_

If anyone's still struggling with this problem there's a build.prop hack in Tillaz's Custom Rom for it.


What biuld prop entries is he using? Maybe we can put them in the ROMs we all use.

  • 0

#16
Northstandhero

Northstandhero

    Regular

  • Members
  • PipPip
  • 118 posts
Not Sure, it's in the Xposed Framework under the Gravity Box settings and then under General Fixes.

  • 0

#17
Dan Mullen

Dan Mullen

    Addict

  • Members
  • PipPipPipPipPip
  • 605 posts
  • Gender:Male
  • Location:Durham, UK
  • Interests:Football (Sunderland AFC), snooker, tennis and darts. Also, PS3 games, creating dynamic websites and watching films.
  • Devices:Nexus 5, Cube U30GT II
  • Twitter:@danmullen

Not Sure, it's in the Xposed Framework under the Gravity Box settings and then under General Fixes.

If it's:
ro.phone.min_match=9
then I can confirm it doesn't work.

  • 0
Dan Mullen » http://www.mullen.org.uk
Stunshot - Web Hosting and Development » http://www.stunshot.com
Simply Dial - Cheap International Calls » http://www.simply-dial.co.uk

#18
pelelademadera

pelelademadera

    Newbie

  • Members
  • Pip
  • 48 posts
  • Devices:vowney v5
  • Twitter:@pl4dox
someone solved it? I have separated sms, and some phones come with +54 (argentina) and some without it.... I think is cause of different company contract

  • 0

#19
Dan Mullen

Dan Mullen

    Addict

  • Members
  • PipPipPipPipPip
  • 605 posts
  • Gender:Male
  • Location:Durham, UK
  • Interests:Football (Sunderland AFC), snooker, tennis and darts. Also, PS3 games, creating dynamic websites and watching films.
  • Devices:Nexus 5, Cube U30GT II
  • Twitter:@danmullen
I can confirm that with tillaz custom ROM, using the GravityBox settings you can switch on a tweak that fixes this problem for both caller ID and SMS - happy days :)

  • 0
Dan Mullen » http://www.mullen.org.uk
Stunshot - Web Hosting and Development » http://www.stunshot.com
Simply Dial - Cheap International Calls » http://www.simply-dial.co.uk

#20
pelelademadera

pelelademadera

    Newbie

  • Members
  • Pip
  • 48 posts
  • Devices:vowney v5
  • Twitter:@pl4dox
But in stock rom???

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users