Jump to content


Photo

Xiaocai X9 - Updated. Root info. Benchmarks etc.

* * * * * 3 votes

280 replies to this topic

#261
Nhede

Nhede

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:xiaocai x9

On first time running the image I need to change provider settings (mobile networks - names accespoints) . the server verification type to "pap and chap" and back to none again, before it connects. But this is to get the 3g connection.

I needed to do this on other rom's / modem.img as well.

 

The newer modem.img I used was to fix problems with O2 provider users, according to RiseAgainst

 

If the above doesn't work, can you try the old modem.img

to see if it maybe wasn't such a good idea to change to the newer one.

 

original modem.img in /system/etc/firmware

 

I can only test with vodafone provider, so more input on this issue is welcome


Edited by Nhede, 15 December 2013 - 11:35 AM.

  • 0

#262
daisyhayseed

daisyhayseed

    Newbie

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:UK
  • Devices:Xiaocai X9, Vido Mini One
Hi Nhede

I'm using your ROM and I haven't encountered any loss of network following a reboot. Things seem to be working OK for me. For reference, I'm on the Three network.

Cheers for your contribution to the community.

Daz

  • 0

#263
Hurders

Hurders

    Newbie

  • Members
  • Pip
  • 26 posts
Great ROM Nhede. On the lock screen image, with the original W100 port if you used Xposed Framework with Gravity Box it used whatever wallpaper you had set as the lock screen background. This doesn't work anymore, is there an easier way to match lockscreen background to wallpaper without editing system files etc?

  • 0

#264
kf123

kf123

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Devices:Xiaocai X9

Yes install the MI Locker from Store!


  • 0

#265
Nhede

Nhede

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:xiaocai x9

The easy way is to have a locker app installed. Mi locker / holo locker.

after you set settings->security->screen lock to none, this is to prevent the system locker from showing before the installed lockscreen app is loaded.

 

Thl hardcoded the original lockscreen all over android.policy.jar

atm there are two places in KeyguardViewManager.smali where the wallpaper is hardcoded to the resource (search for 0x1080614)

If I remove these, the lockscreen is just black. And I didn't find where the wallpaper should be normally set yet.

Also the gallery setting the lockscreen wallpaper option was removed by Thl.

So it would take some time to fix all these things.

Maybe in the future I will look into it again. But for now I wanted to share what I allready had :)


  • 0

#266
Hurders

Hurders

    Newbie

  • Members
  • Pip
  • 26 posts

Yes install the MI Locker from Store!

 

The easy way is to have a locker app installed. Mi locker / holo locker.

after you set settings->security->screen lock to none, this is to prevent the system locker from showing before the installed lockscreen app is loaded.

 

Thl hardcoded the original lockscreen all over android.policy.jar

atm there are two places in KeyguardViewManager.smali where the wallpaper is hardcoded to the resource (search for 0x1080614)

If I remove these, the lockscreen is just black. And I didn't find where the wallpaper should be normally set yet.

Also the gallery setting the lockscreen wallpaper option was removed by Thl.

So it would take some time to fix all these things.

Maybe in the future I will look into it again. But for now I wanted to share what I allready had :)

 

Unfortunately, as with all these 3rd party lockscreen apps, they don't really work properly if you use a security pattern to unlock as you end up unlocking via a swipe on the app then you have to unlock with security pattern via the standard android lockscreen which still has default background rather than your wallpaper.

 

Nhede, as I said in previous post, the original THL100 port would allow XposedFramework/GravityBox to use the current wallpaper as the lockscreen background even using a security pattern where as your rom doesn't let Gravity Box do this anymore? Any reason why that could be?

 

Really like the rom otherwise, no THL boot logo and increased speaker volume is really good.


  • 0

#267
Nhede

Nhede

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:xiaocai x9

I will check if I can see why it does not work. I think XposedFramework/GravityBox changes framework-res.apk layout stuff internally.

but because mediatek related roms, are based on mediatek sdk stuff that have a different implementation for the lockscreen, its all a bit messy.

 

actually andoid lockscreen and mediatek lockscreen co-exist in de sources, and look the same. So I think gravitybox is just a bit confused with some of the layout xml files I copied from the Caios and Sony rom, to fix centering of the glowpad (sliding lock thing).

 

Edit:

I just tested latest xposedframework with latest gravitybox,

de.robv.android.xposed.installer_v25_36cbbc.apk (put in /system/app)

gravitybox JB 2.8.2 installed using xposedframework module downloads

 

needed to enable xposed, reboot, enable gravitybox, reboot again.

 

Then changing the wallpaper for lockscreen in gravitybox worked, on swipe, pin and pattern.

 

so I don't know what you are doing different, but its working here.


Edited by Nhede, 19 December 2013 - 01:56 PM.

  • 0

#268
Hurders

Hurders

    Newbie

  • Members
  • Pip
  • 26 posts

I will check if I can see why it does not work. I think XposedFramework/GravityBox changes framework-res.apk layout stuff internally.

but because mediatek related roms, are based on mediatek sdk stuff that have a different implementation for the lockscreen, its all a bit messy.

 

actually andoid lockscreen and mediatek lockscreen co-exist in de sources, and look the same. So I think gravitybox is just a bit confused with some of the layout xml files I copied from the Caios and Sony rom, to fix centering of the glowpad (sliding lock thing).

 

Edit:

I just tested latest xposedframework with latest gravitybox,

de.robv.android.xposed.installer_v25_36cbbc.apk (put in /system/app)

gravitybox JB 2.8.2 installed using xposedframework module downloads

 

needed to enable xposed, reboot, enable gravitybox, reboot again.

 

Then changing the wallpaper for lockscreen in gravitybox worked, on swipe, pin and pattern.

 

so I don't know what you are doing different, but its working here.

 

Nhede, I tried again, did a full wipe and installed your rom again with latest xposedframework in system/app. Ran/installed xposed, rebooted, installed gravity box (jb) via module downloader, enabled/rebooted. No joy, lockscreen image is still the default jellybean one. If you change the gravitybox settings to use a custom image then that seems to work (but not a proper solution) but if you have the setting as default background it always goes back to the standard jellybean background on the lockscreen rather than whatever you have as your current wallpaper.


  • 0

#269
sttcharl

sttcharl

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:Xiaocai X9

I am using the THL W100 Rom and cannot figure out how to fix a problem I am having with it.  While the phone is charging the screen stays lit, will not go to sleep.  When it is fully charged, the screen goes to sleep.  Under Developer Options, Stay Awake is unchecked.  Anyone have an idea what is causing this?


  • 0

#270
Degurney

Degurney

    Regular

  • Members
  • PipPip
  • 99 posts
  • Gender:Male
  • Devices:Xiaocai X9
  • Twitter:@degurney
Hi all....
Will this phone work in the USA?. I'm moving there in June... Want to know if I need to sell them beforehand...

Thanks


Sent from my iPad using Tapatalk HD

  • 0

#271
sttcharl

sttcharl

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:Xiaocai X9

Hi all....
Will this phone work in the USA?. I'm moving there in June... Want to know if I need to sell them beforehand...

Thanks


Sent from my iPad using Tapatalk HD

 

Yes it works in the US.


  • 0

#272
woofleboofle

woofleboofle

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:XiaoCai x9s

Hey everyone,

Just got my xiaocai x9s and rooted and attempted to flash a new rom onto it. I must have done it incorrectly and now it won't boot. It gets stuck on the XiaoCai logo and won't go any further.

Is there a way to enter recovery mode on the x9?? eg. holding power button and volume button. I haven't been able to find anything searching...
Otherwise it seems my phone is bricked :(
 


  • 0

#273
woofleboofle

woofleboofle

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:XiaoCai x9s

So I've tried every possible combination i can think of.
hold volume - before switching on power.
hold volume + before switching on power.
hold volume - and + and power!
hold volum -/+ then power, then release power and continue holding volume...
holding phone tightly in my hand until i can almost feel the screen about to break, and then shouting cursing words.
nothing has worked so far... well.. the last one i felt was getting somewhere.

I waited 6 weeks for this phone. can't believe it :(
 


  • 0

#274
Degurney

Degurney

    Regular

  • Members
  • PipPip
  • 99 posts
  • Gender:Male
  • Devices:Xiaocai X9
  • Twitter:@degurney
worked it out yet woofle?

  • 0

#275
woofleboofle

woofleboofle

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:XiaoCai x9s

No unfortunately now the battery has run out of charge, and it won't charge in the state that it's in.
Which means I really can't do anything.

Only possibility would be to take it to a service/repair center. But in Australia... that's going to cost me about as much as buying another one.

So, I had to order another one. Really can't believe it. Waited 6 Weeks... and i broke it within an 2 hours. Hmm.... breathe slowly. breathe slowly....

Also, for those wanting to root a x9s (MTK 6582, not 6589), I found using root genie useful (http://www.sjroot.com/). Worked very smoothly. Checked with root checker app, no issues. I could not get the moto auto chopper method listed in this forum to work for the 6582.
As far as flashing a new rom.... again, the method on this forum won't work on the x9s. You could try uncle mtk tools with a different image. Didn't try that, instead I opted to use mtk droid tools... but yeah, I won't give any more advice there!! Unless you also want to brick your phone :S 
Just make sure you read a lot more than I did.....

When i get my new one, I will charge the battery and see if maybe on a full charge i can enter the recovery mode. (In case anyone else has had this issue).


 


  • 0

#276
woofleboofle

woofleboofle

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:XiaoCai x9s

Sorry, I put the chinese version of root genius there. There is an english version, here: http://www.shuame.com/en/root/

Just connect your phone to computer (debugging on). Run the genie program on PC, it will connect. Then click "Root", and it's done.


  • 0

#277
Degurney

Degurney

    Regular

  • Members
  • PipPip
  • 99 posts
  • Gender:Male
  • Devices:Xiaocai X9
  • Twitter:@degurney
Woofie: did you manage to fix your problem? A friend of mine has bought an X9+

I'm guessing I can root it with with root genius. What about Cwm? As I need to get play store on there....

  • 0

#278
notcosi

notcosi

    Newbie

  • Members
  • Pip
  • 25 posts
  • Devices:orang san francisco

Woofie: did you manage to fix your problem? A friend of mine has bought an X9+

I'm guessing I can root it with with root genius. What about Cwm? As I need to get play store on there....

Hi

You will find recovery here along with miui rom

http://www.needrom.c...iaocai-x9-miui/


  • 0

#279
Degurney

Degurney

    Regular

  • Members
  • PipPip
  • 99 posts
  • Gender:Male
  • Devices:Xiaocai X9
  • Twitter:@degurney

Hi

You will find recovery here along with miui rom

http://www.needrom.c...iaocai-x9-miui/

Hi.. is this particularly for the X9+ ??  also... it`s in Chinese...I extracted the files... but I`m not 100% sure this recovery image is for the X9+ because I cannot find one website that has recovery info for the X9+ ( not even for the X9S ( same chipset ))

 

thanks 


  • 0

#280
Keies

Keies

    Newbie

  • Members
  • Pip
  • 1 posts

Hi,
 

I used the guide for rooting x9 and it worked perfectly, but after that it fell and broke. Then i bought an X9S... does anybody know if the guide works for this "s" model too?

Another issue: vibration does not always work. Now and then the phone stops vibrating. Could it be a SO related problem? Or is it just hardware related?

Thanks (and sorry for my english)


  • 0




1 user(s) are reading this topic

1 members, 0 guests, 0 anonymous users


    kelebek