Jump to content


Photo

Zte Blade III is frozen on the green android logo

- - - - -

  • Please log in to reply
1 reply to this topic

#1
estemiera

estemiera

    Newbie

  • Members
  • Pip
  • 1 posts

It won't turn off, it won't turn on.  I took out the battery, waited, plugged the phone in, and the green android popped up without me even turning the phone on.  I tried turning it on while pushing the down volume, and nothing happens, I tried taking out the sd card and nothing happened, I tried taking out the sim card and nothing happened.

When it froze I was using the buzzfeed app.  I'm completely tech unsavvy and have never rooted it or done anything that involves technical fiddling.

Any ideas?


  • 0

#2
plantroon

plantroon

    Enthusiast

  • Members
  • PipPipPip
  • 178 posts
  • Gender:Male
  • Interests:IT, gaming
  • Devices:ZTE Brick III
  • Twitter:@@plantroon

Let it charge for like 10 minutes, unplug it, wait 30 seconds, power it on and describe what happens then ...


  • 0
I wish Canonical made some good work and Ubuntu Touch got optimized&running on any android phone....I wouldn't mind having android apps runtime as well :D




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users