Jump to content


Photo

Problem with Hudl being recognised in Windows 8.1. Need driver. :-(

- - - - -

  • Please log in to reply
20 replies to this topic

#1
TescoHudl

TescoHudl

    Regular

  • Members
  • PipPip
  • 143 posts
  • Gender:Male
  • Interests:Cars, Computers, Gaming, Phones, Photography
  • Devices:OnePlus One, Moto G, Hudl

Just been trying to flash the new ROM posted by hal2710, but the Hudl isn't being recognised by Windows in flashing mode any more... :( It was working okay a couple of weeks ago, so i think the issue is being caused by the recent upgrade to Windows 8.1. The Hudl appears as it should in Windows when it's switched on; the problem only occurs in flashing mode. Does anyone have the correct driver i need to install?

 

ynfs.png

 

Any help/suggestions would be most appreciated. :)


  • 0

#2
Ian...

Ian...

    Newbie

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Devices:Hudl, Galaxy note

I could not flash my Hudl initially. I spent some time trying to flash using RKTools17 but device manager refused to work with the provided drivers. Eventually out of desperation I plugged the tablet into another usb socket and the drivers were detected. I am using Windows 7.


  • 0

#3
TescoHudl

TescoHudl

    Regular

  • Members
  • PipPip
  • 143 posts
  • Gender:Male
  • Interests:Cars, Computers, Gaming, Phones, Photography
  • Devices:OnePlus One, Moto G, Hudl

I could not flash my Hudl initially. I spent some time trying to flash using RKTools17 but device manager refused to work with the provided drivers. Eventually out of desperation I plugged the tablet into another usb socket and the drivers were detected. I am using Windows 7.

 

I tried using another USB socket like you said, but the problem still remains; it just shows this message is the lower right hand corner:

 

h01s.png


  • 0

#4
Ian...

Ian...

    Newbie

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Devices:Hudl, Galaxy note

Weird. That is the message I got when using the wrong usb port.

Have you tried all of the ports on your PC. I changed my existing devices around and plugged the Hudl into the first port. 


  • 0

#5
TescoHudl

TescoHudl

    Regular

  • Members
  • PipPip
  • 143 posts
  • Gender:Male
  • Interests:Cars, Computers, Gaming, Phones, Photography
  • Devices:OnePlus One, Moto G, Hudl

Weird. That is the message I got when using the wrong usb port.

Have you tried all of the ports on your PC. I changed my existing devices around and plugged the Hudl into the first port. 

 

I have tried to get it working in both USB 2.0 ports, and also the USB 3.0 port. Keep getting the same message with them all.  :(

 

EDIT: If i attempt to update the driver, with the Google USB driver, like so:

 

ytv3.png

 

It tells me this:

 

2zot.png

 

I'm beginning to hate my Hudl....

 

I was actually going to go ahead and buy a Nexus 5 on release date (November 1st); but if i can't get the drivers to work on my computer, i may have to reconsider and get an iPhone 5 instead!! ;) (As well as the Hudl i also owned a Nexus 7, and the drivers refused to work with that as well).


Edited by TescoHudl, 29 October 2013 - 03:03 PM.

  • 0

#6
Roy Hudl

Roy Hudl

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:Tesco Hudl, Nexus 7

Try using the RockusbDriver from RKTools folder? 


  • 0

#7
Fisher122

Fisher122

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Galaxy S4 / Tesco Hudl

Try this method:

hudl1.JPG

 

hudl2.JPG

 

hudl3.JPG

 

hudl4.JPG


  • 0

#8
QLF

QLF

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 245 posts
  • Gender:Male
  • Location:The North
  • Devices:Galaxy SII, Advent Vega
Also enable USB debugging and swap to ptp mode instead of mtp. Worked for me!!

  • 0

#9
TescoHudl

TescoHudl

    Regular

  • Members
  • PipPip
  • 143 posts
  • Gender:Male
  • Interests:Cars, Computers, Gaming, Phones, Photography
  • Devices:OnePlus One, Moto G, Hudl

Thank you all for your responses. It is most kind of you guys to try and help me with this problem. :)

 

1. Roy Hudl - I directed the device managers 'Update driver' installer to the location you suggested, but it tells me that the best driver is already installed.

akyV9KA.png

 

WFGm5ze.png

 

2. Fisher122 - I also attempted your method, but the location you've got in the 'Copy manufacturers files from' box, doesn't actually go anywhere. Inside the 'usb_driver' folder i have two folders and three .inf files; i don't know which one to choose? Both of the folders are completely empty.8YGNTKg.png

 

3. QLF - MTP and PTP make no difference unfortunately. USB debugging is on. 


  • 0

#10
TescoHudl

TescoHudl

    Regular

  • Members
  • PipPip
  • 143 posts
  • Gender:Male
  • Interests:Cars, Computers, Gaming, Phones, Photography
  • Devices:OnePlus One, Moto G, Hudl

This is what i'm getting in the device manager:

 

coi6.png

 

And this is the message i get when the device is plugged in for the first time:

 

i2eGR79.png


Edited by TescoHudl, 29 October 2013 - 04:49 PM.

  • 0

#11
menace1944

menace1944

    Newbie

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Aberdeenshire
  • Devices:Tesco Hudl, Samsung Galaxy SII
You could try using the driver from the Archos website. I used this when my hudl wasn't detected and have had no further problems.

  • 0

#12
TescoHudl

TescoHudl

    Regular

  • Members
  • PipPip
  • 143 posts
  • Gender:Male
  • Interests:Cars, Computers, Gaming, Phones, Photography
  • Devices:OnePlus One, Moto G, Hudl

You could try using the driver from the Archos website. I used this when my hudl wasn't detected and have had no further problems.

 

I wasn't sure which driver i needed to download, but i went for this one: http://www.archos.co...pdates_adb.html

 

When attempting to install this driver, it comes up with the same message as before:

 

WFGm5ze.png

 

It seems that the 'USB device descriptor' thingy is preventing the installation of any drivers for the device. I cannot stop the USB device descriptor status being added to the Hudl because it comes up as soon as i plug the device into the laptop.

 

You can bypass the recommendation Windows makes (That the best driver has already been installed) by choosing 'Have disk' on the driver installer, rather than letting Windows search for the driver itself. But if i do this, i get this new message. This error happens on all the drivers i try to install.

 

x9lk.png


Edited by TescoHudl, 29 October 2013 - 05:18 PM.

  • 0

#13
menace1944

menace1944

    Newbie

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Aberdeenshire
  • Devices:Tesco Hudl, Samsung Galaxy SII

I wasn't sure which driver i needed to download, but i went for this one: http://www.archos.co...pdates_adb.html

.

That was the driver I used but I use Windows 7 64bit and had no problem replacing the driver although I did get a message that the existing driver was the best driver.

  • 0

#14
PsYcHoKiLLa

PsYcHoKiLLa

    Addict

  • Members
  • PipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Devices:LG Nexus 4, Tesco Hudl
  • Twitter:@djsubterrain

TescoHudl, I'm getting the exact same as you, I've tried on my PC, laptop and another NetTop, all with Windows 8.1 but no joy.

 

I even went as far as trying installing VirtualBox with Windows 7 as a guest and still couldn't get it installed on there either.

 

Might have to install Windows 7 temporarily on the laptop. Should just be able to do it with one of the digitalriver Windows 7 links, don't even need a serial.


  • 0

#15
TescoHudl

TescoHudl

    Regular

  • Members
  • PipPip
  • 143 posts
  • Gender:Male
  • Interests:Cars, Computers, Gaming, Phones, Photography
  • Devices:OnePlus One, Moto G, Hudl

TescoHudl, I'm getting the exact same as you, I've tried on my PC, laptop and another NetTop, all with Windows 8.1 but no joy.

 

I even went as far as trying installing VirtualBox with Windows 7 as a guest and still couldn't get it installed on there either.

 

Might have to install Windows 7 temporarily on the laptop. Should just be able to do it with one of the digitalriver Windows 7 links, don't even need a serial.

 

It's good to hear that i'm not alone here with this problem... I was convinced that it was just me who was getting this issue. :)

 

I came to the conclusion last night that it is definitely something to do with Windows 8.1. Worst operating system ever... Sure, Windows 8 is good on touchscreen devices, but on a normal computer it's stupid. 99.9% of computers don't have a touchscreen which makes it completely pointless. I've been considering a downgrade back to Windows 7 for quite some time; it wouldn't be too difficult because i have the installation disk here, but i don't want to loose my data on this PC...

 

I borrowed my moms Windows XP SP3 netbook and installed ADB onto that. I tried to install the Archos driver in fastboot mode and it worked flawlessly, proving that this is indeed an issue with Windows 8.1.


  • 0

#16
glossywhite

glossywhite

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,891 posts

It's good to hear that i'm not alone here with this problem... I was convinced that it was just me who was getting this issue. :)

 

I came to the conclusion last night that it is definitely something to do with Windows 8.1. Worst operating system ever... Sure, Windows 8 is good on touchscreen devices, but on a normal computer it's stupid. 99.9% of computers don't have a touchscreen which makes it completely pointless. I've been considering a downgrade back to Windows 7 for quite some time; it wouldn't be too difficult because i have the installation disk here, but i don't want to loose my data on this PC...

 

I borrowed my moms Windows XP SP3 netbook and installed ADB onto that. I tried to install the Archos driver in fastboot mode and it worked flawlessly, proving that this is indeed an issue with Windows 8.1.

 

Microsoft seem completely lost when it comes to touch-based interfaces; they should stick to what they're good at, which isn't touch. As soon as my friend got his new Lenovo laptop with Windows 8 on it, the first thing I did was wipe it off and put Windows 7 on - far better.


Edited by glossywhite, 30 October 2013 - 05:31 PM.

  • 0

#17
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,656 posts
Rockchip USB drivers are currently incompatible with Windows 8.1 due to changes to the USB subsystem. I'm unable to flash any Rockchip based device. If I ever manage to find newer drivers then I'll pop them onto the forum.

  • 0

#18
glossywhite

glossywhite

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,891 posts

Windows 8... LOL. Why would anyone want OR need to use that junk? Windows 7 is perfectly fine, and not at all old... People, re-install Windows 7; problem solved.


  • 0

#19
aramil

aramil

    Newbie

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Devices:S-Galaxy SII (I9100)/Hudl

Rockchip USB drivers are currently incompatible with Windows 8.1 due to changes to the USB subsystem. I'm unable to flash any Rockchip based device. If I ever manage to find newer drivers then I'll pop them onto the forum.


I used the Samsung android USB driver set & ADB(i9100) manually applied in device mgr in windows 8.1 worked first time :) flashes & rooted :-)

  • 0

#20
PsYcHoKiLLa

PsYcHoKiLLa

    Addict

  • Members
  • PipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Devices:LG Nexus 4, Tesco Hudl
  • Twitter:@djsubterrain
Ok. Temporary workaround for windows 8.1 users until we get the drivers. 
  1. Connect your device to the computer in flash mode. The computer will say “USB Device Not Recognized”. Go to Device Manager and you will see your device listed as “Unknown USB Device (Device Descriptor Request Failed)” in “Universal Serial Bus controllers” section
  2. Now in “Universal Serial Bus controllers” section you should also have “USB Root Hub”’s (might be several of them). Click through them and find the one that has “Unknown USB Device (Device Descriptor Request Failed)” in the “Power” tab (should be next to General).
  3. Right click on that “USB Root Hub” and press “Disable”. Now you should have a small arrow pointing down on the USB Root Hub icon and the “Unknown USB Device (Device Descriptor Request Failed)” should have disappeared.
  4.  Now you have to go to the folder where the RKBatchTool is located on your system. Find the file "config.ini" and open it. Find the section where it says:

LOGFLAG=TRUE
#SUPPORTLOWUSB=TRUE时,扫描支持full speed usb设备,默认只支持high speed usb设备
SUPPORTLOWUSB=

Write TRUE next to the second “SUPPORTLOWUSB=”

It should be like this:

LOGFLAG=TRUE
#SUPPORTLOWUSB=TRUE时,扫描支持full speed usb设备,默认只支持high speed usb设备
SUPPORTLOWUSB=TRUE

Save the file and open the RKBatchTool as usual and you should see the green square in Connected Devices.


Now you will be able to flash the rom. The flashing process might take longer than usual but it works. 


P.S: If you have never previously installed Rockchip drivers on your system you might need to do those steps before doing the ones above:
1) First you need do reboot windows with driver signature disabled: configure->change pc settings-> update & recovery -> recovery-> advanced startup -> troubleshoot -> advanced options -> restart -> 7

 

From here


Edited by PsYcHoKiLLa, 03 November 2013 - 12:49 PM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users