Jump to content


Photo

G510 Purple Screen - bricked?


  • Please log in to reply
7 replies to this topic

#1
qwerty?

qwerty?

    Newbie

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Devices:Huawei G510

 Hi, my phone froze a while ago and to restart it I had to remove the battery. Now I am just getting a bright Purple screen 2 seconds after the battery goes in? I cant use power + Vol!

 

I was on ROM http://www.modaco.co...-final-1792013/

 

any ideas on what I can do?

 

Thanks


  • 0

#2
SH3H1

SH3H1

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,264 posts
  • Gender:Male
  • Devices:Xiaomi Redmi 1S
Does your phone's buttons work good???
the pink screen is download mode.
Download official firmware from huawei website.extract it and put the dload folder in root of your memory card.
After that try putting battery in,this should work.

Hope helped

  • 0

#3
kebino

kebino

    Newbie

  • Members
  • Pip
  • 39 posts
  • Devices:Huawei Ascend G510-200
  • Twitter:@kebino3

im experienced it in the past, what i did was just remove the battery, then put it on after 5mins.


  • 0

#4
qwerty?

qwerty?

    Newbie

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Devices:Huawei G510

Does your phone's buttons work good???
the pink screen is download mode.
Download official firmware from huawei website.extract it and put the dload folder in root of your memory card.
After that try putting battery in,this should work.

Hope helped

 

Thanks for the reply.

 

The pink screen appears 2 seconds after I replace the battery, and holding the buttons in makes no difference so I don't know if they work.

 

I'm trying to find the official Firmware for my model the G510 -0100, but can only find the G510-0200 (no NFC) but I am downloading that now to try. I assume you mean place the dload on the SDcard?

 

im experienced it in the past, what i did was just remove the battery, then put it on after 5mins.

 

Thanks, I left the battery out all night, and still getting the purple/pink when I replace it  :angry2:


  • 0

#5
qwerty?

qwerty?

    Newbie

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Devices:Huawei G510

Looks like I have a faulty Power and Vol+ Button. Managed to boot the phone by connecting to power first, then connecting battery. So boots up fine. But I cant use VOL+ or the Power button at all. When the screen turns off the only way to turn it on again is to reconnect the power cable.

 

I guess this phone is dead  

 

and it has now started working again....  weird


Edited by qwerty?, 01 November 2013 - 10:19 AM.

  • 0

#6
SH3H1

SH3H1

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,264 posts
  • Gender:Male
  • Devices:Xiaomi Redmi 1S
As i guessed faulty buttons.....
I hope you will go nicer with buttons from now on....(just joking)

  • 0

#7
qwerty?

qwerty?

    Newbie

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Devices:Huawei G510

As i guessed faulty buttons.....
I hope you will go nicer with buttons from now on....(just joking)

 

Good Call, thanks for that. 

 

It seems to be working fine for now, I was about to attack it with a screwdriver to have a look inside. I did was loosen one screw where the on/off button was and they started to work.


  • 0

#8
SH3H1

SH3H1

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,264 posts
  • Gender:Male
  • Devices:Xiaomi Redmi 1S
Happy to know.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users