Jump to content


Photo

[APP][SHARE] Xposed Framework (for theming, mods and much more):

- - - - -

  • Please log in to reply
65 replies to this topic

#21
bob3450

bob3450

    Newbie

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Devices:Moto G
Did the framework install for everyone? Whenever I try, I get 'Segmentation fault (core dumped)'. [See attachment]

I can't seem to find anything about this.

Attached Files


  • 0

#22
BlueMoonRising

BlueMoonRising

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,520 posts
  • Gender:Male
  • Location:Here, there and everywhere...
  • Devices:Orange San Diego, OSF

Did the framework install for everyone? Whenever I try, I get 'Segmentation fault (core dumped)'. [See attachment]

I can't seem to find anything about this.

I did get some errors come up but it hasn't caused any problems.

I think you used the up to date version, try the 2.3 static 1 version from here http://forum.xda-dev...&postcount=4422

 

You'll need to uninstall all modules and the framework first and then reboot.


  • 1
Whoever exalts himself will be humbled, and whoever humbles himself will be exalted.

Matthew 23:12

#23
bob3450

bob3450

    Newbie

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Devices:Moto G

I did get some errors come up but it hasn't caused any problems.
I think you used the up to date version, try the 2.3 static 1 version from herehttp://forum.xda-dev...&postcount=4422

You'll need to uninstall all modules and the framework first and then reboot.

Thank you for the reply! It's an improvement! Now I get this error: (see screenshot). I am rooted and gave it root access. Any ideas?

Edit: I tried the second version you linked too as well, and that didn't work.

Edit 2: Silly me... Just read the error, and realised I needed yo mount the filesystem! All sorted now! Thank you for the help BlueMoonRising!

Attached Files


Edited by bob3450, 16 November 2013 - 07:02 PM.

  • 0

#24
Hasan217

Hasan217

    Regular

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Devices:Xolo X900

Thank you for the reply! It's an improvement! Now I get this error: (see screenshot). I am rooted and gave it root access. Any ideas? Edit: I tried the second version you linked too as well, and that didn't work. Edit 2: Silly me... Just read the error, and realised I needed yo mount the filesystem! All sorted now! Thank you for the help BlueMoonRising!

 

 

Did the framework install for everyone? Whenever I try, I get 'Segmentation fault (core dumped)'. [See attachment]

I can't seem to find anything about this.

 

First use root explorer and mount system R/W.

Edit: Sorry didn't read your edited post.


Edited by Hasan217, 17 November 2013 - 09:31 AM.

  • 0

#25
Hasan217

Hasan217

    Regular

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Devices:Xolo X900

For all those using Xposed Framework do not install the update 2.4... It breaks xposed and you will have downgrade to version 2.3 static 1 apply it and then update it to 2.3.1. But not beyond the version 2.3.1...


Edited by Hasan217, 01 December 2013 - 12:53 PM.

  • 1

#26
azerty52117

azerty52117

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:orange san diego
Please, help me, I cannot mount the systeme file, I've tried root explorer, many other apps and I've tried with a script, but it dont work ! I always have a error with the mmblkOp file

(And sorry for my bad english...)

Attached Files


Edited by azerty52117, 08 January 2014 - 09:53 PM.

  • 0

#27
bob3450

bob3450

    Newbie

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Devices:Moto G

Please, help me, I cannot mount the systeme file, I've tried root explorer, many other apps and I've tried with a script, but it dont work ! I always have a error with the mmblkOp file

(And sorry for my bad english...)


What version of the Xposed Installer are you using?

  • 0

#28
azerty52117

azerty52117

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:orange san diego
I use xposed installer 2.3 static 1...

  • 0

#29
bob3450

bob3450

    Newbie

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Devices:Moto G

Hmm. I'm not sure then. @BlueMoonRising any ideas?


  • 0

#30
Hasan217

Hasan217

    Regular

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Devices:Xolo X900

Please, help me, I cannot mount the systeme file, I've tried root explorer, many other apps and I've tried with a script, but it dont work ! I always have a error with the mmblkOp file

(And sorry for my bad english...)

It's not an error. It's properly installed. It's ok. Reboot your phone and see and it'll be installed. To test it, you can install any module and give it a try.


Edited by Hasan217, 09 January 2014 - 08:57 AM.

  • 0

#31
xolo x900_2

xolo x900_2

    Regular

  • Members
  • PipPip
  • 106 posts
guys anyone lucky enough to get CRT off animation on their phone??? if so which module???

  • 0

#32
BlueMoonRising

BlueMoonRising

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,520 posts
  • Gender:Male
  • Location:Here, there and everywhere...
  • Devices:Orange San Diego, OSF

Hmm. I'm not sure then. @BlueMoonRising any ideas?

 

Hmm. I'm not sure then. @BlueMoonRising any ideas?

As Hasan217 says, it should actually be fine. He doesn't say whether he's tried it, but I'm guessing not.


  • 0
Whoever exalts himself will be humbled, and whoever humbles himself will be exalted.

Matthew 23:12

#33
azerty52117

azerty52117

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:orange san diego
Hi ! I've rebooted many times, but it don't work, and, xtheme ask me to reinstall xposed or reboot...

  • 0

#34
BlueMoonRising

BlueMoonRising

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,520 posts
  • Gender:Male
  • Location:Here, there and everywhere...
  • Devices:Orange San Diego, OSF

Uninstall all modules and the framework and reboot. Use https://play.google....system&hl=en_GB to mount the system directory writeable and then download (or install) the apk. Reboot and then install the modules you need.


  • 0
Whoever exalts himself will be humbled, and whoever humbles himself will be exalted.

Matthew 23:12

#35
azerty52117

azerty52117

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:orange san diego

I still have this error...

google translate : I think the error has nothing to do with the mounting system in r / w  process 


Edited by azerty52117, 09 January 2014 - 05:34 PM.

  • 0

#36
BlueMoonRising

BlueMoonRising

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,520 posts
  • Gender:Male
  • Location:Here, there and everywhere...
  • Devices:Orange San Diego, OSF

I still have this error...

google translate : I think the error has nothing to do with the mounting system in r / w  process 

I'm confused as to what it is you're trying to do? Is the Xposed framework OK? You mention XTheme? Why?


  • 0
Whoever exalts himself will be humbled, and whoever humbles himself will be exalted.

Matthew 23:12

#37
azerty52117

azerty52117

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:orange san diego
My experiences and my questions :
I try to install xposed, but it fail (mmcblkOp invalid argument). I've mentioned xtheme for test if xposed work, but it doesn't work.
Why ?
Can I do anythings for make it work ?

I speak very bad english... Sorry

  • 0

#38
Hasan217

Hasan217

    Regular

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Devices:Xolo X900

I tested this myself. I get the same message when i install (1st Screenshot). After installing the framework should look something like this (2nd Screenshot).

And for the xtheme engine, if you see the xda forum and search the respective thread, it'll show that others have the same problem with xtheme engine. But if you tap any area on the screen the dialogue box disappears. Then you select any downloaded themes (3rd Screenshot) and apply it (4th Screenshot). After you apply it the it'll ask for a soft reboot (5th Screenshot). Let it reboot. The theme won't work without you applying it.

I'm attaching screenshots just to show that it works.

If all this works for you then it's working properly, otherwise go to the Xposed Freamework thread here and report it: http://forum.xda-dev...d.php?t=1574401

The developer rovo89 complains that people using our devices don't report problems on his thread. That's the reason the latest version does not support our devices. Apparently our phones have a static busybox issue which i don't completely understand. But the developer does not support our devices coz he thinks there are very few users facing this problem. If all users here request him to release a static version of his latest release it'll be more helpful. The developer doesn't know that there is a community here at modaco facing this problem.

Read the original comment and reply here: http://forum.xda-dev...&postcount=6384

Attached Files


  • 0

#39
Hasan217

Hasan217

    Regular

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Devices:Xolo X900

All those trying this framework please take a back up. Our phones don't have custom recovery. So make sure before u take the risk of bricking it. Though I've tried it several times and never has it bricked my device, it's better to be safe than sorry.


  • 0

#40
BlueMoonRising

BlueMoonRising

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,520 posts
  • Gender:Male
  • Location:Here, there and everywhere...
  • Devices:Orange San Diego, OSF

My experiences and my questions :
I try to install xposed, but it fail (mmcblkOp invalid argument). I've mentioned xtheme for test if xposed work, but it doesn't work.
Why ?
Can I do anythings for make it work ?

I speak very bad english... Sorry

Have you tried something that is known to work such as the NFC unlocker http://forum.xda-dev...d.php?t=2478163?


  • 0
Whoever exalts himself will be humbled, and whoever humbles himself will be exalted.

Matthew 23:12




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users