Jump to content


Photo

Root your Moto G - option 1: Superboot


  • Please log in to reply
182 replies to this topic

Poll: Rooting Poll (112 member(s) have cast votes)

How did root go for you?

  1. Rooted OK, Windows (50 votes [44.25%])

    Percentage of vote: 44.25%

  2. Root didn't seem to work, Windows (38 votes [33.63%])

    Percentage of vote: 33.63%

  3. Rooted OK, Mac (4 votes [3.54%])

    Percentage of vote: 3.54%

  4. Root didn't seem to work, Mac (6 votes [5.31%])

    Percentage of vote: 5.31%

  5. Rooted OK, Linux (11 votes [9.73%])

    Percentage of vote: 9.73%

  6. Root didn't seem to work, Linux (4 votes [3.54%])

    Percentage of vote: 3.54%

Vote Guests cannot vote

#21
packers77fr

packers77fr

    Newbie

  • Members
  • Pip
  • 14 posts
  • Gender:Male
  • Devices:Moto G

Dear, 

 

I got same issue like a1Pha. My moto come with retail_FR, can I test your new boot.img too ?


  • 0

#22
TeamKilo

TeamKilo

    Newbie

  • Members
  • Pip
  • 16 posts

Hey guys,

Can someone post a step by step "for dummies" guide to flashing the stock unbranded firmware to over right the UK Tesco firmware?
I've already downloaded the unbranded UK RETAIL firmware and unlocked my phone to use in other networks, that's as far as I've got.
Not looking to root or anything else, just to apply the stock unbranded firmware so that I can get future updates from Motorola and not Tesco.
Thanks.

 

edit. will create new topic, sorry!


Edited by TeamKilo, 27 November 2013 - 09:29 PM.

  • 0

#23
a1Pha

a1Pha

    Newbie

  • Members
  • Pip
  • 19 posts
  • Devices:Motorola Moto G
  • Twitter:@dstoro

Please try replacing the boot.superboot.img with the one in this zip - http://nigella.modac...rboot.a1Pha.zip

P

 

Still the same :-/


  • 0

#24
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,455 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@@paulobrien
TeamKilo, this topic is about root. Please start a new topic.

a1Pha, strange, i'll have a think on it...

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#25
seapoint

seapoint

    Newbie

  • Members
  • Pip
  • 6 posts

@PaulOBrien

If it's any help, I am on Win 8.1 x64 and running your .bat at first didn't work.

 

I just ran an elevated command and manually ran fastboot boot boot.superboot.img  Job done, thanks.


  • 0

#26
terminal 7

terminal 7

    Newbie

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:SW-UK
  • Interests:Phones,pc,mac,linux,android,osx,nothing else !
  • Devices:toomany-today-M-G
  • Twitter:@terminal7

bootloader unlocked as per moto website using oem unlock etc.

but this boot image isnt doing a thing for root, no super user here and in terminal entering su dont work either so no root..

 

mine is tesco brand version but unlocked to any network with an unlock code

 

any ideas ??

 

(( (   ( help )  )   ))


  • 0

#27
a1Pha

a1Pha

    Newbie

  • Members
  • Pip
  • 19 posts
  • Devices:Motorola Moto G
  • Twitter:@dstoro

bootloader unlocked as per moto website using oem unlock etc.

but this boot image isnt doing a thing for root, no super user here and in terminal entering su dont work either so no root..

 

mine is tesco brand version but unlocked to any network with an unlock code

 

any ideas ??

 

(( (   ( help )  )   ))

 

You have the same problem as me. There is no solution yet.


  • 0

#28
shootomanUK

shootomanUK

    Diehard

  • Members
  • PipPipPipPip
  • 455 posts
  • Gender:Male
  • Location:Salford, Manchester
  • Devices:AZ210A , WT19i , DynaTAC 8000X
  • Twitter:@not got one

might be a dumb question but have you tried flashing the retail english rom and  then trying the root method, just to see if it works ?


  • 0

#29
dt_matthews

dt_matthews

    Diehard

  • Members
  • PipPipPipPip
  • 335 posts

 

It boots normally, but no su apk, when i try root checker it says it's not root, and if y a try to install superSU it says binaries are missing.

 

downloading 'boot.img'...
OKAY [  0.281s]
 
It's not too short for an almost 7 Mo file ? why 'boot.img' and not 'boot.superboot.img' ?
 
Thanks

 

 

I appear to have the same - it says it downloads the img to the phone but when it reboots there is no root.

 

anyone got any thoughts?

 

{I'm on a win8 x64 machine}

 

tia


Edited by dt_matthews, 28 November 2013 - 12:03 AM.

  • 0

#30
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404

Well done..  I had a quick look yesterday at it, but I could not get the thing to boot with a new image, I was getting a 'hab check failed' error when I tried to flash an modified boot image..

 

Whats the secret step I missed then? :)


  • 0

#31
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,455 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@@paulobrien
I have a Tesco one arriving today so I'll try the root on that.

Sebastian404, not sure, I didn't do anything different for this device over what I normally do, it's just a regular boot image...

P

  • 1

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#32
c3k

c3k

    Newbie

  • Members
  • Pip
  • 19 posts
  • Devices:hero

device rooted yestarday, thanks

 

on my experience it works on second attemp:

- unlock

- superboot-windows.bat

- reboot

- setup

- *** no root ***

- reboot bootloader

- superboot-windows.bat

- reboot

- root

 

did "fastboot oem lock" works to remove the bootloader alert screen?


  • 0

#33
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,455 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@@paulobrien
You can't relock the bootloader with a modified system image i'm afraid.

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#34
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,455 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@@paulobrien
I added a poll to the topic to track success / failure on different OS'. If you have rooted or have tried to root, please complete the poll.

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#35
a1Pha

a1Pha

    Newbie

  • Members
  • Pip
  • 19 posts
  • Devices:Motorola Moto G
  • Twitter:@dstoro
Paul, I already tried other operating systems (I have tripleboot: OSX, Win8.1, Kali Linux), other cables and switching USB ports (also tried both USB3 and USB2.0), semms not to have any effect..

  • 0

#36
a1Pha

a1Pha

    Newbie

  • Members
  • Pip
  • 19 posts
  • Devices:Motorola Moto G
  • Twitter:@dstoro

might be a dumb question but have you tried flashing the retail english rom and  then trying the root method, just to see if it works ?

 

Just did so, flashed _everything_ (including logo & radio) from retail.en.GB. No effect, besides the fact that the phone shows me "en.GB" in system version now. Still cannot boot Pauls superboot.


  • 0

#37
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,455 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@@paulobrien

Just did so, flashed _everything_ (including logo & radio) from retail.en.GB. No effect, besides the fact that the phone shows me "en.GB" in system version now. Still cannot boot Pauls superboot.

Seriously weird then, technically our phones are identical!!!

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#38
a1Pha

a1Pha

    Newbie

  • Members
  • Pip
  • 19 posts
  • Devices:Motorola Moto G
  • Twitter:@dstoro

Seriously weird then, technically our phones are identical!!!

P

 

Are you able to flash your superboot.img as primary boot partition and boot from it without an error?


  • 0

#39
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,455 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@@paulobrien

Are you able to flash your superboot.img as primary boot partition and boot from it without an error?


I haven't tried...

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#40
t-bon3

t-bon3

    Regular

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Interests:Android
  • Devices:LG G2, Nexus 7

Just did so, flashed _everything_ (including logo & radio) from retail.en.GB. No effect, besides the fact that the phone shows me "en.GB" in system version now. Still cannot boot Pauls superboot.

Just out of interest does doing a full flash re-lock the bootloader?


  • 0




3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users