Jump to content


Photo

Root your Moto G - option 2: Modified recovery


  • Please log in to reply
105 replies to this topic

#61
tinyrodent

tinyrodent

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:Moto G

Ok here is what it looks like when booted normally. There are two items in Device Manager I can see related to the Moto G:

Attached File  adb.png   98.77KB   14 downloadsAttached File  xt1032.png   98.42KB   17 downloads

The "adb devices" command lists the serial number as expected. I unplug the phone, power off, fast boot, choose recovery, and get the recovery menu. Reconnect usb, and choose the first menu item "apply update from sdcard". At this point I hear the USB device hot plug sound effect from Windows and return to Device Manager. Here is what is looks like:

Attached File  unknown.png   87.92KB   14 downloads

But when I try to Update Drivers for this unknown device, no matter what category of driver I look at the message is always "Unable to find any drivers for this device". I tried specifying directly the folder containing the standard Google USB driver which comes with the SDK, but the result is the same.

 

I noticed that if I connect the USB cable while the fastboot menu is displayed, then the Motorola ADB Interface device is listed, but not the other one. And furthermore, even though it's listed in Device Manager, adb does not list it. Restarting adb server does not help.

 

I also tried adb reboot recovery instead of manually fastbooting to the recovery menu, but it still has the same problem with not recognizing the device in this mode. Argh.


  • 0

#62
tinyrodent

tinyrodent

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:Moto G

I finally got it working! I had to edit the Google USB driver inf file as described in this post.


  • 0

#63
mathscott

mathscott

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:Moto G

How to revert back to stock?

I want to install an update.

Thanks.


  • 0

#64
organn

organn

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:MotoG

hi men. 

I have a problem, when i put the fastboot flash mode and apply recovery.

 

i see the next text : "hab check failed for recovery"  u.u


  • 0

#65
organn

organn

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:MotoG

Men i cant update dll u.u. you can send me dlls plz

Ok here is what it looks like when booted normally. There are two items in Device Manager I can see related to the Moto G:

attachicon.gifadb.pngattachicon.gifxt1032.png

The "adb devices" command lists the serial number as expected. I unplug the phone, power off, fast boot, choose recovery, and get the recovery menu. Reconnect usb, and choose the first menu item "apply update from sdcard". At this point I hear the USB device hot plug sound effect from Windows and return to Device Manager. Here is what is looks like:

attachicon.gifunknown.png

But when I try to Update Drivers for this unknown device, no matter what category of driver I look at the message is always "Unable to find any drivers for this device". I tried specifying directly the folder containing the standard Google USB driver which comes with the SDK, but the result is the same.

 

I noticed that if I connect the USB cable while the fastboot menu is displayed, then the Motorola ADB Interface device is listed, but not the other one. And furthermore, even though it's listed in Device Manager, adb does not list it. Restarting adb server does not help.

 

I also tried adb reboot recovery instead of manually fastbooting to the recovery menu, but it still has the same problem with not recognizing the device in this mode. Argh.


  • 0

#66
organn

organn

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:MotoG

my problem is with adb u-u


  • 0

#67
terminal 7

terminal 7

    Newbie

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:SW-UK
  • Interests:Phones,pc,mac,linux,android,osx,nothing else !
  • Devices:toomany-today-M-G
  • Twitter:@terminal7

off topic just a little but does anyone know what functions the recovery list perform ?  it has apply update in 2 positions and this leads me to think all functions are out of order , so much so i dont even want to risk a cache wipe !  any ideas?

 

and the root method in this topic is brilliant, worked for me when superboot would not - genius work again from Paul.

 

==PEACE==


  • 0

#68
linspinho

linspinho

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:Moto G

hi men. 

I have a problem, when i put the fastboot flash mode and apply recovery.

 

i see the next text : "hab check failed for recovery"  u.u

 

Hi organn, I dont know what is "u.u",  the text "hab check failed for recovery" does not mean anything or dont prevent you keeping going!

If you getting problem with windows not recognizing the phone, ready the pag 3 of this topic, you'll find a answer!!


Edited by linspinho, 08 December 2013 - 02:46 PM.

  • 0

#69
Ueta

Ueta

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Moto G

Hi.

This option worked for me (superboot did not).

After reading all posts from the other users I will try to resume what I did:

-I´m using Win 7 64 bits. My Moto G has only 1 chip (8 giga model).

-Downloaded the motorola drivers AND de android developer kit (yes you will need this)

-Installed motorola drivers and extracted the android developer kit

-Allowed the USB debugging (search the posts to see how to do this)

-Unlocked the bootloader (no problems here)

-Followed all the steps in this topic. I had problem right after the "apply update from sd" step. Windows misses the driver and the last command "adb-windows sideload supersu.motog.zip" could not be run. Keep the celphone connected to the computer.

-Some user posted this: http://blog.dantup.c...-recovery-mode/ . Search the android developer kit for this archive: android_winusb.inf (path: adt-bundle-windows-x86_64-20131030\sdk\extras\google\usb_driver).

Edit this file (make a backup first): android_winusb.inf . Add this code:

 

[Google.NTamd64]
 
; !-- snip other devices... --!
 
; Google Nexus 7
; !-- snip existing device IDs --!
; This is the HardwareID shown in Device Manager for the "Nexus"
;  device when in Recovery mode
%CompositeAdbInterface%     = USB_Install, USB\VID_18D1&PID_D001
 
-Save the file. Leave it with the other files.
-Go to the device manager in the control panel. You will see that the XT 1032 (is your android device) is missing the driver. Right click on it and click "update driver". Now search the file that you just edited. Insert the path and try to install the driver. Windows will ask if you want to continue. Click Yes. After the driver installed, run the command adb-windows sideload supersu.motog.zip. Reboot the phone.
-Rooted after it. 

 

 


  • 0

#70
moonwalker66

moonwalker66

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:Moto G

Did it with this method. Really simple.

Thanks Paul.

 

Moto G 8gb uk


  • 0

#71
beegee7730

beegee7730

    Newbie

  • Members
  • Pip
  • 5 posts

Hi,

Will this permanently install a custom recovery? Or will it revert to the stock recovery after flashing?

 

Thanks.


  • 0

#72
darksilk

darksilk

    Newbie

  • Members
  • Pip
  • 10 posts

I cant root yet. Im having the "Devide not found" error when trying to sideload.

 

Ive read the whole thread and i cant figure out how to fix it. I have the yellow mark on other devices menu in devices manager, but i dunno how to update the driver... Could somebody please help me? I just have the MotorolaDeviceManager_2.4.5.exe and thats how i supposed to install drivers.... Im on Windows 8

 

thanks in advance.

 

______________________________________________________________

 

nvm.... i tried again with my W7 laptop and it just worked... seems like the problem was related with W8 tho...


Edited by darksilk, 20 December 2013 - 06:57 AM.

  • 0

#73
sgtb

sgtb

    Newbie

  • MoDaCo Silver
  • Pip
  • 15 posts
  • Gender:Male
  • Devices:SGSII

I cant root yet. Im having the "Devide not found" error when trying to sideload.

Ive read the whole thread and i cant figure out how to fix it. I have the yellow mark on other devices menu in devices manager, but i dunno how to update the driver... Could somebody please help me? I just have the MotorolaDeviceManager_2.4.5.exe and thats how i supposed to install drivers.... Im on Windows 8

thanks in advance.

______________________________________________________________

nvm.... i tried again with my W7 laptop and it just worked... seems like the problem was related with W8 tho...


Google for "install unsigned drivers in Windows 8"

  • 0

#74
linspinho

linspinho

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:Moto G

I cant root yet. Im having the "Devide not found" error when trying to sideload.

 

Ive read the whole thread and i cant figure out how to fix it. I have the yellow mark on other devices menu in devices manager, but i dunno how to update the driver... Could somebody please help me? I just have the MotorolaDeviceManager_2.4.5.exe and thats how i supposed to install drivers.... Im on Windows 8

 

thanks in advance.

 

______________________________________________________________

 

nvm.... i tried again with my W7 laptop and it just worked... seems like the problem was related with W8 tho...

 

Put a think  in your mind, with Windows find the driver in normal use, your driver will be there, you just need patiences to find it, take a look in others post reply of mine!


  • 0

#75
seniorstew

seniorstew

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC Kaiser
Worked great on 4.3.. Will it work on 4.4?

  • 0

#76
Andrelgl

Andrelgl

    Newbie

  • Members
  • Pip
  • 2 posts

It did work on my 16 GB Dual SIM Brasil Retail ...

I'm always a little afraid to flash those .img, but it's worthed =D

 

Thank you very much ... made me happier with my Moto G !!!

quasmin, Hello I'm from Brazil too, you could root with which methods? Worked smoothly, your mobile phone and 16G dual sim confirms?...


  • 0

#77
quasmin

quasmin

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Brasil
  • Devices:Moto G

quasmin, Hello I'm from Brazil too, you could root with which methods? Worked smoothly, your mobile phone and 16G dual sim confirms?...


This method... I could not with the superboot, but the modified recovery worked just fine. Yeap, running smoothly and steady...

  • 0

#78
tom cerberus

tom cerberus

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Moto G

I can not pass this, does anyone know how to solve?

 

https://docs.google....Xp6dkE4dW8/edit


  • 0

#79
buggi

buggi

    Newbie

  • Members
  • Pip
  • 2 posts
Hi,

Thanks a lot for the job.
I just still have an issue (Linux, Moto G 8 GO FR). Indeed, when I used this command ./fastboot-moto-linux flash recovery recovery.testkeys.img I can move on my phone to go to recovery (I can't go up or down)
I can't go futher than : target max-sparse-size: 256MB
sending 'recovery' (10240 KB)...

In Windows I have this message :target max-sparse-size: 256MB
sending 'recovery' (10240 KB)...
FAILED <data transfer failure <Unknown error>>
Finished

What should I do ?
Thanks a lot

Edited by buggi, 23 December 2013 - 08:13 PM.

  • 0

#80
MickJack

MickJack

    Regular

  • Members
  • PipPip
  • 116 posts
  • Gender:Male
  • Devices:Huawei G300 & Moto G 16gig
Had the moto G for a while, just got round to unlocking the bootloader and rooting. I am not good at this and need to pick my way across the instructions slowly (very slowly).

There are good guides to unlocking the bootloader out there:
http://www.androidpi...loader-and-root

http://www.android.g...o-g-bootloader/

http://androidflagsh...otloader-moto-g

and more just a google away

I tried to root method 1 but it did not seem to want to work so on to this thread and method 2. All going well until the sideload supersu bit, had the 'device not found' problem, the win7 laptop has had no problem seeing the moto G until now !! Quit and read up a bit more, thanks to ahac85 and mheman for the tip to updating driver from device manager (post #28), my motorola driver was in "android devices".

Flash again and reboot handset and we now have root, supersu in the apps drawer.

Only now do I see that I have a nice fresh handset, all my app and data gone, my backup using MyBackupPro app gone so no restore, not a problem just a bit of work to do in a idle moment or hour, photo's have gone as well, I should have known better, nothing importent but a lesson learned.

Thanks Paul and all on here.

Edited by MickJack, 05 January 2014 - 04:30 PM.

  • 0




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users