Jump to content


Photo

problem with fusionX B199


  • Please log in to reply
10 replies to this topic

#1
Kronolynx

Kronolynx

    Newbie

  • Members
  • Pip
  • 18 posts
  • Devices:Huawei y300

I tried fusionX B199 for a couple of days and really  like it but i have a problem with the cell network not working. I tried also cyanogenmod 10 and 10.1 by Kra1o5 with the same problem, right now i'm using B199 ultralight and works good, no problem with cell network , 3g working fine. cell network also works good if  I use stock rom.

 

with fusionX and cyanogenmod the cell network signal is gray and has an R

while that R appears i can't make or receive calls, text messages use 2g or 3g and is a little unusual that if i connect to a wifi the cell network starts working the icon gets blue, I can see an H or a 3g next to the icon and I can call  and send text messages but as soon as I disconnect from the wifi again gray icon with R

 

could any one please help me find a way to get fusionX cell network working ?

 

thanks in advance

 

 

PS. I got a huawei ascend y300-0100


Edited by Kronolynx, 06 December 2013 - 11:25 PM.

  • 0

#2
rederik75

rederik75

    Enthusiast

  • Members
  • PipPipPip
  • 257 posts
  • Gender:Male
  • Location:Italy
  • Interests:Computers, Linux, Photography, Motorcycles
  • Devices:Huawei Y300-0100
Are the APNs correctly set?

  • 0

I won't say sorry for my bad english, because actually it's not so bad....  even if I'm Italian!

 

:D  :D  :D


#3
Kronolynx

Kronolynx

    Newbie

  • Members
  • Pip
  • 18 posts
  • Devices:Huawei y300

Are the APNs correctly set?

 

I didn't set it manually, do i need to do it ? 

in the stock rom and the ultra-light B199 rom that I'm using right now it's set automatically.

even if I don't set APN or are not correctly set that should only affect the internet, but in my case I can't make phone calls.

as far as I understand the R i have in the network icon means that I'm roaming. why does my phone starts roaming when I'm not connected to a wifi ?

 

PS. I just reinstalled fusionX set the APN manually but still roaming and 2 mins ago with the other rom my phone was ok. I'm in the middle of a big city so i shouldn't be roaming.

 

 in settings / about phone / status

 

Network
Tuenti

signal strength

-79 dBm 15 asu

Mobile network type

UMTS:3

Service state

In service

Roaming

Roaming

Mobile network state

Disconnected

My phone number

Unknown

 

IP Address

Unavailable

 

 

any other suggestion ?


Edited by Kronolynx, 07 December 2013 - 01:03 AM.

  • 0

#4
tillaz

tillaz

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 5,869 posts
  • Gender:Male
  • Location:Rockstar North
  • Interests:Time & Space
  • Devices:Z3 Compact

the difference is the apn_config

 

from the stock rom send me

 

system\etc\apns-conf.xml

 

and i will make a flashable.zip for you


  • 3

#5
Kronolynx

Kronolynx

    Newbie

  • Members
  • Pip
  • 18 posts
  • Devices:Huawei y300

the difference is the apn_config

 

from the stock rom send me

 

system\etc\apns-conf.xml

 

and i will make a flashable.zip for you

 

thank you so much for answering tillaz, I really like  what you have done with FusionX , great job :)

 

here is the code or should i actually upload the file somewhere ?

<?xml version="1.0" encoding="utf-8"?>
<!--
/*
** Copyright 2006, Google Inc.
**
** Licensed under the Apache License, Version 2.0 (the "License");
** you may not use this file except in compliance with the License.
** You may obtain a copy of the License at
**
**     http://www.apache.org/licenses/LICENSE-2.0
**
** Unless required by applicable law or agreed to in writing, software
** distributed under the License is distributed on an "AS IS" BASIS,
** WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
** See the License for the specific language governing permissions and
** limitations under the License.
*/
-->

<!-- use empty string to specify no proxy or port -->
<!-- This version must agree with that in apps/common/res/apns.xml -->
<apns version="7">
    <apn carrier="T-Mobile US"
         mcc="310"
         mnc="260"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
    />

    <apn carrier="T-Mobile US 250"
         mcc="310"
         mnc="250"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
            />

    <apn carrier="T-Mobile US 660"
         mcc="310"
         mnc="660"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
            />

    <apn carrier="T-Mobile US 230"
         mcc="310"
         mnc="230"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
            />

    <apn carrier="T-Mobile US 310"
         mcc="310"
         mnc="310"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
            />

    <apn carrier="T-Mobile US 580"
         mcc="310"
         mnc="580"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
            />

    <apn carrier="T-Mobile US 240"
         mcc="310"
         mnc="240"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
            />

    <apn carrier="T-Mobile US 800"
         mcc="310"
         mnc="800"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
            />

    <apn carrier="T-Mobile US 210"
         mcc="310"
         mnc="210"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
            />

    <apn carrier="T-Mobile US 160"
         mcc="310"
         mnc="160"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
            />

    <apn carrier="T-Mobile US 270"
         mcc="310"
         mnc="270"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
            />

    <apn carrier="T-Mobile US 200"
         mcc="310"
         mnc="200"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
            />

    <apn carrier="T-Mobile US 220"
         mcc="310"
         mnc="220"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
            />

    <apn carrier="T-Mobile US 490"
         mcc="310"
         mnc="490"
         apn="epc.tmobile.com"
         user="none"
         server="*"
         password="none"
         mmsc="http://mms.msg.eng.t-mobile.com/mms/wapenc"
            />

    <!-- T-Mobile Europe -->
    <apn carrier="T-Mobile UK"
         mcc="234"
         mnc="30"
         apn="general.t-mobile.uk"
         user="t-mobile"
         password="tm"
         server="*"
         mmsproxy="149.254.201.135"
         mmsport="8080"
         mmsc="http://mmsc.t-mobile.co.uk:8002"
    />

    <apn carrier="T-Mobile D"
         mcc="262"
         mnc="01"
         apn="internet.t-mobile"
         user="t-mobile"
         password="tm"
         server="*"
         mmsproxy="172.028.023.131"
         mmsport="8008"
         mmsc="http://mms.t-mobile.de/servlets/mms"
    />

    <apn carrier="T-Mobile A"
         mcc="232"
         mnc="03"
         apn="gprsinternet"
         user="t-mobile"
         password="tm"
         server="*"
         mmsproxy="010.012.000.020"
         mmsport="80"
         mmsc="http://mmsc.t-mobile.at/servlets/mms"
         type="default,supl"
    />

    <apn carrier="T-Mobile A MMS"
         mcc="232"
         mnc="03"
         apn="gprsmms"
         user="t-mobile"
         password="tm"
         server="*"
         mmsproxy="010.012.000.020"
         mmsport="80"
         mmsc="http://mmsc.t-mobile.at/servlets/mms"
         type="mms"
    />

    <apn carrier="T-Mobile CZ"
         mcc="230"
         mnc="01"
         apn="internet.t-mobile.cz"
         user="wap"
         password="wap"
         server="*"
         mmsproxy="010.000.000.010"
         mmsport="80"
         mmsc="http://mms"
         type="default,supl"
    />

    <apn carrier="T-Mobile CZ MMS"
         mcc="230"
         mnc="01"
         apn="mms.t-mobile.cz"
         user="mms"
         password="mms"
         server="*"
         mmsproxy="010.000.000.010"
         mmsport="80"
         mmsc="http://mms"
         type="mms"
    />

    <apn carrier="T-Mobile NL"
         mcc="204"
         mnc="16"
         apn="internet"
         user="*"
         password="*"
         server="*"
         mmsproxy="010.010.010.011"
         mmsport="8080"
         mmsc="http://t-mobilemms"
         type="default,supl"
    />

    <apn carrier="T-Mobile NL MMS"
         mcc="204"
         mnc="16"
         apn="mms"
         user="tmobilemms"
         password="tmobilemms"
         server="*"
         mmsproxy="010.010.010.011"
         mmsport="8080"
         mmsc="http://t-mobilemms"
         type="mms"
    />
</apns>

thanks again :)

 

 

PS. I just flashed again the fusionX rom in to my phone , replaced the apns-conf.xml with the one from the stock rom but my phone still roaming, is anything else i could replace or check to find out why is it roaming when I'm not connected to a wifi ?


Edited by Kronolynx, 07 December 2013 - 11:48 PM.

  • 0

#6
Kronolynx

Kronolynx

    Newbie

  • Members
  • Pip
  • 18 posts
  • Devices:Huawei y300

found a solution for the roaming, installed the universal cust then did a factory reset and now is working great.

really happy that now i can keep fusionX on my phone


  • 0

#7
Kronolynx

Kronolynx

    Newbie

  • Members
  • Pip
  • 18 posts
  • Devices:Huawei y300

now i got another problem, when i go to settings / Fusion X / Xposed Framework

i get this error

 

Unfortunately, FusionX has stopped , ok

 

any possible way to solve it ?

 

thanks again


  • 0

#8
tillaz

tillaz

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 5,869 posts
  • Gender:Male
  • Location:Rockstar North
  • Interests:Time & Space
  • Devices:Z3 Compact

no sure why that's happening as its not here, have you removed anything?


  • 1

#9
Kronolynx

Kronolynx

    Newbie

  • Members
  • Pip
  • 18 posts
  • Devices:Huawei y300

no sure why that's happening as its not here, have you removed anything?

 

I installed the universal cust and after that  I did a factory reset.  as far as i read the universal cust i installed formats data so probably that was the problem if not then was the factory reset. I downloaded Xposed and gravitybox , installed them and it seems that fixed it, I don't know if i lost anything else but right now everything seems to be working.

 

thanks for the great rom :)

 

ps. do you know why i need to install the universal cust to stop the roaming ?


Edited by Kronolynx, 08 December 2013 - 10:41 PM.

  • 0

#10
ghmk4406

ghmk4406

    Newbie

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Location:Surabaya
  • Devices:Huawei Y300
because the xposedinstaller.apk not a system file,so the factory reset will remove it,i think gravity box also.
sorry for my bad english.

  • 0

#11
Alluisses

Alluisses

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:Huawei Y300-100

Hey mate i know this is old thread but how and where u got the universal cust? i need it i got same problem as u on the y300-0100


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users