Jump to content


Photo

Help! GPS Broken

- - - - -

  • Please log in to reply
5 replies to this topic

#1
phyllocrania

phyllocrania

    Enthusiast

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:India
  • Devices:Huawei Ascend G300

I was running CM 11 13/12 nightly till yesterday noon and GPS was working fine. Maps, Facebook location, etc. everything fine.

 

At night, I flashed CM 10.1 29/11 and GPS was broken. After that I re-flashed CM 11 and it was still broken. Also installed Slim V13 and stock Gingerbread but its broken. 

 

Can anyone help me what's wrong?

 

I installed all these ROMs with full wipes, etc. I think my device GPS is dead or something.  :(  :(  :(


Edited by phyllocrania, 15 December 2013 - 08:21 AM.

  • 0

#2
phyllocrania

phyllocrania

    Enthusiast

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:India
  • Devices:Huawei Ascend G300

I flashed stock ICS and inserted a SIM card from another operator and everything is back to normal. Weird problem it was. 

 

Sorry for this creating this unnecessary topic. I actually had a panic attack on seeing GPS broken.


  • 0

#3
dalyer

dalyer

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,345 posts
  • Gender:Male
  • Location:Dublin, Ireland
  • Devices:Haier W910, Coolpad F1 8297W

In case it's of any use to you or anybody else in a similar situation at any stage...

 

http://www.modaco.co...able/?p=2181953


  • 0

#4
phyllocrania

phyllocrania

    Enthusiast

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:India
  • Devices:Huawei Ascend G300

After trying almost all GPS apps on Play Store with no results, I finally inserted a different SIM card from another operator and voila! GPS was fine again.

 

I put the other SIM card (with broken GPS problem) into an old samsung phone of mine and GPS wasn't working on that device either.

 

I also tried accessing GPS apps like maps on wifi with this "faulty" SIM and GPS still didn't work (on both devices). It was like whenever I used this SIM card, no matter if I'm on wifi or network data, GPS was still non-functional. :wacko:  

 

I have for the first time encountered such GPS problem with SIM cards. That's so weird. I never thought/heard that SIM cards could make GPS non-functional.  :blink:

 

Taking the SIM card to the operator tomorrow for a replacement.


  • 0

#5
smweb

smweb

    Diehard

  • Members
  • PipPipPipPip
  • 411 posts
  • Devices:Ascend G300

^ That's weird! Which SIM was that?


  • 0

#6
phyllocrania

phyllocrania

    Enthusiast

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:India
  • Devices:Huawei Ascend G300

The problematic SIM is from Vodafone India. I was shocked. To confirm, I repeated the entire process of checking by swapping the SIM cards with both devices and different ROMs (CM 11, CM 10.1, Slim V13, Stock GB) on G300, trying with just network data and also with wifi around 4-5 times. And the results were same. The Vodafone SIM broke GPS on whichever device it was put in.  :blink:

 

This problem started after flashing CM 10.1 as I already stated. But clearly the ROMs are not at fault. Its the SIM card.


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users