Jump to content


Photo

Wifi connect only on some ROMs

- - - - -

  • Please log in to reply
4 replies to this topic

#1
Antiseptic

Antiseptic

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Female
  • Devices:Telenor Touch plus
I have a problem with wifi as the title says. I have Telenor touch plus (atlas version), wifi only works on roms based on Cyanogenmod 7 :o and miui 4+ (can't remember the exact android version).

Now, I have a router that I use for Internet on this phone but I also have tablet that is always connected to the same router. There are NO problems with cm7 based roms but with most others it just disconnects(after around 5-10min) both tablet and the phone and I have to reset router if I want for it to work..

When I for example disconnect tablet and only use the phone it's okay, no problems again, but it's a problem when both are connected.
I assume it's a router related issue but can anyone help me resolve this, what do I do?

Thank you very much.

If needed : tablet runs on stock android 4.1.1 version.

Edited by Antiseptic, 08 January 2014 - 11:07 PM.

  • 0

#2
dodgetimmy

dodgetimmy

    Enthusiast

  • Members
  • PipPipPip
  • 295 posts
  • Gender:Male
  • Location:East Sussex, UK.
  • Devices:ZTE Crescent, HTC Desire
Check your Mac address or ip being assigned isn't the same on both devices.Also, If you don't back up your Mac when rooting you will default to a broken Mac, something like aa:bb:cc etc if this is the case you'll need to change to a working Mac address.

  • 0

#3
Antiseptic

Antiseptic

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Female
  • Devices:Telenor Touch plus
Thank you for your time,

Mac address is fine, everything works, I just can't understand why it works on some roms while not on others.
Maybe I should change some settings on the router? Because I didn't do anything about it, how my ISP set it up that's how I use it.

  • 0

#4
dodgetimmy

dodgetimmy

    Enthusiast

  • Members
  • PipPipPip
  • 295 posts
  • Gender:Male
  • Location:East Sussex, UK.
  • Devices:ZTE Crescent, HTC Desire

Thank you for your time,

Mac address is fine, everything works, I just can't understand why it works on some roms while not on others.
Maybe I should change some settings on the router? Because I didn't do anything ab is about it, how my ISP set it up that's how I use it.

Are you sure your router isn't assigning the same ip address to both when this happens? Also make sure the name of each device is different.

Anyway you should be able to work around this by setting up a manual ip address on either device, or if your router supports it, assign a specific address to each device, but keep it within the dhcp address range.

The only other thing I can think is you have to many devices on the network, but that's unlikely unless your router is set only to accept a small amount.

  • 0

#5
Antiseptic

Antiseptic

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Female
  • Devices:Telenor Touch plus

Thank you again :-) 

 

At the moment IP address is different on both devices but then again.. I'm currently using cm7 based rom.  

I will try on different rom and check again. 

 

I will post update and solution if I find one.  


Edited by Antiseptic, 14 January 2014 - 04:18 PM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users