Jump to content


Photo

JoyTab 9.7" Issues

- - - - -

  • Please log in to reply
3 replies to this topic

#1
gtd2000

gtd2000

    Newbie

  • Members
  • Pip
  • 7 posts

I bought a couple of JoyTabs last April and on the whole they have been reasonably good tablets.

 

One of them required a new keyboard as the bluetooth function was defective out of the box.

 

The same tablet has always had a problem with bluetooth transfers (photos/music etc.) but will connect to the replacement bluetooth keyboard at all times, which seems a bit strange.

 

You can send files from the tablet to the same device as far as I remember but I've given up on BT transfers...

 

There is another problem when filling out forms on websites - usually to do with personal information when completing an application. You get so far down the page then the tablet refused to enter any information. It does not matter what browser is used the tablet just stops inputting text - very frustrating.

 

The same website works perfectly on other Android devices - any ideas why they don't with the JoyTab?

 

Recently the charger gave up the ghost but the other charger from the second charges provides power – this has been sent back under and RMA but they seem to be taking a long time to get it sent back.

The tablet also started exhibiting a flickering display and this has resulted in another RMA for the tablet.

Then just before we did the RMA for the tablet a portion of the keyboard stand decided to break making the stand useless so that’s gone back under RMA as well.

So we are doing very well indeed.

Gemini are very tardy in their response times to any technical support but they are very quick to generate RMA numbers for warranty.

Let’s hope they can resolve all of these items ASAP J

 


  • 0

#2
gtd2000

gtd2000

    Newbie

  • Members
  • Pip
  • 7 posts

Well a quick email to Gemini to see what the state of play is with the RMA gave a response that the tablet is currently being looked at by the technicians.

 

Lets hope they get it repaired and sent back soonest! ;)


  • 0

#3
gtd2000

gtd2000

    Newbie

  • Members
  • Pip
  • 7 posts

Tablet was returned yesterday and all appears to be well.

 

Could not connect to WiFi network during initial setup to use existing google account but just loaded android as a new user and opted out of creating an account.

 

Once into the start page the tablet would connect to the local WiFi signal and then the Google account added when opening the Play Store.

 

So far, so good - just need to reinstall all of the apps again!


Edited by gtd2000, 24 March 2014 - 07:27 AM.

  • 0

#4
gtd2000

gtd2000

    Newbie

  • Members
  • Pip
  • 7 posts

Well the charger just failed on the other tablet that I bought.

 

They must be pretty low grade quality, as that's 2 out of 2 that have failed now :(


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users