Jump to content


Photo

Storage descriptions & respective values in CM11 Nightly builds - SD Card vs. Internal.


  • Please log in to reply
2 replies to this topic

#1
zodiac007

zodiac007

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:Huawei Y300

I've done a general web search for this and found nothing documented.  Therefore, felt I should register to confirm whether anyone's aware of this or might just be on my phone.  Firstly, rooted the Y300 this week, and loaded the last Nightly CM10 version to test - all seemed fine, so updated it with CM11 dated 16/05/2014.- generally, all is OK with this as well.

 

However, I notice in Settings - Storage, under the 2nd sub-heading "SD Card" it's in fact showing my values for the Internal Storage, and under the 3rd sub-heading, "Internal Storage", just below "Total space" shows my SD Card values.  Note that this is when "Use external SD as primary" (at the top of the screen) is ticked / checked.  Does anyone else, or the Devs. notice the same?

 

Is this a known issue, as it caused me quite a bit of confusion at first - {initially I'd thought that TWRP or CM had done something like auto. partition part of my SD Card during the root process}.  If I'm correct, I presume that theoretically, all that's needed is for the headings to be swopped around by whoever does the Nightly builds ?  I don't think this is specifically a KitKat problem, as I recall finding similar discrepancies when I loaded CM10 approx. 18 hours before (version 4.3.1 to test).

 

Then, if I untick / uncheck "Use external SD as primary" & reboot again, the Storage values are all aligned correctly with their respective headings, but in Settings- Apps, if you scroll across to "On SD Card", at the bottom of screen under "SD card storage", those values are clearly for the Internal Storage, not for a much larger SD storage capacity.

 

I wonder if others of you could check these things, and comment if you agree / disagree.  

I'd find it hard to believe I'm the only one experiencing these differences. (unless there's something wrong with the way in which these ROMs loaded, but I did clear cache / wipe Dalvik before doing a .zip install of CM10, and an OTA one of CM11).

 

Furthermore, if other users / developers are finding the same issues, can these descriptions be amended to agree to the exact values in each of the 2 scenarios (above), in a future Nightly build ?

 

I look forward to any meaningful comments / feedback on this ... 


  • 1

#2
DoMaCo

DoMaCo

    Newbie

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Devices:Y300

It's exactly the same for me on CM 11 Nightly 20140515


  • 0

#3
zodiac007

zodiac007

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:Huawei Y300

@DoMaCo - thanks for confirming.

 

I presume all that's needed is a change in labelling by the Dev./s

Sending a PM to @Dazzozo , but if the Moderator/s are aware of how to fast-track these changes, it would be appreciated !

 


  • 1




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users