Jump to content


Photo

Please Help - Huawei G510-0100 / 0200 Firmware problem.

- - - - -

  • Please log in to reply
4 replies to this topic

#1
tonyt1967

tonyt1967

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Huawei g510

Hi all,

 

first time post and hoping someone can help me.

 

I've already posted this in another section, but never received a response, so I'm hoping I get one here, coz I really need to sort this out.

 

So please somebody help

 

I bought a G510-0100 from Vodafone last year. While I have been generally happy with it there has recently been an update. I tried updating and it wouldn't, so I downloaded late one night from , which I am sure,was from the Huawei consumer website. After the download, I did the update from the micro SDcard which worked, but upon starting up, any reference to Vodafone had gone and now only starts up with the the name android. I have done some searching and cannot find anything to help me. The phone now runs very slow and sometime unresponsive. What I have also noticed, is the Model number has changed from G510-0100 toG510-0200, which I have only found out when I compared the label under the battery to the info in the about section of the handset and oh HiSuite.

I have tried installing a G510-0100 firmware, but it comes up with Failed on the second step.

 

If anybody can shed some light as to what I may have inadvertently done, I would be most greatfull.... I thought the phone had to be rooted to be  able to install a different  operating system.

 

Since writing this, i have tried rooting the phone and now have a super user icon , but installed a root checker and it says phone not rooter - I'm stuck now. Everything runs like snail pace.

 

Many Thanks in advance.


Edited by tonyt1967, 02 August 2014 - 04:32 PM.

  • 0

#2
Kamikazi

Kamikazi

    Newbie

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Devices:Xperia M2

i would recommend a factory reset and re-rooting. Can you tell me how you rooted it? Links if possible


  • 0

#3
tonyt1967

tonyt1967

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Huawei g510

Hi, thanks for answering.

 

I am using Kingo Rooting software. But originally I didn't.

 

I tried a factory reset, to no avail and it still shows as G510-0200. I just don't understand.

 

Thanks - Tony


  • 0

#4
Kamikazi

Kamikazi

    Newbie

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Devices:Xperia M2

Hi, thanks for answering.

 

I am using Kingo Rooting software. But originally I didn't.

 

I tried a factory reset, to no avail and it still shows as G510-0200. I just don't understand.

 

Thanks - Tony

:/ well I guess at this stage all there is is to do install a custom ROM. Since I think (i may be wrong) that your system files are messed up and really should do a total wipe and reinstall everything via ADB since we don't know what the problem is. if you don't know what adb is please don't mess around with it, i say it's a lifesaver and a lifetaker at the same time


  • 0

#5
tonyt1967

tonyt1967

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Huawei g510

Ah, you mention ADB, I presume you mean the ADB tool kit of around 700Mb.

 

I tried downloading that and it would get so far and would stop downloading and say, "file is corrupt". Tried several times.

 

Just to note, I have done another factory reset and it has taken to phone out of root, because Kingo, couldn't unroot it for what ever reason.

 

I am willing to give anything a try, even this ADB Toolkit, what ever it is.

 

I'm not sure if I'm allowed to post links, but here is where I tried Downloading the ADB Toolkit. http://www.adbtoolkit.com/

 

It's the ISO File.

 

Cheers for answering - Tony


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users