Jump to content


Photo

Exchange Server 2003 Always-Up-To-Date notifications HOWTO

- - - - -

  • Please log in to reply
92 replies to this topic

#21
nigelmu

nigelmu

    Newbie

  • Members
  • Pip
  • 7 posts
thanks fenice

I moved away from the corporate provider & things still work to the point of the SMS message arriving on the phone. It arrives - but the phone does nothing with it - i.e. it does not trigger a pickup. From what I can gather - this is because the email alert function of orange strips the message body of the message & only "alerts" the user of the email - this does not seem to be enough info to trigger a pickup!

Are you in the UK? Are you using orange email from www.orange.net with the alert function activated?

Many thanks
Nigelm

  • 0

#22
fenice

fenice

    Newbie

  • Members
  • Pip
  • 24 posts
Hi

Yes, I'm in the UK. I'm sorry but I misread your post, I thought you were talking about using Exchange Server 2003 with AUTD, that's what you need to get your mail automatically downloaded to your phone. I do have an email account at orange.net and it does alert me when mail arrives but it is only for that, SMS notification - it doesn't download your mail, you do need Exchange 2003 for AUTD to work to it's full potential. The reason it doesn't trigger a pickup is that Exchange sends a 'special' type of SMS that triggers the smartphone to sync with an Exchange server.

  • 0

#23
nigelmu

nigelmu

    Newbie

  • Members
  • Pip
  • 7 posts
I have exchange 2003 with all the up to date notifications enabled & SSL active synch enabled & working.

An email hits my inbox, exchange forwards that message to [email protected], my orange email alert gets forwarded to the phone & nothing happens - the message just sits in the SMS inbox

What am I missing here??

Thanks
Nigelm

  • 0

#24
fenice

fenice

    Newbie

  • Members
  • Pip
  • 24 posts
Ok, just for clarification. You say that '... exchange forwards that message' - it actually should send an SMS message to orange.net and your original email sits on your exchange server until it syncs. Is that what's happenening to you or are you saying that there's just the SMS in your inbox?

Have you tried syncing your phone by cable to your exchange server and does it work? Is there any firewall on your systems and is port 443 open? Do you have the Exchange server set-up correctly? Have you made any changes to the phone settings?

  • 0

#25
nigelmu

nigelmu

    Newbie

  • Members
  • Pip
  • 7 posts
- sorry - my mistake - it forwards a notification message to my orange email which then sends an alert.
- phone synchs via cable link & via SSL via GPRS
- it all seems to come back to that sms that arrives on the phone - the smartphone does not seem to recognise them as up to date alerts. I am assuming this is because they lack the message body??

Any thoughts?
thanks
Nigelm

Ok, just for clarification. You say that '... exchange forwards that message' - it actually should send an SMS message to orange.net and your original email sits on your exchange server until it syncs. Is that what's happenening to you or are you saying that there's just the SMS in your inbox?

Have you tried syncing your phone by cable to your exchange server and does it work? Is there any firewall on your systems and is port 443 open? Do you have the Exchange server set-up correctly? Have you made any changes to the phone settings?


  • 0

#26
fenice

fenice

    Newbie

  • Members
  • Pip
  • 24 posts
In that case, I'm stumped I'm afraid. The odd thing about your setup is that, AFAIK, the SMS that tells your phone to sync 'hidden' (for want of a better technical term) and you should never see it.

As I mentioned earlier the SMS that forces the sync is only for that purpose and when the phone sees the AUTD SMS it just syncs with your server, it doesn't have anything in it other than the notification to sync. In other words, the set-up with E2K3 is as follows: and email arrives in your inbox; OMA then sends the 'special' SMS; your phone recognises that and does a sync just as if you had pressed the ActiveSync option. In other words the phone pulls the email from your server they're not stricly pushed to your phone.

I'm about the end of my technical ability here as I'm just just a beginner with E2K3, about the only thing that I can suggest would be a reset of your phone back to manufacturers defaults and start again. Have you tried asking these questions in the microsoft.public.exchange. - clients/connectivity/admin groups?

  • 0

#27
nigelmu

nigelmu

    Newbie

  • Members
  • Pip
  • 7 posts
the crux of the problem seems to be the "special" sms

the message arrives at my orange email box - eg of subject =
9101fd0014c9324c92146f46dceb1c22-cd8a8

with content of
//SCKL040A AwFqAAADxgADBQHDEER1e4lT6p+XALskFIvUwwEB

but when the orange alert mechanism forwards the message to the phone - it only includes the subject. I am guessing that is the problem.

Is that how the SMS message gets to your phone - ie via orange alert?

Ta
Nigelm


In that case, I'm stumped I'm afraid. The odd thing about your setup is that, AFAIK, the SMS that tells your phone to sync 'hidden' (for want of a better technical term) and you should never see it.

As I mentioned earlier the SMS that forces the sync is only for that purpose and when the phone sees the AUTD SMS it just syncs with your server, it doesn't have anything in it other than the notification to sync. In other words, the set-up with E2K3 is as follows: and email arrives in your inbox; OMA then sends the 'special' SMS; your phone recognises that and does a sync just as if you had pressed the ActiveSync option. In other words the phone pulls the email from your server they're not stricly pushed to your phone.

I'm about the end of my technical ability here as I'm just just a beginner with E2K3, about the only thing that I can suggest would be a reset of your phone back to manufacturers defaults and start again. Have you tried asking these questions in the microsoft.public.exchange. - clients/connectivity/admin groups?


  • 0

#28
fenice

fenice

    Newbie

  • Members
  • Pip
  • 24 posts
The SMS would be different but according to the event viewer on my E2K3 server box that's something like the type of message I get sent. As I mentioned eearlier, I never see the SMS as it's supposed to be hidden and is just to trigger the AUTD sync from the phone. Yes, the messages are coming to me from Orange alert, I send the notification to my phone at [email protected]

I know you can do this via the phone but when you made the entries for your Device Address etc, did you do it via the cable connection?

  • 0

#29
nigelmu

nigelmu

    Newbie

  • Members
  • Pip
  • 7 posts
Yes - I did set this up while connected via cable.

Perhaps it is worth completing a full reset on the phone & setting it up from scratch - just in case

thanks for your help
Nigelm

  • 0

#30
fenice

fenice

    Newbie

  • Members
  • Pip
  • 24 posts
Now, I'm totally confused - I was just trying to get some info and reset it to use the Corporate Service Provider in device settings and it worked. :shock: :? It didn't earlier and from a post in a newsgroup I was under the impression it wasn't working at all for the moment.

Try turning on diagnostic logging in E2K3 for the server in your Administrative Groups/Servers/ if you right click properties the Diagnostic Logging on the Services for MSExchangeActiveSyncNotify you'll see two entries for the Categories, you can set them to maximum and you see messages in the event log that detail the information they've snt to Orange, at least you can se if it matches the SMS info you posted earlier.

I'm afraid that a full reset is always a faithful stand-by in cases like this. :cry:

  • 0

#31
nigelmu

nigelmu

    Newbie

  • Members
  • Pip
  • 7 posts
Hard reset the phone & set from scratch for SMS notification & turned on all the loggin.

Am convinced that the problem relates to the Orange email alert only sending the subject line & not the body of the message!

Interesting - if I manually send an email with the message body in the subject - it seems to work.

So - I am wondering how on earth yours works? Are you not simply getting the subject?

Best regards
Nigelm

  • 0

#32
jigboby

jigboby

    Newbie

  • Members
  • Pip
  • 1 posts
Wow, it actually worked! I just followed the directions in this thread. Thanks everyone for your help. I now have my Samsung i600 receiving messages as I get them in my office.

  • 0

#33
Dr_StrangeTrick

Dr_StrangeTrick

    Addict

  • Members
  • PipPipPipPipPip
  • 728 posts
  • Gender:Male
  • Location:Birmingham
  • Devices:HD2 flashed with WP7
Don't know if any of you guys can help.

I have followed the notes etc but I am still having problems.

I am running Windows 2003, Exchange 2003 and ISA 2000 (with the SP loaded), the server itself runs fine and I only have the E100 (should not make much difference).

Problems I have, when I put my phone in the cradle to sync the active sync box comes up and reports that Calendar, Contacts and Inbox are 'sync status is on the device' and I cant get any contacts, emails etc to appear and I cant find out what that message means.

Secondly when I try to access my OMA server from my phone it asks me for my username and password but it refuses to accept them. If I cancel I get a 401.1 error. I have the forms authentication turned off and I have loaded the disablecertchk but still no joy.

Can anyone help??

  • 0

#34
fenice

fenice

    Newbie

  • Members
  • Pip
  • 24 posts
Hi

Have you go authentication setup correctly on E2K3 & IIS? Have you also got the correct ports open on ISA? Have a look at this article http://snipurl.com/53ji it describes how to set-up E2K3 with ISA. There's a second article to that series, you can find the link on the page above.

HTH

  • 0

#35
johnsoanes

johnsoanes

    Newbie

  • Members
  • Pip
  • 19 posts
The sync status set on phone message is normal. That just means that syncronisation is being handled by direct communication between the E200 and the Exchange Server.

Tasks are syncronised using the Active sync program on the workstation connecting to Outlook and not handled by a direct connection to Exchange Server.

  • 0

#36
dh

dh

    Regular

  • Members
  • PipPip
  • 109 posts
  • Devices:Orange SPV C500
This topic is juct what i've been looking for, from what i understood this was not possible in the UK, seems I was wrong, so i've just set it up this afternoon, all is working except orange.net is rejecting the smtp message from the exchange server, stating the recipient [email protected] is an invalid recipient.
Any ideas. The xxxxxxxxx is my orange phone number.

  • 0

#37
fenice

fenice

    Newbie

  • Members
  • Pip
  • 24 posts
Hi

Where have you entered the phone number [email protected]? Under E2K3 System Manager/Global Settings/Mobile Services you only enter @orange.net, you need to enter the mobile users phone number on his mailbox details.

  • 0

#38
dh

dh

    Regular

  • Members
  • PipPip
  • 109 posts
  • Devices:Orange SPV C500
fenice

I entered @orange.net in e2k3, but actually used the smtp address setting on the phone and entered 'phone [email protected]'. I've also entered the details in the telephone field in active directory users and computers (exchange version). I checked the smtp log on the exchange server which is stating the recipient 'phone [email protected]' is invalid.

I was wondering if it was necessary to be on a particular orange tariff, my phone is on some company tariff with Orange? Maybe an included SMS allowance per month or something?

  • 0

#39
fenice

fenice

    Newbie

  • Members
  • Pip
  • 24 posts
OK, on your phone go to the ActiveSync from the Start menu. When the ActiveSync screen comes up go to the Menu/Options/Server Settings/Connection - going down the list of options:

Username = username on the E2K3 server
password = user password
Domain = domain name of the Server
Server Name = url of your server
SSL = check box to use SSL
Address Device Using = Service Provider
Device SMS address = leave blank
Service Provider = Orange
Device Phone Number = your phone number

Those setting are the ones I have on my phone and it receives AUTD fine. Just to confirm that you do have WIN2K3 + E2K3 plus a Windows 2003 mobile device?

  • 0

#40
dh

dh

    Regular

  • Members
  • PipPip
  • 109 posts
  • Devices:Orange SPV C500
Got all that, I've also set the diagnostics logging on ActiveSyncNotify service, which then shows in the event viewer that all is ok, its orange that is rejecting the message it seems.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users