Jump to content


Photo

How to fix the homescreen bug on MPx200 with Jmms installed

- - - - -

  • Please log in to reply
76 replies to this topic

#41
ddmf

ddmf

    Regular

  • Members
  • PipPip
  • 88 posts
  • Location:Dundee
  • Interests:stuff!
  • Devices:MDA Vario II
aye, well, just slap the chuff out of me if i'm ever in wales - i put those links back and now receive mms too, so to re-iterate, just change the registry setting... that's it, no more, no less ('s a magic number...)

  • 0
Developing: Onsite Consultant Invoicing system... Products and Customers on your phone, get them to sign, add notes - sends email to special email address. Invoice server reads email, creates sales order & emails customer. After 3 weeks or >£ amount invoices can be autocreated and emailed...

Mobile History: star-tac 5200 -> pf768 -> t14 -> 3210 -> 8210 -> 8310 -> 7650 -> 7250 -> t610 -> mpx200 -> c500 -> mda compact -> mda vario -> mda vario 2 -> mda varia 3 / nokia n95 -> ???

#42
lawsonium

lawsonium

    Regular

  • Members
  • PipPip
  • 88 posts
  • Location:Caerphilly, South Wales
  • Interests:Horses, Blading, Live Comedy.
ddmf,

I'm still unable to send and receive MMS messages...

I'm gonna change my registry back tonight and see if I can still send/receive with the old setup.

I'll report back asap (I'm off to watch Lord of the Rings now so it will be later on tonight, but I will do it tonight)

Thanks in advance and all that P/C stuff.

Matt.

  • 0
"Behind every defeated man there's a frustrated love." - Carry Grant
LAWSONIUM -}LoA{-

#43
The Lostprophet

The Lostprophet

    DO'H

  • Members
  • Pip
  • 34 posts
  • Location:stansted, Essex, UK
  • Interests:music and mobiles...i sell mobiles alday tho....
  • Devices:M5000...AT LAST
ur the best :D u just made my mpx200 complete :) i owe u one!

Ok, go to regedit

blue button down on HKEY_CLASSES_ROOT
scroll down to CLSID -> push blue button
scroll down to {2F930BF... -> push blue button
inprocserver32 -> push blue button (blank screen)
push VALUES -> see default -> push blue button

Value Name:
Default

Value Data:
Windowstpcutil.dll

Value Type:
REG_SZ

^ change it to that -> click done -> exit regedit, restart phone!


  • 0

#44
lawsonium

lawsonium

    Regular

  • Members
  • PipPip
  • 88 posts
  • Location:Caerphilly, South Wales
  • Interests:Horses, Blading, Live Comedy.
I still can't send an MMS even witht he original setup, all I get on my MPx200 is the following message 'alert: error in dialing'.

That was what I was getting with the new registry edited version.

What's going on?

Any help much appreciated as I can't receive either. I just get an MMS with an Orange url and password.

  • 0
"Behind every defeated man there's a frustrated love." - Carry Grant
LAWSONIUM -}LoA{-

#45
lawsonium

lawsonium

    Regular

  • Members
  • PipPip
  • 88 posts
  • Location:Caerphilly, South Wales
  • Interests:Horses, Blading, Live Comedy.
Ok, I got it working now.

The fix is working and my custom homescreen looks as intended and I can send MMS also.

Great, splendid, wonderful, lovely.

Cheers guys.

  • 0
"Behind every defeated man there's a frustrated love." - Carry Grant
LAWSONIUM -}LoA{-

#46
scott2eyes

scott2eyes

    Diehard

  • Members
  • PipPipPipPip
  • 429 posts
  • Location:London
  • Interests:Star Wars, Stone Roses, Shiny things.
  • Devices:iPhone 3G
How did you get it working?

I've done the registry edit, which has removed the MMS problem from my homescreen, but also completely removed any MMS functionality from my phone (not even getting the SMS with the URL.)

  • 0
My (slightly out of date!) guide to the MPx200 (including customising the homescreen and Media Player):

*LINK*

#47
lawsonium

lawsonium

    Regular

  • Members
  • PipPip
  • 88 posts
  • Location:Caerphilly, South Wales
  • Interests:Horses, Blading, Live Comedy.
So you WERE able to send/receive MMS before you made the change?

Because, if you have followed the instructions exactly there is no reason why it shouldn't work. The reason I was having problems is that I hade made mistakes.

The only thing I can suggest is re-trace your steps and re-set the registry key. Then check that MMS is working (if it isn't then ring Orange and check MMS is still enabled on your account). However, if it is then you probably did something wrong so just follow the steps listed in this thread again and double check your spelling and the case of the characters you use. Don't forget to re-set the phone.

Hope you get it working mate, I hate it when stuff that should work doesn't.

Matt.

  • 0
"Behind every defeated man there's a frustrated love." - Carry Grant
LAWSONIUM -}LoA{-

#48
scott2eyes

scott2eyes

    Diehard

  • Members
  • PipPipPipPip
  • 429 posts
  • Location:London
  • Interests:Star Wars, Stone Roses, Shiny things.
  • Devices:iPhone 3G
I think I have found my problem- my MMS was working before I started making the changes; however, as I was unlocking my phone and putting a load of unsigned software on at the same time, my phone locked up when resetting, so I had to do a hard reset- obviously wiping the JMMS software in the process...

(And I can't reinstall JMMS as my CD drive is broken!)

Ah well- at least my Calvin & Hobbes custom homescreen looks Ok...

  • 0
My (slightly out of date!) guide to the MPx200 (including customising the homescreen and Media Player):

*LINK*

#49
scott2eyes

scott2eyes

    Diehard

  • Members
  • PipPipPipPip
  • 429 posts
  • Location:London
  • Interests:Star Wars, Stone Roses, Shiny things.
  • Devices:iPhone 3G
...Also, I've just discovered that changing the setting to "Windowstpcutil.dll" (as opposed to just "tcputil.dll") seems to stop the internet & email connection from working (it just sits on the "dialling" screen for about 5 minutes, then claims that there's no network connection...)

Which should make for an interesting problem for Orange's technical support to scratch their heads over. (And the fact that halfway through after taking the battery out, I started getting SIM card errors, which turned out to be because the little plastic clips holding the SIM card in place have snapped off will no doubt be the icing on the cake for some poor engineer!)

  • 0
My (slightly out of date!) guide to the MPx200 (including customising the homescreen and Media Player):

*LINK*

#50
botty67

botty67

    Newbie

  • Members
  • Pip
  • 2 posts
IS THERE ANY WAY YOU CAN EXPLAIN THAT ONE IN A SIMPLY WAY I'M ONLY 15 PLZ

  • 0

#51
lawsonium

lawsonium

    Regular

  • Members
  • PipPip
  • 88 posts
  • Location:Caerphilly, South Wales
  • Interests:Horses, Blading, Live Comedy.
Which part would you like explained botty? This thread has deviated a little from the original post :-)

Matt

  • 0
"Behind every defeated man there's a frustrated love." - Carry Grant
LAWSONIUM -}LoA{-

#52
hiffy

hiffy

    Newbie

  • Members
  • Pip
  • 5 posts
hi... can someone explain to me what is experienced when people say that their homescreens are 'garbled'... the reason i ask is that i had put my own homescreen on... the message counters displayed correctly on my screen...

howvever, the problem i was getting was that whenever the homscreen was re-painted (i.e. when returning to homescreen from the menu or another program) some of my memory was eaten up... (to be exact 48k each time...) and as you can imagine after using the phone all day it would run out of memory pretty quick... :)

anyway, i tried setting the default skin again but made no difference... did a hard reset and then installed apps one at a time to see which was causing the problem. i think it came back to jmms if i remember correctly... then came across this fix thread and did what the instructions said... seams to be working fine now... no problems with mms or memory disappearing... although i'm not getting a count for mms messages...

does my memory problem sound like something that would be caused by 'garbled' skins??? or could have been down to something else??? and if so any ideas what??? problems gone now but i'm still curious... any info to help me sleep better at night would be much appreciated... :roll:

regards,
hiffy.

PS. keep up the good work people...

  • 0

#53
scott2eyes

scott2eyes

    Diehard

  • Members
  • PipPipPipPip
  • 429 posts
  • Location:London
  • Interests:Star Wars, Stone Roses, Shiny things.
  • Devices:iPhone 3G
Some homescreens are designed to display the message counts in a certain way- for example, they might have an icon for SMS, email etc. as a part of the background, and then have the message count lined up to fit in with the background.

The problem is that the Orange MMS software has been designed in such a way that the message count is always displayed in the same format- "SMS: (number), MMS: (number), Email: (number)"- meaning that if you've got a homescreen designed to show the messages in a specific way, they simply don't come out the way they were intended, so the screen looks a mess.

I don't know enough to say whether the memory problem would be related to this though, although from your tests it certainly sounds to me like it's down to the jMMS software.

  • 0
My (slightly out of date!) guide to the MPx200 (including customising the homescreen and Media Player):

*LINK*

#54
smartphone-web.com

smartphone-web.com

    no coverage? - nooooo

  • Members
  • PipPipPip
  • 180 posts
  • Location:Germany
This is a fully automatic patch to fix this problem. Just install and have fun!

Credit: http://www.hochstaetter.org/mobile

Attached Files


  • 0
Stephan Schmidt
Editor in Chief of smartphone-web.com (smartphone2002.info)
Member and Final Judge of Pocket PC Magazine Board of Experts 2003, 2004 and 2005
Microsoft MVP - Mobile Devices

#55
iahmat

iahmat

    Newbie

  • Members
  • Pip
  • 3 posts
sorry guys after changing the registry i can't connect to the internet.keep having the following error.

" unable to connect.Verify you have network coverage and try again".

it works before i change the setting......

anyone can share where i went wrong...also i could have screw up another CLSID entry call 2FFD93B3-0FF0-4228-

anyone can share what should be the entry for the above

thanks

  • 0

#56
scott2eyes

scott2eyes

    Diehard

  • Members
  • PipPipPipPip
  • 429 posts
  • Location:London
  • Interests:Star Wars, Stone Roses, Shiny things.
  • Devices:iPhone 3G

sorry guys after changing the registry i can't connect to the internet.keep having the following error.

" unable to connect.Verify you have network coverage and try again".

it works before i change the setting......

anyone can share where i went wrong...also i could have screw up another CLSID entry call 2FFD93B3-0FF0-4228-

anyone can share what should be the entry for the above

thanks


Looks like you might have done what I did- if you've changed the setting to "Windowstpcutil.dll", then try changing it to just "tpcutil.dll" (without the quotes.)

Also, the registry entry for 2FFD9... etc. on my phone is the same- "tpcutil.dll" (without quotes.)

  • 0
My (slightly out of date!) guide to the MPx200 (including customising the homescreen and Media Player):

*LINK*

#57
iahmat

iahmat

    Newbie

  • Members
  • Pip
  • 3 posts
thanks, but still having the same problem.....
can't hard reset the phone also.

not sure where it went wrong

  • 0

#58
thelagermonster

thelagermonster

    Newbie

  • Members
  • Pip
  • 15 posts
iam now a very man at last them homescreens work :)

  • 0

#59
jonmayes

jonmayes

    Newbie

  • Members
  • Pip
  • 11 posts
Hi guys,

trying to fix the message count on the homescreen..

first of all the tpcutil.dll file does not appear to be present anywhere on my phone (after doing a hard reset). Also, I'm fairly sure that two of MMSRegister.exe, MMSReceive.exe, MMSNotification.exe used to run on startup before I reset the phone. Do you think it might be something to do with this?

  • 0

#60
Kian

Kian

    Newbie

  • Members
  • Pip
  • 3 posts
Hey guys.

Listen, I have an MPX200 with the generic rom and Jmms installed, and I find the registry entry. The only thing is, when I change it, nothing happens on the homescreen, and if I reset the phone, it resets the registry value back to the Jmms default.

Any ideas?

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users