Jump to content
bitbank

Sega GG + Nintendo GameBoy emulator for SP beta test

Recommended Posts

Thanks to everyone for sending bug reports. I've fixed several problems and will be releasing a new build shortly.

Please keep the bug reports coming.

After this last round of fixes, the Gameboy code seems to be nearly perfect. The SMS/GameGear code is in good shape and only fails for about 3 games that I could find.

I'm very interested in hearing about problems with PC-Engine and Genesis games.

I realize that the Genesis code is not real fast with sound enabled, but some games require the Z80 emulation to run properlyl.

Thanks,

L.B.

Share this post


Link to post
Share on other sites

New build is up! (0.12). You can download it here:

www.bitbanksoftware.com/downloads/smartgear.zip

What's new:

1) Fixed a GBC timer bug. This allows several games to work correctly (including one submitted as a bug report).

2) Fixed Key Definition dialog to allow you to exit with the soft menu keys.

3) Enabled ARM assembly language CPU emulation in NES. You will see incredible speed in NES games (try unchecking throttling).

4) Enabled volume adjustment keys during gameplay (this was in the last build, but I forgot to mention it).

Please keep the bug reports coming.

L.B.

Edited by bitbank

Share this post


Link to post
Share on other sites
New build is up! (0.12).  You can download it here:

<{POST_SNAPBACK}>

Oh my god ! wondeful ! my three NES games reported are working fine !

I can Use the volume keys for volume !!! how the hell ? excellent

I still try to figure how to use the save key ??

Note that I experiencing strange really bad sounds, perhaps it's me

Share this post


Link to post
Share on other sites
New build is up! (0.12).  You can download it here:

www.bitbanksoftware.com/downloads/smartgear.zip

What's new:

1) Fixed a GBC timer bug.  This allows several games to work correctly (including one submitted as a bug report).

2) Fixed Key Definition dialog to allow you to exit with the soft menu keys.

3) Enabled ARM assembly language CPU emulation in NES.  You will see incredible speed in NES games (try unchecking throttling).

4) Enabled volume adjustment keys during gameplay (this was in the last build, but I forgot to mention it).

Please keep the bug reports coming.

L.B.

<{POST_SNAPBACK}>

im not sure if the problem existed in the previous version, but there are weird graphics in pokemon crystal. (other pokemon seem to run nice)

cya

Edited by Sly123

Share this post


Link to post
Share on other sites

Opinions Wanted

-------------------

Many of you have noticed that the rotate display option doesn't work in all of the games. The reason has to do with performance. Each game emulator renders its graphics in 8-bits per pixel and then translates the colors through the palette into 16-bits per pixel for display on the device. This occurs on a scanline-by-scanline basis so that games which dynamically change the color palette will look correct (many GBC games do this).

Here's the problem:

If I take the translated pixels and draw them directly on the display memory as they are rendered in the game, I get the best possible performance. The downside to this is that I would need to add scaling and rotation logic to each game engine so that it could render the game image the way you want to see it.

The alternative is to render each game image into an offscreen bitmap and then pass that to a central "smartgear" display routine which would handle rotation and scaling. This leads to a loss of performance because copying 112K (256x224 16-bit pixels) 30 times a second translates into a minimum of 3.4MB of data copied per second. The slow system and video memory of these devices means that a significant chunk of time is lost just copying the data.

I can improve this situation by having each emulator know if there needs to be scaline or rotation and act in the fast or slow manner. A way to gain even more speed is to render everything in 8-bit pixels until the entire display is to be updated. This will display incorrect colors on games which change the color palette mid-screen.

Much of the time lost manipulating colors and bit depths could be avoided if Windows Mobile supported an 8-bit palettized video mode (the chipsets do support it, WM has the RGB565 restriction).

Ideas? Opinions?

Thanks,

L.B.

Share this post


Link to post
Share on other sites

rocket power getting air on gbc doesnt work (with all builds except the old 0.05)

"I can improve this situation by having each emulator know if there needs to be scaline or rotation and act in the fast or slow manner."

I think thats it....

but i dont see the rotate function anywhere...

genesis games dont work for me

most of thetime if a rom doesnt load,hangs, doesnt matter wich emu, gbc,gamegear,genesis, ... the `back key` doesnt work, though the `paused` function is still accesable with the defined key, standard its the ´0´ key

Edited by Smartastic

Share this post


Link to post
Share on other sites

It would be more accurate to render everything off screen but because of the performance hit I vote to leave it as is. ;) If it really annoys people that some games cannot be rotated then I vote for your last option.

For some reason I cannot turn off sound. If I go into options and disable sound it doesn't make any difference. Even if I switch my phone to the silent profile, and the sound option is turned off in Smartgear I get sound! The only way for me to make it silent is to turn the earpiece volume all the way down.

My phone is an orange SPVC500 and I am running Wario Land 3 (gbc).

Thanks for such an awesome emulator! ;)

Share this post


Link to post
Share on other sites

Bitbank,

I'd recommend you'd go for speed first (1st option)

As the devices will get faster during next season and the seasons to come I reckon the phone will be able to handle more and optimized emu's are less essential than they are now.

Cheers,

Share this post


Link to post
Share on other sites

i think u should leave the nes(pocketnesterplus is free and is better) and megadrive (picodrive masterall port is very very decent+ FREE) and even the turbo sumthing sumthing....try to emulate NEO GEO POCKET, ATARI LYNX, GB ADVANCE and keep it like a "pocket console emulator"...

Share this post


Link to post
Share on other sites
Opinions Wanted

Hello Larry, my name is Francesco, I'm living in Italy and I've tried the very last build of Smartgear on my QTEK 8310.

Here's what I discovered while using it:

- While browsing for a ROM to load, I noticed that the file box is smaller than the screen. I suppose that it was meant to be used on a 176x220 screen. Could you fix it to fit also to QVGA screen?

- During emulation, the very first line of the HOME SCREEN is still visible behind the black screen.

- While playing, the emulator screen is not centered on the device. Maybe this could be still caused by the different screen resolution of my QVGA smartphone?

- I've disabled sound under options menu. But when I launch a Gameboy ROM, Smartgear plays sound effects anyway

- Under gameboy emulator, Shantae graphics seems to be all messed up; under PockeGnuboy everything is OK. Don't know if you already know about this issue

- IMHO a great feature you could add to the emulator could be the ability of "stretching" the video, to fit entirely the screen (I don't care much about the aspect ratio)

- Another great addition could be the ability of loading and saving snapshots, so anyone could be able to freeze a game and then reload it from any point

- An Atari Lynx emulator and a Neo Geo Pocket emulator, if technically possible, would be fantastic

That's it..

Thank you very much for your time

Edited by Cescone

Share this post


Link to post
Share on other sites

Hi,

I've just started testing you emulator with GBC games to see how it compares to others out there. As far as speed goes, it great!! However i've having issues with my iMate sp3i and the joystick control. When playing Pokemon (yeah yeah, it good to test with...) and you need to move great distances, generally you hold the joystick in the direction until you need to stop. However for about 1 second everything is fine, then the game gets VERY choppy! The FPS fall to between 20 and 30 instead of nearly 60, and if the sound is on it sounds terrible!

I have checked in the task manager for anything that may be running in the background, but nothing is other than the operating system. Is this a prob with all phones of the type? Previous to this I was using the gnuBoy emulator and it was fine until mid last week when I installed a few apps, etc.. which is when the prob started, hence thought I'd give this emulator a try, but I have since uninstalled all the other apps I installed but it is still playing up.

Any ideas?

Share this post


Link to post
Share on other sites

I seem to have an odd problem which seemingly no one else has. Whenever I load up any game, the video seems to lag behind the audio; the game will work fine, but then the video will "freeze up" for 30 sec - 1 min while the audio continues. This tells me the game is still being emulated, but the video is not catching up for some reason. I have an SMT5600 and this seems to occur with every emulator included, from NES to GBC.

Also, while it is running, it seems to be running too fast, maybe 20% faster than normal. Throttle framerate is on as well.

Edited by obiwanblee

Share this post


Link to post
Share on other sites

Larry,

Strangely enough, I'm still having problems getting smartgear to work.

When I launch everything looks fine, but when I load a rom the screen gets black anbd stays like that, except for the blue 'smartgear' bar in the top of my screen.

I'm still using an spv c500. WM 2003 2nd ed, Rom version 4.21.1088 (Build 14132)

Any ideas?

Share this post


Link to post
Share on other sites
Larry,

Strangely enough, I'm still having problems getting smartgear to work.

When I launch everything looks fine, but when I load a rom the screen gets black anbd stays like that, except for the blue 'smartgear' bar in the top of my screen.

I'm still using an spv c500. WM 2003 2nd ed, Rom version 4.21.1088 (Build 14132)

Any ideas?

<{POST_SNAPBACK}>

This version is not for C500 but c600 are you french ? you can PM me if yes.

Anyway i experienced black screen, it was because of previous Save files, try to erase them

Share this post


Link to post
Share on other sites

Please help. im new user of spv classic and i cant run smartgear.exe. Im using resco explorer but i supose its not so important. Every time i try to run smartgear.exe nothing happens, only a beep-sound. It occur in few more .exe's but not everyone. Can u tell me whats goin on? its so irritating that i cant execute most of apps... Or if yu can put a install file(.cab?) or unpacked, zipped version to put to program files... what am i doing wrong?

I presume that smartgear works on 2002 spv classic...

Hope to get help... :cry:

Share this post


Link to post
Share on other sites
I presume that smartgear works on 2002 spv classic...

Hope to get help... :cry:

<{POST_SNAPBACK}>

Of course it doesnt work on spv classic, old smartgear from 2 years ago is working fine on it.

Share this post


Link to post
Share on other sites
Anyone have one?

<{POST_SNAPBACK}>

No we updated our phones, check armadillo

Share this post


Link to post
Share on other sites

well i found some weird bug (tested with 2 different phones)...

its on 1 game called Bust-A-Move on the GameGear, for some reason it cannot display the background properly...the rest of the game is fine..

worked great on the older version (0.05)

Share this post


Link to post
Share on other sites

I found a problem with Final Fantasy 3. After selecting the game I get a line of graphics at the bottom of the screen and then a black screen. When I try to exit with 2 taps nothing happens. I have to close the emulator externally with the memory function.

Share this post


Link to post
Share on other sites

Sorry guys - I'm extremely busy readying stuff for E3. Thanks for reporting more problems ;)

I'll try to fix the problems you've found when I return (after May 14th)

L.B.

Share this post


Link to post
Share on other sites

hey bitbank just want to say great job on ur emu cant wait until u continue your work on it ;) im running game gear games np on it as for gameboy games there running quality on my c500 must be the new update from orange or something with old rom on c500 was getting jolty sound but its all fine now hurry up and continue the work on smartgear!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.