Jump to content
Alex (nedge2k)

UK PSP Important Info

Recommended Posts

Ok, if you havent been following the PSP scene there's a few thing you'll need to know:

1.5 Firmware = Good

2.0 Firmware = Bad

with v1 and v1.5 PSPs you can run homebrew apps and, up until today, firmware after 1.5 wasnt able to do this. A downgrade tool is supposed to be released today which can put v1.51/52 firmware back to 1.5. The UK PSPs are released as 1.52 with a v2.0 upgrade disc.

v2.0 firmware does have a couple of nice features; web browser, wallpaper, avc codec etc. BUT it hasnt been cracked to run homebrew yet.

When i got my PSP you could only run homebrew on v1 and my psp came as 1.5 so i stupidly upgraded to v1.51. A couple months later v1.5 was cracked :oops: A couple weeks ago v2.0 was released and as the was no word of 1.51/52 being cracked, i upgraded to v2.0 and now they're talking about a 1.51/52 downgrade!!! :evil:

www.PSPUpdates.com is a great place for all the latest PSP news btw :)

Share this post


Link to post
Share on other sites

Downgrading your PSP is a very fisky thing.

Someone said that "it can make the PSP a very expensive door stop". It also invalidates your warrantee and you really have to know what your doing.

In sure in time people will crack the version 2. But personally, having my Jakki Degg pic on my PSP is a much changing as im going to do.

Share this post


Link to post
Share on other sites
Guest

Woaw, just tried the pspupdates URL posted above, and before the page had a chance to load, the pop-up blocker started to go crazy.

Won't be trying that again!

Share this post


Link to post
Share on other sites
Woaw, just tried the pspupdates URL posted above, and before the page had a chance to load, the pop-up blocker started to go crazy.

Won't be trying that again!

Doh...sorry...forgot to mention it was heavy with advertising. Get adblock plus and firefox and it wont bother you :) Really is the best news site for psp....they get it all first ;)

I cant get on ps2nfo as they have banned NTL's transparent proxy! Muppets :roll:

Edited by nedge2k

Share this post


Link to post
Share on other sites

I've had my JAP PSP since November last year, and luckily, I didn't upgrade past 1.5 FW

It's amazing. Ridge Racers is the best game ever, in the world, ever amen.

Go on, stop reading about them, and go and buy one :)

Share this post


Link to post
Share on other sites

Whether you update or not depends on what you primarily use your PSP for. I've had mine since the day of the US release a couple months ago and upgraded to 2.0 last week. The web browser is great, it's so much cleaner than the Wipeout "hack". If you primarily use your PSP for games, movies and want to be able to surf the web than upgrade to 2. If you want to run homebrew stuff, keep it at 1.5. Either way, I wouldn't even attempt to downgrade if 2 is already on there, it's not worth the chance IMO.

Share this post


Link to post
Share on other sites
http://ps2nfo.com is way better then pspupdates btw, had my jap v1 psp for 6 months now and i love it :)

<{POST_SNAPBACK}>

Err, I get an error when I go to that site. - "Sorry. The administrator has banned your IP address."

Anyone else get this?

Greg

Share this post


Link to post
Share on other sites

Had my PSP yesterday and love it ;) , it did come with firmware 1.52 but upgraded to 2.0 as I really wanted the web browswer, plus it now supports WPA encryption which I need as that's what I use on my router :)

PSP is awesome :(

Share this post


Link to post
Share on other sites

of course soon you wont have any choice in upgrading cos games will REQUIRE the 2.0 update to actually run (even some films require the upgrade before you can watch them). Personally, I wanna play state of the art games not emulated ones, if i wanted to play emulated games i'd get a gamepark (or just use my PC) :o

Share this post


Link to post
Share on other sites
as long as the game/film sees v2, it doesnt have to be v2 :o

<{POST_SNAPBACK}>

That is very true :( Also playing the emulated games is awsum, I love being able to have my complete Sega/Nintendo/NeoGeo/Mame collection with me!

Fantastic, Also there is a half decent web browser out anyhow :lol: and the backgrounds can be changed on 1.5 as well? cant see the need or reason to update to 2.0.

Share this post


Link to post
Share on other sites
That is very true :o Also playing the emulated games is awsum, I love being able to have my complete Sega/Nintendo/NeoGeo/Mame collection with me!

Fantastic, Also there is a half decent web browser out anyhow :( and the backgrounds can be changed on 1.5 as well? cant see the need or reason to update to 2.0.

How do you change backgrounds on 1.50?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.