Jump to content
TomeQ

Problems with unicode in SMS

Recommended Posts

Hi.

When i'm writing SMS messages i'm using T9 text input. But in my language (polish) there are special characters, which need unicode encoding. So, what's the problem? If i'll enable Unicode option, i'm able to send only 70 character in message, but when i'll disable it, character limit is set back to 140, but... after sending message with special characters (like ą, ć, ż, ź,

Share this post


Link to post
Share on other sites
Hi.

When i'm writing SMS messages i'm using T9 text input. But in my language (polish) there are special characters, which need unicode encoding. So, what's the problem? If i'll enable Unicode option, i'm able to send only 70 character in message, but when i'll disable it, character limit is set back to 140, but... after sending message with special characters (like ą, ć, ż, ź,

Share this post


Link to post
Share on other sites
I guess that the sms center either on your side or the recipient's side is not configured for Unicode.

Try to send to yourself, and see if it will be presented with proper Polish characters.

But enabling unicode in messages = 70 characters max. in one message.

In my last phone (Motorola E1000), disabling unicode = change ą => a, ć = > c, etc. so special chars were removed. But here all special chars are being replaced with "?"...

Share this post


Link to post
Share on other sites
But enabling unicode in messages = 70 characters max. in one message.

In my last phone (Motorola E1000), disabling unicode = change ą => a, ć = > c, etc. so special chars were removed. But here all special chars are being replaced with "?"...

Yes, but probably they are still treated as Unicode in your phone all the time - you will not get question marks in your own phone, no? Only in the recipient's phone?

Edited by flodis79

Share this post


Link to post
Share on other sites
Yes, but probably they are still treated as Unicode in your phone all the time - you will not get question marks in your own phone, no? Only in the recipient's phone?

No, when i will send message to my phone number, i will see question marks too... So i think phone is sending messages with question marks.

Share this post


Link to post
Share on other sites

im polish too and i have the same problem on my Toshiba G500 with WM5. it converts special characters from unicode to question marks instead of normal letters.

anyone knows how to change coding page of messages being sent from phone? i would experiment with this...

Share this post


Link to post
Share on other sites

The following works for sending other Unicode characters in SMS

from http://www.ppcsg.com/lofiversion/index.php/t84361.html

to send [unicode] characters properly, Unicode must be enabled in your device...to enable Unicode, launch your SMS Inbox, select Menu, Tools, Options, click on Text Messages and then make sure the "Use Unicode when necessary" is ticked...

Hope this helps.

Ed

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.