Jump to content
Sign in to follow this  
shenson

T-mobile SIM and Motorola A835 incompatibility...

Recommended Posts

I've been on T-mobile WnW Pro for a while now on the SIM only tariff. I'd used it on an ex-orange C550 with no problems for a few months.

I wanted to try 3G data on it. The "right" (for me) handset wasn''t available at the time so I got an ex-3 Motorola A835 from Ebay.

The handset works fine but when I attempt to power up with the T-mobile SIM it locks up on power up. There is an animated "M" logo and it freezes at that point. Other SIMs work fine. A trawl through various forums suggests this problem is quite common with the latest T-mobile SIMs (and not just on the A835) but no one has a solution. It isn't clear if its a firmware or hardware issue. People with the latest firmware version also seem to have this problem.

Anyone have any suggestions or is the phone unusable on T-mobile?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.