Jump to content
brilliant-green

WIFI Connected, but Can't Browse Internet

Recommended Posts

Hi All, need help.

Now i'm using DXHI3, previously i used DXHI1.

The problem is :

I have Wifi router at my home, and i can connect using my omnia.

But i can't browse using opera/IE. I already check some settings like :

Browser connection, etc. Seems no problem.

Do you know any other setting i must set ? 1st time i used omnia, is hk version DZHH1, and that time, i try and able to connect/browse to internet using wifi.

Please advise... i already try using 2 different wifi, my home, and public wifi, both can't browse internet, but wifi is already connected.

Many many thanksss ;)

Share this post


Link to post
Share on other sites

what did you do so far, did you enter WEP or WPA key used on the router?

Edited by Raul6

Share this post


Link to post
Share on other sites

okay : what i do, is :

1. search for network

2. found my home wifi

3. input WEP key.

4. wifi status show "CONNECTED" to my current wifi.

and then try to browse, always show error, the error is like i'm not connected to internet connection.

did i miss some setting ? or did my installation corrupted ? because i previously using DXHI1, and try to re-flash to DXHI3...

Share this post


Link to post
Share on other sites

I have the same here, but if i connect to a different WiFi unit near me (unlocked) it connects to the Internet.

My old M7-- (HTC Trinity) had no problems so not sure what is happening here...

Z

Share this post


Link to post
Share on other sites

is it because the wifi has wep key ? i already try using free public wifi, also can't browse although connected.

i have question, under the wep key, there's index ( 1,2,3,4), i don't know how to set this index. is it have something to with this index ?

Share this post


Link to post
Share on other sites
is it because the wifi has wep key ? i already try using free public wifi, also can't browse although connected.

i have question, under the wep key, there's index ( 1,2,3,4), i don't know how to set this index. is it have something to with this index ?

Opera>Settings>Connections>Automatically detect settings checked?

After hard resetting yesterday I too couldn't browse via my wifi until I remembered to check this option.

Share this post


Link to post
Share on other sites

you go in Formulations-connect-WI-FI-Card net

select Wlan and modification ........use IP manual and DNS Public o provider.

you will see that it works

ITALIANO

Vai in impostazioni-Connessioni-WI-FI- Scheda di rete, selezioni la scheda di rete WLAN e seti IP manuale e DNS publici o del provider

Esempio

IP andress 192.168.1.12

Subnet Mask 255.255.255.0

Gataway 192.168.1.1 (your router andress)

DNS My provider :

193.70.192.100

195.210.91.100

Sorry my english traslate

Share this post


Link to post
Share on other sites
Opera>Settings>Connections>Automatically detect settings checked?

After hard resetting yesterday I too couldn't browse via my wifi until I remembered to check this option.

Yes, i already setup this thing... still can not.. T__T

Share this post


Link to post
Share on other sites

Here is my setting :

I search my network, and found my wifi, then I go to wifi detail :

"Configure Wireless Network"

===================

Network Name : MywifiNetworkName

Connects To : can't choose anything, empty comboBox.

This is a hidden network ( uncheck )

This is a device-to-device (ad-hoc) connection (disable, and uncheck)

NEXT----

Authentication : Open

Data encryption : WEP

The key is automatically provided - Unchecked

Network key : xxxxxxxxxxx

Key Index : 1

NEXT -----

Use IEEE 902.1x network access control - Unchecked

EAP Type : - disabled

FINISH ------

Do i need to set the network adapter ?

My Network card connects to : blank combobox

- SyChip Jaguar WLAN GSPI Card

- NE2000 compatible Etherned Driver

- AsyncMac NDISWAN Miniport

-........

Share this post


Link to post
Share on other sites

I had a similar problem

But after installing wifi companion by socket v2.10.4.0 it somehow started working- dont know how .. but it works.

Share this post


Link to post
Share on other sites
hi kuteguy, what is the wifi companion by socket v2.10.4.0 ??

where can i get it ?

many thanksss ;)

I believe if you searched in google for 'wifi companion socket ipmart' you might find what you are looking for

Share this post


Link to post
Share on other sites
hi, is there any other way beside wifi companion ?

i just flash back to official DXHH1, and the problem still not fixed, still can't browse... although it's connected to wifi..

Some stupid questions to consider (as normally when I can't get something to work it's an obvious problem I've not noticed):

Are you sure it's connected to wi-fi (i.e. can you download e-mail)?

My Omnia came with Opera and IE. Do both have no browsing facility?

Settings>Connections>Browser Connections. Does changing this setting affect things?

When you say it's not browsing, have you tried browsing a number of sites. My Omnia came with homepages set to a walled garden from the service provider that couldn't be accessed by WiFi connections.

Share this post


Link to post
Share on other sites
hi, is there any other way beside wifi companion ?

i just flash back to official DXHH1, and the problem still not fixed, still can't browse... although it's connected to wifi..

Another stupid question:

Does it say that it's connected. Because i had a problem with my connection because it remained on connecting and didn't connect.

Share this post


Link to post
Share on other sites

Just as a quick thing, I take it all the people having problems have this tweaked?

Start -> Settings -> Connections -> WiFi -> Network Adapters -> My network card connects to "The Internet" rather than "Work"

Share this post


Link to post
Share on other sites
Just as a quick thing, I take it all the people having problems have this tweaked?

Start -> Settings -> Connections -> WiFi -> Network Adapters -> My network card connects to "The Internet" rather than "Work"

*I'm not sure 'bout this, but on my setting, I can't choose the setting, because the option is blank, it's just a blank option, so can't choose anything from "My Network card connects to" , is it the problem ? i didn't change anything, as i just re-flash with old DXHH1. so all i did is just setting some basic setup for WIFI.

*And I also do the other check, to browse to some site, including cnn.com, msn.com, google.com, yahoo.com, all can't browse.

*The status of wifi is already connected. not just connecting... but already connected.

*Browser connection is also "Automatically detect connection"

thanks for the suggestions... T__T..... don't know what to do.......

Share this post


Link to post
Share on other sites

Hm.. i found some strange thing :

I installed WIFI COmpanion, i used the tools :

1. WIFI Ping : to www.yahoo.com, and it can succesfully ping the www.yahoo.com, without timeout, 100% succed

2. WIFI Trace : to www.yahoo.com, and also no timeout, succesfully tracing.

But when i go to opera, and write www.yahoo.com it showed :

============

ERROR!

Network Problem

You tried to access the address http://www.yahoo.com, which is currently unavailable. Please make sure that the web address (URL) is correctly spelled and punctuaed, then try reloading the page.

*make sure your internet connection is active and checked whether other applicaitons that rely on the same connection are working.

============

did i miss something ?

opera setting is already "automatically detect settings"

Share this post


Link to post
Share on other sites
Hm.. i found some strange thing :

I installed WIFI COmpanion, i used the tools :

1. WIFI Ping : to www.yahoo.com, and it can succesfully ping the www.yahoo.com, without timeout, 100% succed

2. WIFI Trace : to www.yahoo.com, and also no timeout, succesfully tracing.

But when i go to opera, and write www.yahoo.com it showed :

============

ERROR!

Network Problem

You tried to access the address http://www.yahoo.com, which is currently unavailable. Please make sure that the web address (URL) is correctly spelled and punctuaed, then try reloading the page.

*make sure your internet connection is active and checked whether other applicaitons that rely on the same connection are working.

============

did i miss something ?

opera setting is already "automatically detect settings"

flash to hi2 and you will not have problems

Share this post


Link to post
Share on other sites

Wish I could help more - from a network perspective it looks fine! i.e. you are able to ping websites

like I said .. I installed wifi companion and then rebooted my phone and it just started working - so I left it at that

fyi> I am on HH1 (the default ROM/RADIO that I got from Vodafone when I got the phone in September)

Edited by Kuteguy

Share this post


Link to post
Share on other sites

Hi all, I'm having the exact same problem, it's really frustrating! I'm able to connect to msn / gmail, but am unable to send email (can receive though) and can't browse too. I'm on a secure network (university network) but by right it should work fine (I've entered my passwords). Settings have been set per the above responses but still no luck. Please help :lol:

Share this post


Link to post
Share on other sites
Hi kuteguy, thx for the help, right now i'm already reflash for HH1.... still can't...

Let me try to reflash to HI2... hope it's fixed.... T__T

many thanks

Am also on HH1 and cannot connect with wifi to my wifi router. Does flashing to HI2 fix your problem?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.