Jump to content
PaSSoA

Step by Step: Learn To Cook Custom ROM

Recommended Posts

nop, don't work for me, no one application on default:( don't start automatically

anyone can help me?

i want install on default(manilla and others) , so why don't automatically run :lol: :D

thx in advance

Share this post


Link to post
Share on other sites

If your talking about Today screen starting automatically, it's in the registry settings and has to be enabled. I think you have to change the DWORD value to 1. Due a search first because I'm not sure of the actual value.

Share this post


Link to post
Share on other sites
If your talking about Today screen starting automatically, it's in the registry settings and has to be enabled. I think you have to change the DWORD value to 1. Due a search first because I'm not sure of the actual value.

hi , for example i want to instal on italian cooked rom ,manilla, how can i do to run it automatically :lol:

thx

Share this post


Link to post
Share on other sites
I have a problem with Divx Registration,i try to remove it,deleted two files from OEMApps and some registry keys,but i don't find a way to remove icon from settings,in initflashfiles.dat there is nothing...anyone can help me?

I think it's hardcoded in one of the files. Aside from those you already mentioned, I also tried a registry trick to at least hide the icon but it doesn't seem to work for me.

Share this post


Link to post
Share on other sites

you mention the latest framework..

shall we install "Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)" which was released M09.08 ?

or the tools we are using are well tested with the previous release., which is more prefered ?

thks.

Share this post


Link to post
Share on other sites

Hi PaSSoA ;)

I've got one little problem... In my rom, Id like to disable unsigned applications warning. I found the right settings in regedit ([HKEY_LOCAL_MACHINE\Security\Policies\Policies]->"0000101a"=dword:1), and this key exists in 2 differents rgu files : one in OS folder and the 2nd in Shell folder. initial value is 0 and I changed to 1. but, when I flash my rom, I always have security warnings, and the value is changed to 0 in regedit :lol: If I change it to 1, no problem. but I want to change it inside the cooked rom... :o

Is there another thing to change, or just change 1 key instead of 2 ? it's really weird :D

Thanks in advance !

Share this post


Link to post
Share on other sites
Dear, Could u pls tell me that where is the .rug file??? Open the .rgu which contains registry settings in Notepad.

The .rgu files appear when you drag'n drop your into ExtractROM_exe.cmd. Be sure that you've Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) installed, and all windows hiding files options disabled :lol:

Share this post


Link to post
Share on other sites
The .rgu files appear when you drag'n drop your into ExtractROM_exe.cmd. Be sure that you've Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) installed, and all windows hiding files options disabled :lol:

hi guys... I have installed the latest ms visualc++ sp1, i have downloaded the latest rom i900DZHJ1_updater_xp.exe but I get some errors.

Is it something I am doing wrong ? below you may find the steps i follow..

Thanks in advance for you support and help.

- download i900DZHJ1_updater_xp.exe

- rename it to a.exe

- drag n drop on extract.exe.cmd and i get the following errors..

Extracting ROM. Please Wait......

OS ROM Partition Tool V1.48 By Weisun :> PDAclan.com

ERROR - Can not open the source file

The system cannot find the file specified.

OS ROM Partition Tool V1.48 By Weisun :> PDAclan.com

ERROR - Can not open the source file

OS ROM Partition Tool V1.48 By Weisun :> PDAclan.com

ERROR - Can not open the source file

Extracting Imgfs. Please Wait......

Extracting XIP. Please Wait......

usage dumprom file.nb

Extracting OEM and SYS. Please Wait.......

The system cannot find the file specified.

The system cannot find the file specified.

The system cannot find the file specified.

The system cannot find the file specified.

Clean-up of unnecessary files......

The system cannot find the file specified.

Could Not Find D:\cooking\i900Romkitchen\i900Rom\pda.*

Could Not Find D:\cooking\i900Romkitchen\i900Rom\imgfs.bin

Could Not Find D:\cooking\i900Romkitchen\i900Rom\XIP.bin

All ROM files have been extracted. Start BuildROM after customisation......

Press any key to continue . . .

Share this post


Link to post
Share on other sites

Really really weird :lol:

Are you running under XP or Vista ? XP is better

Are you using the kitchen form #1 post ?

Maybe you have to make a new directory (a short name, like "C:\i900\") and extract rar (with winrar and nothing else) files inside, and verify that everything inside are not in read-only mode, and off course your rom file. Disable your firewall and antivirus. I dont know if these advise will change anything, but have a try :D

and try with another old rom at the end...

Share this post


Link to post
Share on other sites

One last question... Do you have .NET installed on your PC ? Because at work ( :D ), I tried to extract a rom, and I had the same error as your... I installed last .NET and everythings fine :lol:

Share this post


Link to post
Share on other sites

why its not possible that buildos overwrites files that already exist?!?!?! thats crap!! if i build an os for example flaslite31 and opera beta it always stops because an file already exist... thats awfull

i will try it the last time at this forum to ask a question and i hope some of the proguys may help... its not ok that just one of my posts has been replayed... why?

so lets try

how did i install NetCF3.5 and Flashlite3.1 and Opera9.5beta so that all work?

here is what i do but it wont work.

i found the cab-files and make them oem! then i copy and past them to OEMApp folder and drag and drop the OS.nb to BuildRom.cmd. it starts to work and after some secs. all jobs are done... but if i flas the rom.exe which i build with i900tool.exe nothing of this three things work... why?

and the worst work is to implement opera... 200 times an error because some files allready exist in dump folder... grrrrrrr....

so pleas PaSSaO, Paul or some one who reach it that this three things work, HELP!!! =)

you could see my effort !!!here!!!

Edited by black-DraGon

Share this post


Link to post
Share on other sites

It is very tedious to remove Opera, you have to remove the old version before cooking in the new version. It has many files, dlls and registries that have to be removed. I, unfortunately do not have the patience to do that :lol: and furthermore I am happy with the original build.

Also, the OEM packages for your programs should be in \OEM\ folder not \OEMApps\ folder. When you buildos, remember to make sure the programs are checked before building.

But good work on your ROM and hope you can find all the files to remove, don't forget there are many Opera entires in initflashfiles.dat too.

Share this post


Link to post
Share on other sites

Yup, all my ROMs are using Opera 9.5 Build 2520. It's not the latest but it works great on the Omnia, so why make your life more complicated? Furthermore it works with FL3.1, but as usual, make sure your remove all the old FL2.0 files and registries first.

Share this post


Link to post
Share on other sites

hi PaSSaO thanks for info...

now i will try to install it again... you are right with the oem dir... make a little mistake yesterday.

did i have to remove saplaywm etc. as well`?

i use Find-iT for searching all the strings in the data and there are many things that the tool found...

maybe you have some more tips =)

files wich i found for flashlite are: axobjects.ini, flashlite.dll, saplaywm.exe, si_impl.dll and widgetidle.dll...

some missing???

*edit*

damn man... i cant do it... no netcf and no flashlite... what im doing wrong???

Edited by black-DraGon

Share this post


Link to post
Share on other sites

just a question, when you add oem packages into the ROM, are the program installed into the windows folder or can I choose which folder to install in?

Share this post


Link to post
Share on other sites
hi PaSSaO thanks for info...

now i will try to install it again... you are right with the oem dir... make a little mistake yesterday.

did i have to remove saplaywm etc. as well`?

i use Find-iT for searching all the strings in the data and there are many things that the tool found...

maybe you have some more tips =)

files wich i found for flashlite are: axobjects.ini, flashlite.dll, saplaywm.exe, si_impl.dll and widgetidle.dll...

some missing???

*edit*

damn man... i cant do it... no netcf and no flashlite... what im doing wrong???

There are more flashlite files are also many registries. Did you remove the old netcf in the sys folder and also it's registries?

just a question, when you add oem packages into the ROM, are the program installed into the windows folder or can I choose which folder to install in?

You have to edit the initflashfiles with the package creator to point them to the correct folders. Eg. \Program Files\WhateverApp\ or \Start Menu\Programs\shortcut.lnk

Share this post


Link to post
Share on other sites
There are more flashlite files are also many registries. Did you remove the old netcf in the sys folder and also it's registries?

yes i did ive searched all folders and files wiht NetCF and flashlite entry

could you plz post the filename of this files?

Edited by black-DraGon

Share this post


Link to post
Share on other sites
yes i did ive searched all folders and files wiht NetCF entry

Then it might be a problem with the package. Try another package or cab.

Share this post


Link to post
Share on other sites

On Omnia is possible to use SDAutorun to add a small cabs or custom registry entries?

If is possible...how to?

Share this post


Link to post
Share on other sites

Hi there!

I would like to ask something. I come from greece so my omnia has a greek rom and of course a greek keyboard. Since I've tried the passoa's rom with m2d and I liked it, is there a way that I could have the manilla 2d on my phone without loosing the greek keyboard? Is there a way I could cook a rom like passoa's but with the greek oem keyboard?

Thanks for any answer!

B)

Share this post


Link to post
Share on other sites

I want to change this registry key:

HKLM\Security\Policies\Policies000101a

At default it's setted to 0 i want to set at 1.

I change the dword in default.hv and in another .rgu file,but when i flash the custom rom on my Omnia,this key is setted at 0...anyone can help me?

  • Upvote 1

Share this post


Link to post
Share on other sites
I want to change this registry key:

HKLM\Security\Policies\Policies000101a

At default it's setted to 0 i want to set at 1.

I change the dword in default.hv and in another .rgu file,but when i flash the custom rom on my Omnia,this key is setted at 0...anyone can help me?

You have to put that new key in another file, not a .rgu, but a .provxml file, like mxip_oemdrivers_105.provxml in your OEM\OEMDrivers folder. It take a loooong time for me to find this, but it works B)

like this :

			   <characteristic type="HKLM\Security\Policies\Policies">

					 <parm name="0000101a" value="1" datatype="integer" />

			   </characteristic>

Edited by JonPhone

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.