Jump to content
BeamRider

OmniaTMC Beta 2 (and unofficial Beta 3)

Recommended Posts

anyone here from Australia can get this TMC work? I live in Sydney and use 106.5 FM here, got the TMC signal in OmniaTMC and in IGO8.

However, in IGO doesnt show any Traffic Information.... it says CA-TMC (key ok).

I think over here, its subscription based, provided by SUNA, where usually the subscription already included when purchasing new standalone GPS devices, e.g. TomTom, Navman, etc...

Any ideas guys how to get this thing working? =(

Another question regarding radio antenna + car charger problem.. is there any ways I can charge the phone in the car while getting the radio signal as well without using modified car charger (i dont know how to solder etc etc)..

Will this be useful / work? http://www.fommy.co.uk/view-full-page.asp?...amp;skuno=82507

THanks in advance.

Edited by alvinezz

Share this post


Link to post
Share on other sites
so how do i get igo8 to detect it? what settings do i need to put into the tmc bit?

In iGo8, change the port for TMC to whatever you have in OmniaTMC, and leave other settings to auto.

Share this post


Link to post
Share on other sites
In iGo8, change the port for TMC to whatever you have in OmniaTMC, and leave other settings to auto.

Where do you set the port? The only settings I have is a tick box for "Use Auto tuner"

Share this post


Link to post
Share on other sites
Where do you set the port? The only settings I have is a tick box for "Use Auto tuner"

next to the gps port bit lower down in omniaTMC

In iGo8, change the port for TMC to whatever you have in OmniaTMC, and leave other settings to auto.

right i did that but it says no tmc hardware found?

Edited by lostunsunghero

Share this post


Link to post
Share on other sites

Hi!

OmniaTMC works well on my Omnia with DXIA5 ROM.

But... If I use TMC or don't (doesn't matter) after using iGO the battery's lifetime is much more less.

Sorry for my bad english.

I can use my device for 4-5 days without charging if I deactivate the TMC or make 2 softreset after using it.

If I use it, it's only 2 or less days...

nbs86

Share this post


Link to post
Share on other sites

To lostunsunghero and nbs86,

Can you check if you have this line in sys.txt?

Source="virtlserial"

It should be in [gps] section.

Share this post


Link to post
Share on other sites
To lostunsunghero and nbs86,

Can you check if you have this line in sys.txt?

Source="virtlserial"

It should be in [gps] section.

In my sys.txt for the [gps] section:

[gps]

port=3

baud=4800

source="virtlserial"

disable_advanced=0

It's working fine except the problem with the battery's lifetime after using (or not using, but in active mode) it.

Share this post


Link to post
Share on other sites
To lostunsunghero and nbs86,

Can you check if you have this line in sys.txt?

Source="virtlserial"

It should be in [gps] section.

You are in the US and it's working for you? I mean you get any free stations?

Share this post


Link to post
Share on other sites

Hallo Billou,

Sorry to tell you, but the below mentioned connector from Fommy, does not work for FM reception. A ready to use solution can at the moment not be bought. The best solution I could find is described in post 298 in this thread.

W

Work fine at home ( France )

Now my problem is for have a charger + fm ... ( I have a car charger with usb cable but I don't know if I can modify the usb cable for plug in it ... )

Maybe someone sold it ?

Edit : I think that is work : http://www.fommy.com/view-full-page.asp?skuno=82507

Share this post


Link to post
Share on other sites
Hallo Billou,

Sorry to tell you, but the below mentioned connector from Fommy, does not work for FM reception. A ready to use solution can at the moment not be bought. The best solution I could find is described in post 298 in this thread.

W

Oky thanks for your response, but I'm not good in electronic lol

Oh well, I use my GPS without TMC ;)

Share this post


Link to post
Share on other sites

I installed everything, and can find lots of stations streaming data from the OmniaTMC test/config app. When I scan with it, it finds and stops on probably half a dozen stations here across the FM dial in the Santa Cruz, CA area.

I also made the changes specified in my iGO8 config file. iGO finds the port, says there is TMC hardware, and looks good from that standpoint. HOWEVER... Autotune in iGO doesn't do anything, and if I uncheck it the manual controls don't do anything either. It just stays on FM 88.5 (or whatever that lowest frequency is that it starts with), no matter what button I press.

Anyone have any insight on how to fix this?

Share this post


Link to post
Share on other sites
To lostunsunghero and nbs86,

Can you check if you have this line in sys.txt?

Source="virtlserial"

It should be in [gps] section.

Hmmm... It's working fine now.

The problem was with my iGO8 link. It's start my old version of igo with wrong sys.txt (There was no source="virtlserial") Changing the link to point to the good igo8.exe and voila it's working fine and after using it no problem with the battery.

Anyway thank you for your help!

Sorry for my english.

Share this post


Link to post
Share on other sites
I installed everything, and can find lots of stations streaming data from the OmniaTMC test/config app. When I scan with it, it finds and stops on probably half a dozen stations here across the FM dial in the Santa Cruz, CA area.

I also made the changes specified in my iGO8 config file. iGO finds the port, says there is TMC hardware, and looks good from that standpoint. HOWEVER... Autotune in iGO doesn't do anything, and if I uncheck it the manual controls don't do anything either. It just stays on FM 88.5 (or whatever that lowest frequency is that it starts with), no matter what button I press.

Anyone have any insight on how to fix this?

Start igo and set the tmc to manually mode. You can't change the frequency but do not close the igo only send it to the background. Start OmniaTMCSetup. Set the freqenncy you want. (Sometimes it's need to close and start again to set the frequency) And go back to igo and it will working now. Sorry for my english.

Share this post


Link to post
Share on other sites

i fixed the TMC problem, thank you VERY much. Unfortunately, I can't navigate at all since I get a:

"cannot find path, maps are isolated"

anybody help????????????????

Share this post


Link to post
Share on other sites

For those in Canada, most stations showing RDS data in OmniaTMC turn out to have "No TMC signal" in iGo8. I did find one station (97.9 in Ottawa) that usually shows "TMC State Unknown", but sometimes shows "CA-TMC (No key)". I understand that there are also such stations in at least Montreal and Toronto. I will test in New York City soon. I assume that some sort of key is still needed for decoding. How can I get such a key (ideally one that would work in both the Canada and USA)?

Edited by itb44

Share this post


Link to post
Share on other sites
Another question regarding radio antenna + car charger problem.. is there any ways I can charge the phone in the car while getting the radio signal as well without using modified car charger (i dont know how to solder etc etc)..

I am able to use the USB cable as antenna and charger while slow-charging form a cig. lighter adapter that happens to have a USB charging port on the side.

Share this post


Link to post
Share on other sites
iGO finds the port, says there is TMC hardware, and looks good from that standpoint. HOWEVER... Autotune in iGO doesn't do anything, and if I uncheck it the manual controls don't do anything either. It just stays on FM 88.5 (or whatever that lowest frequency is that it starts with), no matter what button I press.

Anyone have any insight on how to fix this?

I have the same issue, but can make it work by manually tuning OmniaTMC and leaving it running before returning to iGo8. Then iGo8 uses that station even though tuning not working at all from my iGo8 (ver. 8.3.2.64029).

EDIT: PDA-derived versions of iGo8 seem to have the above broken TMC tuner requiring the above work-around when used on Omnia, but PNA-derived versions of iGo8 seem to have a working tuner on Omnia, FWIW.

Edited by itb44

Share this post


Link to post
Share on other sites

I've found out the following about TMC in North America. TMC Clear-Channel USA depends on the presence of a signal de-scrambling routine (CODEC) with correct deciphering key(s), which are NOT the same as activation keys. Apparently, at least my version of iGO8 (ver. 8.3.2.64029) either does not have a valid deciphering key for the CODEC or the CODEC itself is missing from the executable. The TMC license and activation keys are just for enabling the software to display traffic events on the TMC info page. Thus, I still see "CA-TMC (No Key)" instead of "CA-TMC (Key OK)". Does anyone have a version that shows "CA-TMC (Key OK)" for TMC data received anywhere in the USA or Canada? If so, which version of iGo8 are you using, and which broadcast station?

Even if I had a different iGo8 version that included the CODEC and therefore showed "CA-TMC (Key OK)", I've heard that I still probably wouldn't get actual traffic info/updates enroute or in the TMC info page to show on the phone without a subscription assigned to my particular UUID. I read that a lifetime subscription might be available through various PNA device sellers for about $50-60, some per year and others per "lifetime" (of the particular UUID), but I'm not sure where to find my UUID, or if those resellers would even sell the subscription for a PDA. I think NNG offers this in iGo Pro releases for Europe, but not North America.

EDIT: I'm going to guess that the CODEC presence can be solved if that code is included (or can be added or activated) in a particular version of iGo. I'm actually not sure whether or not it's already there. It may already be present in at least the "Pro" versions of IGo. I guess the key could also be solved that way if the same code corresponded to a range of UUIDs (or presented a generic one). Otherwise, I think the key is what comes by subscription and must correspond to the UUID presented by the device. I have no idea what the UUID is of a non-PNA device -- that is, does an Omnia or other PDA even have a UUID?

Edited by itb44

Share this post


Link to post
Share on other sites

Please delete (posts consolidated)

Edited by itb44

Share this post


Link to post
Share on other sites

OmniaTMC Beta 2 testing with different versions of iGo8 on my Omnia:

iGo8 8.0.0.29000: "No TMC Hardware Found!"

iGo8 8.3.2.64029: "CA-TMC (No Key)". IGo8 PDA TMC tuner broken, so tune manually using OmniaTMC and leave it running.

iGo8 8.3.2.93112: "CA-TMC (No Key)". IGo8 PNA TMC tuner works!

iGo8 8.3.2.97313: "CA-TMC (No Key)". IGo8 PDA TMC tuner broken, so tune manually using OmniaTMC and leave it running.

If anyone finds a version of IGo8 that displays "CA-TMC (Key OK)" from the Settings/TMC screen (rather than "CA-TMC (No Key)") anywhere in North America (Canada and/or USA), please post here. Thanks ;)

Share this post


Link to post
Share on other sites

Same here buddy. Appears tp me that TMC on iGo works only in countries that have a free TMC stations setup as public services. No chance of that in "money money money" Canada or USA. And governments here are hardly likely to do anything about it since they employ people who dont have to use their heads much.

OmniaTMC Beta 2 testing with different versions of iGo8 on my Omnia:

iGo8 8.0.0.29000: "No TMC Hardware Found!"

iGo8 8.3.2.64029: "CA-TMC (No Key)". IGo8 PDA TMC tuner broken, so tune manually using OmniaTMC and leave it running.

iGo8 8.3.2.93112: "CA-TMC (No Key)". IGo8 PNA TMC tuner works!

iGo8 8.3.2.97313: "CA-TMC (No Key)". IGo8 PDA TMC tuner broken, so tune manually using OmniaTMC and leave it running.

If anyone finds a version of IGo8 that displays "CA-TMC (Key OK)" from the Settings/TMC screen (rather than "CA-TMC (No Key)") anywhere in North America (Canada and/or USA), please post here. Thanks ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.