Jump to content
BeamRider

OmniaTMC Beta 2 (and unofficial Beta 3)

Recommended Posts

Just made an interesting discovery.

If i connect the wall plug cable (220V charger) i am actually able to receive TMC in Germany :excl:

Although reception is not that good as with the headset cable it does receive TMC event if i don't connect the cable to a wall plug.

I tried with 2 different - original Samsung - 220V charger type ATADS10EBE

That means that the antenna isn't shorted in the plug that goes in the Omnia which makes it quite easy.

You only have to open the end that goes to the wall plug and solder it to a car charger and you might even be able to extend the antenna because it must go through the whole cable.

I just need to buy a spare 220V charger, open it (you will probably have to damage it because i couldn't find any screws), take out the cable, open the car charger and solder the wall charger cable to the 12V plug.

Should work...

Heheh bit late... Read a few pages back :excl:

Edited by illusion786

Share this post


Link to post
Share on other sites

Thanks for this awesome application, this is really a very good idea.

I see a problem though, when I use my Omnia with iGo8, the Battery only lasts around 1 hour before reaching 20%. I already have bought a car adapter to solve this problem, but unfortunately the plug is the same as the plug for the headset (and therefore also for the radio).

Would it be possible to insert something like a split cable, to have both headset and power cable plugged in? Would the Omnia support that?

Share this post


Link to post
Share on other sites
Thanks for this awesome application, this is really a very good idea.

I see a problem though, when I use my Omnia with iGo8, the Battery only lasts around 1 hour before reaching 20%. I already have bought a car adapter to solve this problem, but unfortunately the plug is the same as the plug for the headset (and therefore also for the radio).

Would it be possible to insert something like a split cable, to have both headset and power cable plugged in? Would the Omnia support that?

No, it's not possible beacuse chargers usually short antenna to GND

Share this post


Link to post
Share on other sites
Yes it should because you were using a coax cable, with pin 2 connected the cable shield was shielding your antenna from signal (as it is supposed to do). That's why I suggest to not use coax cables for standalone antenna application.

I remade the antenna with no 3.5mm jack. ( Click here for previous antenna )

Pics are below. im impressed with this antenna as it gives me full radio reception (95%). The antenna is only 10 inches long which also means i dont have any dangling extra wires and is very portable .

I got a 2pair twisted copper wire from a telephone extension drum i have.

Stripped the plastic off from the telephone cable.

I then got a spare cable with a black plastic/rubber outer. Gently pulled out the inner wire and inserted the copper wires from the telephone extension.

I then cut the flexi rubber from the 3.5mm jack cable and cleaned the inside to make way for the new rubber cable.

Also took the connector from the 3.5mm cable and soldered the wire to pin one.

There is no connection to pin 2, which is why i have full reception.

job done

SNC00039.jpg

SNC00040.jpg

SNC00041.jpg

SNC00042.jpg

SNC00043.jpg

SNC00044.jpg

SNC00045.jpg

SNC00046.jpg

SNC00048.jpg

SNC00049.jpg

Edited by illusion786

Share this post


Link to post
Share on other sites
Heheh bit late... Read a few pages back :excl:

I only see BeamRider saying that it's not working for him but how comes that i receive TMC with the 220V charger cable and not with the car charger cable?

That must mean that in the 220V charger cable GND and Antenna are not shorted or am i wrong?

Would be nice if someone could explain that :excl:

Share this post


Link to post
Share on other sites
I only see BeamRider saying that it's not working for him but how comes that i receive TMC with the 220V charger cable and not with the car charger cable?

That must mean that in the 220V charger cable GND and Antenna are not shorted or am i wrong?

Would be nice if someone could explain that :excl:

I leave in a very bad place to receive radio signal ... Reagrding the power adapter, the only explanation I have is that the two pins are not shorted, the antenna pin is acting as antenna and the GND cable is extending the ground plane of the antenna (acting as half of an antenna) helping the recpetion of radio signals.

Share this post


Link to post
Share on other sites

Hi Beamrider,

"Does you splitter have a S20 (the same connector that Omnia has) replicated port? Does TMC works if you connect the headset adapter to the replicated port?

If you answered yes to the above questions, you may only need a simple antenna harness just like the one made by illusion786 shown on the previous page."

I have this one : http://www.fommy.co.uk/view-full-page.asp?...amp;skuno=82507

Tonight I have tried a few things with that port splitter and here are the results.

- Yes it has S20 connector. When looking at connector with magnifiing glass it seems all pins are there on the Omnia side

- The 2 replicator ports (again 20 pins samsung) are also fully loaded (20 pins)

- But whatever I try no reception of a radiostation (let alone TMC). Of course as soon as I plug my headset directly in Omnia I have no problem at all. Seemed they have shortened the antenna pin directly in connector - I can't check because the connector can not be opened without destroying it.

- Can confirm note from gemx that wall charger does indeed work as antenna as well (original wall charger that came with Omnia). However, reception is by far not as good as headset and of course has no audio connections

- Looked at headset connector as well but there pin 1 and 2 are just not present in Omia connector, so no way we can turn that into a audio + charger + antenna cable

-looked around internet but have not really been able to find alternative port replicator (this - http://www.mobilefun.co.uk/samsung-omnia-t...able-p18478.htm - comes close to needed functionality but I doubt if there is an antenna in there. The Samsung video cable I have also doesn't work as antenna.

- I wouldn't mind build my own audio/ charger / antenna cable but that combination seems impossible to build. Only if you have a loose Omnia S20 connector (with all the needed pins) which so far I have not been able to find on the web.

Also looked at your comment around settings in iGo. I changed GPS from port0/57600 to port 3/4800. Left TMC at port 4. Everything worked more or less the same. If music is playing (on headset) and then start iGo, iGo can't find GPS and TMC anymore (and I need to reset to get GPS and TMC working again. If iGo is working with TMC all sound is distorted (as if d/a convertor can't cope / frequency is to low).

Oh and something else I found out... if you switch of your phone then the gps and tmc/radio receiver is also completely switched off. Hadn't noticed in the 9 months I have my Omnia now.

That's it for today....

Share this post


Link to post
Share on other sites
The "low frequency noise" effect is caused by some interaction between iGO audio settings and FMRadio that I'm investigating. The audio output is working but playback is extemely slow (appears a wrong sampling rate on playback). If you raise the volume to a very high level you'll notice that it's just the "click" sound.

Yesterday I finished my charger/antenna adapter and it is working. By using a charger as antenna audio routing does not happen anymore and output remains on speaker. This is the best option because I can charge the phone on car/bike while receiving stations.

Does the "audio from speaker" option makes sense if headset isn't needed anymore?

(asking your opinion ... to me no, but I can make it configurable from the tool)

If so, it doesn't make sense, I agree.

(I [wrongly] supposed that the "headset available" pin was mandatory for antenna receiving...)

Cheers

Share this post


Link to post
Share on other sites

Hi all!

Does anyone have any idea why doesn't it work with IGO 8.0? With IGO 8.3 it works like a charm, but my genuine IGO is 8.0, and I don't like warez. :excl: So I'm looking for a solution for my 8.0.

IGO finds the TMC receiver but I can't search through frequencies neither in auto nor manual mode, it always shows 0.0MHz. Then IGO looses the TMC receiver for a while then finds it again then looses, then find it, and so on...

Share this post


Link to post
Share on other sites

Sorry, I, m a liitle confused. What do I need to make it possible to run your prog for the XPERIA. What dll I or you need ? Sorry for my question. I can start the OmniaTMC pro and when I start the Activate AdvFMR he says to me "Registry key not found unable to activate" Can you help me plz. -?

Share this post


Link to post
Share on other sites

Is there a possibility to let the sound go trough the speakers when the headphones are connected? OmniaTMC works like a charm, but I hate it that the sound goes trough the headphones.

Men, we need a build-in antenna in a phone, so we can throw away our TOMTOMS etc. :excl: If Samsung would make a new phone with a build-in antenna we could receive TMC without headphones.

Maybe I should mail samsung. I think if there was a Cellphone with all of that, many would buy it

Share this post


Link to post
Share on other sites
Is there a possibility to let the sound go trough the speakers when the headphones are connected? OmniaTMC works like a charm, but I hate it that the sound goes trough the headphones.

Men, we need a build-in antenna in a phone, so we can throw away our TOMTOMS etc. :excl: If Samsung would make a new phone with a build-in antenna we could receive TMC without headphones.

Maybe I should mail samsung. I think if there was a Cellphone with all of that, many would buy it

Unfortunately, as far as I know, they took opposite direction.

In the next gen they took off GPS chip at all, preferring digital TV receiving. :excl:

Hope they are just rumors...

(I was complaining about the fact that Samsung did not use SIRF-III chipset, that is reeeeeeally better than qualcomm, but now, standing on that rumors, I'm not complaining at all... :excl: )

Anyway, for those who are quite confused about pin numbering, like me, here you are the scheme:

samsung_20p.gif

My main issue now is, how to open that bloody connector with my bear-like hands ?!?! :excl:

Ciao

Edited by Fabione72

Share this post


Link to post
Share on other sites
Men, we need a build-in antenna in a phone, so we can throw away our TOMTOMS etc.

Have a look at my post above. You can use my antenna as an example.

Anyway, for those who are quite confused about pin numbering, like me, here you are the scheme:

samsung_20p.gif

I swear that layout is the wrong way round ???

Pin 1 & 2 are on the right side and 20 is on the left. I know cause i made my antenna using the opposite pins and is working....

please correct me if im wrong.

Edited by illusion786

Share this post


Link to post
Share on other sites
Have a look at my post above. You can use my antenna as an example.

I swear that layout is the wrong way round ???

Pin 1 & 2 are on the right side and 20 is on the left. I know cause i made my antenna using the opposite pins and is working....

please correct me if im wrong.

Yeah, but I can't do that :excl: Too difficult for me.

Share this post


Link to post
Share on other sites
Have a look at my post above. You can use my antenna as an example.

I swear that layout is the wrong way round ???

Pin 1 & 2 are on the right side and 20 is on the left. I know cause i made my antenna using the opposite pins and is working....

please correct me if im wrong.

Hi,

I guess PIN numbering is causing a lot of confusion... :excl:

I/We just need to understand if they are counted wathing the connector from the plug, or watching it from the soldered cables.

I searched that image on the internet 'cause i didn't find anythig on any post.

For sure you get the right position.

Would you please post what it the right counting rule? I guess it'll be very usefull :excl:

Ciao

PS

in the meantime I broken a plastic latch of my car-charger connector (same brand posted by BeamRider) with my word-unfamous bear-hands... :excl:

It would be great to find samsung connectors for sale, and to produce a customer cable with 3 wired cables (Vcc,GND,antenna), unfortunately I didn't find anything on internet.

That's the only way I see to get out of this problem...

Doeas anybody of you tried this way as well?

CIAO

Share this post


Link to post
Share on other sites

Hi!

I have the same problem with restarting iGO 8.3.2.83157 and then at second start TMC is not present. Is a solution available? I use OmniaTMC 0.9.3.8.

Thanks alot for this driver, that gives the omnia a new feature! :excl:

UPDATE:

I have added that line:

[gps]

source="virtlserial"

to sys.txt and now it finds the TMC every time! :excl:

Edited by Wetzer

Share this post


Link to post
Share on other sites

Hi, iGo doesn't show the cop routine controles as speed camera's. My iGo gives 2 options: avoid and don't avoid.

I want to hear a voice or beep if i'm approaching a routine controle. I don't want to avoid them, because maybe I will be driving 20km's more or something like that. Any solution?

Share this post


Link to post
Share on other sites

WOW.. I really like this TMC app.. I use it together with iGO8.3.2.83157 and am receiving traffic info.

However, my GPS keeps disconnecting now and then for a fraction of a second and then reconnects again. It neither get's any data from the enhanced GPS (which uses a new server address as I read here: http://www.modaco.com/content/i9x0-omnia-h...ta-for-the-gps).

Could this be an iGO issue, or WM6.5? Or does it have to do something with the OmniaTMC?

In OmniaTMC I'm using port 4 for TMC and 3 for GPS. In iGO8 the same ports.

Best regards.

San

EDIT: I think I've already solved it, someone said in another topic to press and hold the reset button for 30 secs, after this it looks stable again..

Edited by SKonig

Share this post


Link to post
Share on other sites

Hi folks,

so today I received my 2nd car charger. So I will try again to modify it with the tmc antenna. Last week I received the first "real" tmc warning on the highway. So I took the redirection of my route :-)

@Beamrider: Today, I will finally donate your work :-) Thanks again for the great app. I hope we will receive soon a second beta :-)

Share this post


Link to post
Share on other sites

Hi! Great piece of software!

Tested today, here are my results:

- v8.3.2.71348 doesn't show correctly in the settings, the green signal level bar. The bar stays black, the events are received, however. Sometimes the driver locks up, it's not possible to tune frequency (stays at the last good known) the bar shows green 100%, no events are coming. Restarting iGO fixes the problem.

- v8.0.0.55127 doesn't work at all, no TMC. Frequency can't be tuned (stays az 0.0MHz). It crashes the system too, no other GPS software would work after running and exiting it. Resetting device will allow other GPS apps, but this one will still not work.

The entry

[gps]

source="virtlserial"

is added to both version's sys.txt.

Thanks and keep up the good work!

Share this post


Link to post
Share on other sites

As I'm not able to make soldered connection to my toaster even, I was trying to find something, what will be replacement of such. Well, looking at the description - it SHOULD work.

Here's the link:

Samsung S 20 pin Multi Adapter AAET554CBE Omnia i900 UK

alternatively, you can Google for: Samsung S 20 pin Multi Adapter AAET554CBE Omnia i900. As the cost is (I think) acceptable, I'll buy it, and when will be delivered, I'll try to have some TMC working on it :D

Share this post


Link to post
Share on other sites
As I'm not able to make soldered connection to my toaster even, I was trying to find something, what will be replacement of such. Well, looking at the description - it SHOULD work.

Here's the link:

Samsung S 20 pin Multi Adapter AAET554CBE Omnia i900 UK

alternatively, you can Google for: Samsung S 20 pin Multi Adapter AAET554CBE Omnia i900. As the cost is (I think) acceptable, I'll buy it, and when will be delivered, I'll try to have some TMC working on it :D

Great idea. The adapter is already discussed at this forum : http://www.modaco.com/content-page/271740/...solved/page/60/

Should be great if it works.

Edited by Mike5678

Share this post


Link to post
Share on other sites

Hi,

I´m on IGO 8.3.2.79297 and everything is ok. Great job.

IGO on My storage without installation (only create shortcut in \windows\start menu)

TMC port set to 4

GPS port set to 2

I´m in Luxembourg and could get all traffic information in Belgium :D :lol:

Edited by jclsm

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.