Jump to content

Recommended Posts

For those of you who have had both Omnia's, what is your review of the Omnia's II GPS performance?

Do you notice quicker locks?

Does the Omnia II heat up very bad like the Omnia I?

Does the Omnia II's battery drain quickly with GPs the same way the Omnia I did?

Please share your experiences with the Omnia II GPS. I plan on using the GPS very frequently once i get it.

Share this post


Link to post
Share on other sites
For those of you who have had both Omnia's, what is your review of the Omnia's II GPS performance?

Do you notice quicker locks?

Does the Omnia II heat up very bad like the Omnia I?

Does the Omnia II's battery drain quickly with GPs the same way the Omnia I did?

Please share your experiences with the Omnia II GPS. I plan on using the GPS very frequently once i get it.

Hey there~

I traded it in my Omnia 1 3 weeks ago for the Omnia 2. Here's what I've got:

GPS on the Omnia 2 is definitely faster and more accurate.

1) With the Omnia 2, i could pin point my exact location (even walking on a pavement).

2) It took me about a minute to get a fix for a cold start and for hot start, about 10 to 15 secs.

3) In terms of battery consumption, i'll have to say its similar to Omnia 1.

4) Omnia 2 doesn't really burn up like the Omnia 1 when it's on GPS, so that's a real plus.

Hope this helps.

Edited by myglowinghalo

Share this post


Link to post
Share on other sites
Hey there~

I traded it in my Omnia 1 3 weeks ago for the Omnia 2. Here's what I've got:

GPS on the Omnia 2 is definitely faster and more accurate.

1) With the Omnia 2, i could pin point my exact location (even walking on a pavement).

2) It took me about a minute to get a fix for a cold start and for hot start, about 10 to 15 secs.

3) In terms of battery consumption, i'll have to say its similar to Omnia 1.

4) Omnia 2 doesn't really burn up like the Omnia 1 when it's on GPS, so that's a real plus.

Hope this helps.

agree

1) +1

2) cold - 30-40s hot 5-15s

3) +1

4) +1

Share this post


Link to post
Share on other sites
agree

1) +1

2) cold - 30-40s hot 5-15s

3) +1

4) +1

Is that normal that the phone call function disabled also the GPS disabled simultaneously? Mine gets this strange behavior and so my GPS cannot be operated while phone offline.

Share this post


Link to post
Share on other sites

Did not have the Omnia 1 so can't compare but mine takes a good 5-7 mins to get a fix with or without the XTRA data.

I have tried IGO8, TT7 and also use GPSTest and VisualGPSce. VisualGPSce seemed better at showing what was going on. I have the Samsung stock UK 6.5 ROM.

PDA - II9

CSC - II9

Phone - II6

How do you guys get such a fast GPS Fix?

Regards

Edited by yshaikh01

Share this post


Link to post
Share on other sites

hello

my older PDA is the Asus P535 with SiRF 3 GPS chip, i think this is very good and have a stable satellite(GPS) Signal.

the omnia 2 does not make me happy in relation to GPS.

newer ROMs makes it a little bit better, but needs more work for a better GPS.

i also hope this can optimized inside the software/firmware.

now i used Firmware CSC/PDA/Eboot: 8000NXXIJC and phone IK2 , i think this is a little bit better then PDA-II9/phone-II6

if someone has a better suggestion which ROMs are better ?

Share this post


Link to post
Share on other sites

I bought the i8000 mainly to use with memory-map ordnance survey maps I have purchased. Initially I was disappointed with the internal gps performance but as i have got a bluetooth gps receiver I carried on using that. Since I flashed IJ9 the internal gps performance has improved enough that I use that most of the time, with reasonable accuracy and fix times. Some of the improvement I am seeing while hiking could be seasonal though ie less foliage on the trees to block the satellites. I would prefer to use the internal receiver anyway because it doesn't mess up the track if I go into a building while hiking. The bluetooth receiver track will shoot off miles if I do this but the Omnia gps just stops and quickly locks on again when I am outside again.

Another advantage of IJ9/winmob 6.5 is that it now works with large map files. Win Mob 6.1 wouldn't work with files over about 100 mb. Memory-map area files are over 300 mb and had to be cut into smaller sections before they would work.

Share this post


Link to post
Share on other sites

Hi, for me the GPS on the Omnia 2 is more fast and reliable than the i900.

The reception of satellites is very quick.

I use Drive (McGuider) and IGO8.

Both works great and more fast. I am very happy.

:)

Share this post


Link to post
Share on other sites

For those who is disappointed with the GPS fix time, please try this :-

1) must turn on XTRA

2) must enable SNTP in XTRA

3) because of SNTP enabled, data will be downloaded when GPS is enabled. Make sure you have a data plan.

For some reason, XTRA won't work if you just enable XTRA and disable SNTP, even though you pre-download the XTRA using wifi. With SNTP disabled, it is same as with XTRA disabled. However, with SNTP and XTRA both enabled, I can get a cold position fix within 30 secs. This behaviour is consistent with my i900, strange!

For battery consumption, the i8000 is better in battery life using GPS, probably partly due to the AMOLED consuming less.

Share this post


Link to post
Share on other sites

For those who has problem on using GPS of i8000, please try this software: GpsModDriver

I had tried Garmin, Agis, Tomtom, and none of them could get signal fixed before I install GpsModDriver.

After I install this program, normally, it fixed in less than 15 seconds. Even in my room, it got fixed if the phone is near windows.

One issue to be mention:

After the installation of GpsModDriver, it will take over the GPS module and output data using Port 2. Thus you need to set your GPS software port to Port 2.

I am using winmo 6.1 version now.

Now I love my i8000 more than ever. Have a happy time with your GPS of I8000.

Share this post


Link to post
Share on other sites
For those who has problem on using GPS of i8000, please try this software: GpsModDriver

I had tried Garmin, Agis, Tomtom, and none of them could get signal fixed before I install GpsModDriver.

After I install this program, normally, it fixed in less than 15 seconds. Even in my room, it got fixed if the phone is near windows.

One issue to be mention:

After the installation of GpsModDriver, it will take over the GPS module and output data using Port 2. Thus you need to set your GPS software port to Port 2.

I am using winmo 6.1 version now.

Now I love my i8000 more than ever. Have a happy time with your GPS of I8000.

Add a link:

http://download2us.softpedia.com/dl/afa5ef...psModDriver.zip

Share this post


Link to post
Share on other sites

Just got my i920 Wednesday.

All I can say is that after the initial delay to get a fix from a complete cold start, the damn thing seems like it's on all the time (I know it's not). I Google Maps for instance, it gets a fix before GM finishes loading map data. Similar in iGO8 -- by the time it's fully loaded and I hit the globe button to see the map, I've got a blue cursor and a fix.

Much faster than my 910.

Also, the sensitivity is substantially better -- I consistently recieve, and lock on to, more visible satellites than my 910 did.

Share this post


Link to post
Share on other sites
Thanks for the tip.

Tried it and in iGo not much changed. Still takes a long time to get a first fix from a cold start.

I think the 2 get a lock hella faster then the one, new phone out of the box 30 sec, omnia 1 a minute maybe two

Share this post


Link to post
Share on other sites

Guys I need a help too

I have an Omnia II with iGO installed but I can't fix any satellite!

Sunday I fixed and the GPS worked like a charm, but yesterday and today it don't fix.

I tried to use the port splitter, gpsmoddriver but none helped me =\

Please, anyone can help me?

Share this post


Link to post
Share on other sites
Guys I need a help too

I have an Omnia II with iGO installed but I can't fix any satellite!

Sunday I fixed and the GPS worked like a charm, but yesterday and today it don't fix.

I tried to use the port splitter, gpsmoddriver but none helped me =\

Please, anyone can help me?

Satellite fix depends also on weather, if its cloudy you'll have problem with losing satelite receptions.

Share this post


Link to post
Share on other sites

I had same problem. Very bad GPS reception an cold start about 5 min.

I found here, that XTRA must be turned ON.

Both enable XTRA server an enable SNTP server must me turned ON. I also have marked When connected to PC via ActiveSyn.

Now cold star is about 30-60 sec and warm start 20 sec. GPS performance is also better.

GPS performance is not the best, but good enough for navigating.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.