Jump to content

Diamond Problems... Please Help!!!

Recommended Posts

the phone is working, but I can't see anything! I know it's working, because when it turns on, it vibrates, and if I plug it into my computer, it functions as a USB drive (I can see files on it).

Why is my screen suddenly not working? I tried removing the battery and putting it back in, didn't help. I tried holding the red reset button, didn't help.

just reset tried to do a hard reset on the phone (hard to do since i can't even see anything on the screen) and turned it on.

when it came on, the LCD is working, but there is no backlight. there is a message saying something like "microp version mismatch 0" then "please upgrade latest microp firmware"

after that, it goes to the normal touchflo home screen, but there is no backlight.

he had no idea what the problem was. had me to a reset though the settings (clear device storage)

phone turned back on. still no backlight after completing all the steps.

then he transferred me to the "repairs" department. the guy there told me that he only deals with hardware repairs.

they have no idea either. they told me to come to this website.

so how can i fix this? at this point i can't see ANYTHING on the screen.

Share this post

Link to post
Share on other sites

There's something not quite right here....

A post with the very same text as yours can be found here dated Dec '08. If that post is yours, which presumably it is, then it seems you've fixed it.

Care to elaborate?


Share this post

Link to post
Share on other sites

can you get into bootloader mode?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

By using this site, you agree to our Terms of Use.