Jump to content
Kavern

Buttons Don't Work After Case Replacement

Recommended Posts

Anyone having the same problem ?

I bought a Case+Digitizer set from eBay.

Replacing the digitizer is simple, but the buttons seems not to be happy with the case ...

anybody facing the same problem before ? I desperately need help on this ;) ;)

Edited by Kavern

Share this post


Link to post
Share on other sites
Anyone having the same problem ?

I bought a Case+Digitizer set from eBay.

Replacing the digitizer is simple, but the buttons seems not to be happy with the case ...

anybody facing the same problem before ? I desperately need help on this ;) ;)

If you mean the Call and End Call buttons, try loosening the the two bottom corner screws ;)

Share this post


Link to post
Share on other sites
If you mean the Call and End Call buttons, try loosening the the two bottom corner screws ;)

no ... the camera button (can't focus now) and the taskbar/menu button :) B)

Share this post


Link to post
Share on other sites
Anyone having the same problem ?

I bought a Case+Digitizer set from eBay.

Replacing the digitizer is simple, but the buttons seems not to be happy with the case ...

anybody facing the same problem before ? I desperately need help on this :) ;)

I really undestand what are you feeling "Desperate". I had the same problem.. I replace the buttons with the old ones and works perfect now. The new buttons are a little different from the original ones. Hope it helps.

Share this post


Link to post
Share on other sites
I really undestand what are you feeling "Desperate". I had the same problem.. I replace the buttons with the old ones and works perfect now. The new buttons are a little different from the original ones. Hope it helps.

i am already using the old buttons but still not working :)

Share this post


Link to post
Share on other sites
i am already using the old buttons but still not working :)

I to have this problem, when i changed a touchpanel and new case, buttons for the camera, task manager and sometimes end call don't work. Tried to open it again and adjust everything again no succes anyone has anymore ideas what to do? TNX

Share this post


Link to post
Share on other sites

can you link to the ebay seller you bought your case from? i'm thinking of buying a replacement case as well.

i don't see a lot of ebay sellers selling this stuff. i hope we can find one that works or at least get it to work after some proper adjustments.

Share this post


Link to post
Share on other sites
can you link to the ebay seller you bought your case from? i'm thinking of buying a replacement case as well.

i don't see a lot of ebay sellers selling this stuff. i hope we can find one that works or at least get it to work after some proper adjustments.

http://cgi.ebay.com/Original-Housing-Cover...=item414be7cc6f

I bought mine from this seller, contents of the package were without any fault. I think the dimensions of this housing might be slightly different then the original also the buttons might be a bit smaller, but I think it should work fine anyway...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.