Jump to content
miragebg

Problem with Hero on incoming calls

Recommended Posts

Hello guys!

This problems makes me really pissed off..- when my friends call me, my phone starts ring between third and fourth free signal on theirs side, then the time I am realizing it rings and it's in voicemail already..very annoying...what makes this in-acceptable delay?

Edited by miragebg

Share this post


Link to post
Share on other sites

I also have this problem. But the only solution i can find is to extend the time it takes to kick into voice mail up to the maximum of 30seconds for O2

see...

http://androidforums.com/htc-hero/7513-lon...quick-lock.html

Or see.... Try searching next time

http://android.modaco.com/content/htc-hero...ing-call-issue/

Edited by htclova

Share this post


Link to post
Share on other sites
I also have this problem. But the only solution i can find is to extend the time it takes to kick into voice mail up to the maximum of 30seconds for O2

see...

http://androidforums.com/htc-hero/7513-lon...quick-lock.html

Or see.... Try searching next time

http://android.modaco.com/content/htc-hero...ing-call-issue/

Thank you very much!!!

Edited by miragebg

Share this post


Link to post
Share on other sites

This problem is a common complaint about the Hero. I have managed to test this by using a virtual telephone number which I can divert to ring on multiple numbers at the same time.

I set up the number to ring through to my landline, my Hero (on Orange UK) and an old Palm Treo 650 with an Orange UK sim. The virtual number is programmed to dial all the phones at the same time.

When I dialled the virtual number, the first phone to ring was the landline. Next to ring, after 1 second, was the Treo. A full 8 seconds after the landline started ringing, the Hero started to ring.

This is not a network operator issue as both mobiles are on Orange UK, so the delay is either introduced by Android or by the Sense UI (or both).

Share this post


Link to post
Share on other sites

I had thought it was just the network being crap, but now I've started to realise that my phone is showing missed calls without even ringing.

There seems to be some processing lag in starting to ring, the phone definitely knows about the call as it starts to act on it, eg by stopping my music if i'm listening to it, and sometimes blinking the leds, but doesn't show the caller screen or ring for a lot lot longer.

I didn't recall this being such a big issue before I upgraded to Modaco 3.0, from 2.8ish, and enabled apps2sd, but i cant blame these factors just yet without some testing.

Share this post


Link to post
Share on other sites
I didn't recall this being such a big issue before I upgraded to Modaco 3.0, from 2.8ish, and enabled apps2sd, but i cant blame these factors just yet without some testing.

I have had the issue since I have had the phone, although I am now also using Modaco 3.0. I don't think that it is down to the ROM, but Sense may be an issue. It would be interesting to turn off Sense to try without. How can I do this and would the phone default to the Android phone application if I did?

The ideal would be to have another Android phone to test against to see whether it is an Android, Sense or Hero issue. My guess is that all three add their own overheads that delay the total time to incoming call notification.

Share this post


Link to post
Share on other sites

Please, guys, please.....

Funniest thing was having my father's phone and mine ringing at the same time from an incoming call made from my mom's phone....... she got bored of ringing mine, hung up, and then rang my father's :-D

It is actually very annoying, and made the phone's value get REALLY low when it comes to plain phone B-)

One comment: I've managed to get it better deactivating the mobile network. But I don't think this is the idea, isn't it??

Cheers,

MO

Share this post


Link to post
Share on other sites

Thanks for the link. Looking into it a bit further, however, suggests that turning off Sense will not make that much of a difference. What I really need to do it to test the phone without all of the HTC baggage, including the phone application, People, etc. I will look into getting hold of a non-HTC android phone to test.

Share this post


Link to post
Share on other sites
Thanks for the link. Looking into it a bit further, however, suggests that turning off Sense will not make that much of a difference. What I really need to do it to test the phone without all of the HTC baggage, including the phone application, People, etc. I will look into getting hold of a non-HTC android phone to test.

I had the same problem when trying out one of the 2.1 custom ROMs.

I'm assuming your handset is rooted and you can get in to the Recovery Menu (by holding down the Home key whilst powering on).

Once in the recovery menu, see if you have an option to wipe the dalvik-cache. If you have, select it and follow the on screen prompts. Once done, reboot your phone.

Worked perfectly for me, I went from not hearing or seeing the phone ring to it reacting immediately. I now wipe the dalvik-cache every time I flash a new ROM :)

Edited by thecastlefordkid

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.