Jump to content
kendon

the flipclock

Recommended Posts

UPDATE: seems to work fine for most people by just flashing, my phone had different problems.

it does work with this method when having trouble otherwise: wipe, fresh installation of mcr3.1/2, boot and do the setup, flash the clock. a wipe is not mandatory, it has proven to work without a wipe in many cases now. should work on all 1.5 sense roms.

in every case make a nandroid backup before! then flash the zipfile as usual from the recovery menu, no need to delete anything manually before.

who wonders what this is about, from 0:12 in http://www.youtube.com/watch?v=aaFH0vI2w1A. the flipclock was removed by htc in the 2.73 series roms, probably for performance reasons. since (especially) paul and teknologist have done a lot on the performance side it is worth a try IMHO. so far the feedback is good, ppl don't seem to notice an impact on the performance.

GSM_update_flipclock_signed.zip

Edited by kendon

Share this post


Link to post
Share on other sites

well done kendon :D id test it but im too busy this month =\ so bleh! love the return of the flip clock though!

Share this post


Link to post
Share on other sites
so i dived into the flipclock thing, and i finally got it working on mcr3.1. well sort of, for me the situation is this:

as soon as i have the flipclock on the homescreen the phone won't attach to the network anymore. it flips beautifully, and i couldn't find any other problems without an extensive search, but well, a phone in "always airplane mode" is not that cool...

if you are interested try it, regular update.zip for use with recovery. as always make a nandroid before, i can make some update.zips later to restore the original/working one so you don't need to restore the backup if it doesn't work for you.

here is what i haven't tried, maybe someone can do it:

- deleting the clock (from homescreen), then reboot and see if there is connection

- test wifi at all, dunno if it still works or is dead aswell

- check logcat for indicators WHY there is no attach to the network

have fun :D

edit: who wonders what i am talking about, from 0:12 in http://www.youtube.com/watch?v=aaFH0vI2w1A.

This is amazing, im flashing MCR3.1 and this clock i will let you know what i find :D

Share this post


Link to post
Share on other sites

Good news, i wiped the phone via Amon RA and then installed 3.1 then booted up and did all the setup. I then restarted after my google finished syncing and flashed the flip clock and everything seems fine.

I can get:

Data/Wifi just fine switching these on and off and i still have a signall :D

Woop it works!

Share this post


Link to post
Share on other sites

I've just tired using it on MCR3.2 Beta, but it's isn't working there isn't no clocks in the HTC widgets, which is a shame :D Great work though I've always missed the flip clock!

Share this post


Link to post
Share on other sites
I've just tired using it on MCR3.2 Beta, but it's isn't working there isn't no clocks in the HTC widgets, which is a shame :D Great work though I've always missed the flip clock!

can you get a logcat of the boot process?

do "adb logcat > logcat.txt" until the phone is fully booted up, then zip and paste that logcat.txt here please, or send via pm.

if you know how you can also "grep -i clockwidget" and give me that.

Share this post


Link to post
Share on other sites
Well i guess your glad i found that out for you ... lol

it's nice to hear that it works at least for one person, i have still the problem of no connection. gonna try an unmodified mcr3.1 after a wipe now.

do all/most of your apps work? i think i had FCs with connectbot when the clock was installed...

Share this post


Link to post
Share on other sites
can you get a logcat of the boot process?

do "adb logcat > logcat.txt" until the phone is fully booted up, then zip and paste that logcat.txt here please, or send via pm.

if you know how you can also "grep -i clockwidget" and give me that.

Here is the logcat. I don't know how to do the other thing.

logcat.rar

Share this post


Link to post
Share on other sites

Well, I just flashed it on my MCR 3.1 (in use for about a week, so no recent wipe) and it looks like it works pretty damn well.

AWESOME JOB!

Share this post


Link to post
Share on other sites
Here is the logcat. I don't know how to do the other thing.

ok, this is the problem:

E/PackageManager(  112): Package com.htc.widget.clockwidget signatures do not match the previously installed version; ignoring!

does someone know how to deal with this?

Share this post


Link to post
Share on other sites
Kendon was it as hard making this work?

if you want to call "working"...

i got the old rom, installed it, learned i needed root to deodex things, rooted it, installed it, deodexed the file, reassembled the apk and that is what we got here so far. so actually not hard work, but i had to find out how to do a few of these things, so it took me quite a while...

Share this post


Link to post
Share on other sites

Wow i thought it would be more complicated than that! thanks alot :D

Do you think this would be able to work on almost all senseui roms? if its just a clock repack?

Edited by jayw08

Share this post


Link to post
Share on other sites
Wow i thought it would be more complicated than that! thanks alot :D

Do you think this would be able to work on almost all senseui roms? if its just a clock repack?

like i said, for me it is still not working... just try it, it basically should work at least on all 1.5 sense roms. it is just an older version of the clock, but it was made based on sdk1.5...

Share this post


Link to post
Share on other sites
like i said, for me it is still not working... just try it, it basically should work at least on all 1.5 sense roms. it is just an older version of the clock, but it was made based on sdk1.5...

Well like i posted earlier, if you do a clean install it works perfectly, no issues. Why not do a titanium backup and then wipe and install using my instructions earlier?

Share this post


Link to post
Share on other sites
I've just tired using it on MCR3.2 Beta, but it's isn't working there isn't no clocks in the HTC widgets, which is a shame :D Great work though I've always missed the flip clock!

If you do a clean install of 3.2 and do the setup, then restart and flash the clock it will work just fine.

Share this post


Link to post
Share on other sites
Well like i posted earlier, if you do a clean install it works perfectly, no issues. Why not do a titanium backup and then wipe and install using my instructions earlier?

i am working on it, i like to try if i can do it without a wipe first... seems to work for some.

just tried mcr3.1 then flash the clock without a reboot in between, gives me:

E/PackageManager(  152): Package com.htc.widget.clockwidget has no signatures that match those in shared user com.htc.rosie.uid.shared; ignoring!

Share this post


Link to post
Share on other sites
ok, this is the problem:

E/PackageManager(  112): Package com.htc.widget.clockwidget signatures do not match the previously installed version; ignoring!

does someone know how to deal with this?

i think "signature" means the MD5 hash, there must be a way to change the certificate for it. hmm..

Share this post


Link to post
Share on other sites
If you do a clean install of 3.2 and do the setup, then restart and flash the clock it will work just fine.

can confirm this for 3.1. now trying 3.2... thanks for the tip jayw!

edit: 3.2b5 works aswell when using that procedure.

Edited by kendon

Share this post


Link to post
Share on other sites
can confirm this for 3.1. now trying 3.2... thanks for the tip jayw!

No problem, great work on your park, i only tested it :D

Share this post


Link to post
Share on other sites

Yeah, just installed this baby on my rooted MCR 3.2 Beta 5 install of a couple months and it works great!

No radio problems, can turn WiFi on and off, as well as airplane mode.

Love having the old clock! And its not noticably slower than before the install :D

Thanks!!! :D

Share this post


Link to post
Share on other sites

Been using it since last night (GMT) .. amazing, my ROM is as fast as it's always been. It's nice to finally have that clock flipping again instead of being a flip clock with no flip haha.

Share this post


Link to post
Share on other sites

I have installed on 3.2 beta 5 on a rooted unlocked Hero and all seems well.

So far I haven't noticed any slowdown. I tested wifi by turning on, using, turning off and repeating this several times - it works fine.

I also tried airplane mode, switching on and off both worked fine.

Several reboots in all seems well... if you like the flip clock this is great.

Well done kendon!! :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.