Jump to content
PaulOBrien

30/Jun r5 - MoDaCo Custom ROM for GSM Hero now with Online Kitchen - Android 2.1

Recommended Posts

OK, the issues now. I have setup r5 and it seems pretty good as of now.

Issues:-

1) Titanium backup and MCR Scripts always Force Closed.

2) Memory: I use Taskpanel for memory management. On MCR 3.2 my average free memory used to be around 80 MB. With r5 it has dropped to around 40-50 MB. Is it within the acceptable limits? Will it slow down the phone?

Can anyone suggest a good memory management tool other than TaskPanel?

Share this post


Link to post
Share on other sites

I'm using Taskkiller, and It's the same here. Much less memory available on 2.1 than 1.5. I haven't noticed the phone being slower though, so it doesn't bother me :)

Share this post


Link to post
Share on other sites
I'm using Taskkiller, and It's the same here. Much less memory available on 2.1 than 1.5. I haven't noticed the phone being slower though, so it doesn't bother me :)

Free RAM = Waste RAM

You can use Autokiller, which will automatically start killing apps when a certain amount of free memory is left, you can download it from the Market it's free.

And remember less free RAM doesn't mean that your phone will work slow.

Share this post


Link to post
Share on other sites
Free RAM = Waste RAM

You can use Autokiller, which will automatically start killing apps when a certain amount of free memory is left, you can download it from the Market it's free.

And remember less free RAM doesn't mean that your phone will work slow.

Are you sure? Because at times when my phone used to lag too much I would kill some apps using Taskpanel, the free memory would shoot up from 40 to 70 and the phone would become responsive again. To me it seems like it does have a significant effect.

Share this post


Link to post
Share on other sites
Are you sure? Because at times when my phone used to lag too much I would kill some apps using Taskpanel, the free memory would shoot up from 40 to 70 and the phone would become responsive again. To me it seems like it does have a significant effect.

+1

Share this post


Link to post
Share on other sites
Its in a loop.

The first time the green bar was there. It finished and now every 1 minute the same quietly brilliant screen comes up without the green bar, screen goes black for a second and again same white quietly brilliant thing.

Edit: I just plucked out the memory card and the phone booted just fine. What can be the issue? Any ideas folks. Its a memory card issue for sure.

Formatted and partitioned the card. Everything working fine.

Thanks Paul. Looks like taking up a Modaco Ad free account was a good idea.

This sounds like the issue I had, where the boot/post-install process gets fscked by something in the /system/sd/app or /system/sd/app-private folder.

See earlier posts in this thread.

TBX

Share this post


Link to post
Share on other sites

Btw, if you are wondering if you need to "boot your phone again" once you've thought you've finished your upgrade, you should check Settings -> About Phone -> Software information -> Software number -- if it says to reboot the phone, you should! :-)

TBX

Share this post


Link to post
Share on other sites
Are you sure? Because at times when my phone used to lag too much I would kill some apps using Taskpanel, the free memory would shoot up from 40 to 70 and the phone would become responsive again. To me it seems like it does have a significant effect.

Your apps would lag a little bit, the ones which have heavy requirements like browser with multiple tabs open or games etc but otherwise the phone would run smooth atleast that's the case with me and I would recommend you to use 'Autokiller' so that it will automatically kill apps and not wait for you to kill them.

Share this post


Link to post
Share on other sites

Just a quick note: I've installed r5 (after wiping), but Aboute phone/SW Info still says MoDaCo Custom ROM r4 :)

Other than that, nothing to say but thanks for THE custom rom for my Hero!!

Share this post


Link to post
Share on other sites
Is it me, or are there widgets missing in the r5 release?

I can't find HTC e-mail not WiFi/GPS/BT toggle widgets.

Try clearing the Data of HTC Sense in Manage Application in Settings.

Share this post


Link to post
Share on other sites
Try clearing the Data of HTC Sense in Manage Application in Settings.

Update: A wipe seems to have taken care of this. Possibly Titanium Backup caused the problem.

Edited by enemywithin

Share this post


Link to post
Share on other sites
Just a quick note: I've installed r5 (after wiping), but Aboute phone/SW Info still says MoDaCo Custom ROM r4 :)

Other than that, nothing to say but thanks for THE custom rom for my Hero!!

odd, mine says r5, perhaps you might want try again without wiping, but after a Nandroid backup - just in case :-)

Share this post


Link to post
Share on other sites

Hello,

I just apply this new ROM (2.1) on my Hero, everything works fine BUT I don't have any data transmission over GSM network.

WiFi work fine, but no Internet access over GSM.

I ve checked "mobile Network" in the settings (which allow - normally - the data transfer over GSM when no WiFi network are available).

Someone could help me ?

Thanks.

Edited by BPA

Share this post


Link to post
Share on other sites
odd, mine says r5, perhaps you might want try again without wiping, but after a Nandroid backup - just in case :-)

Must have been something weird, re-installed r5 now via the kitchen and it says r5. It might just be me imagining upgrading to the Euro-release :)

Voice Search

This option includes the Voice Search application. This also adds the stock Android keyboard.

Does that mean that if I don't include Voice Search I'll loose the on-screen keyboard? Or is the keyboard a separate HTC-thingie?

Edited by miniPax

Share this post


Link to post
Share on other sites

After update with r5, my system reboots and loops, like another members, then it stays on "formating cache".

What is the problem (and the solution!) :

- reformating ext4 partition with ext3?

- wiping?

- applications I must install (I have installed A2SD+, radio update but left A2SD)?

- wait for r6?

Thanks for some help.

Share this post


Link to post
Share on other sites

Hi,

I've just upgraded my HTC Hero 1.5 (offical 1.76.405.6) to 2.1 (modaco r5 with additions with radio image 3.32.405.1). I restored my SMS datas, HTC Mail datas and all user apps/data with Titanium Backup.

I have 3 troubles :

- The standard "Manage application" force close when it is loaded from the Android menu. It loads well when it loaded from Titanium Backup but force close when I change the sort type.

- A2SD seems to not work. I created the ext2 partition, then converted it to ext3 with Amon Ra recovery.

- The ADB command return strange caracters :

adb shell ls -l /

drwxrwx--x	1 1000	 2001		  2048 Jul  5 16:57 ←[1;34mcache←[0m

dr-x------	2 0		0				0 Jul  4 22:03 ←[1;34mconfig←[0m

lrwxrwxrwx	1 0		0			   17 Jul  4 22:03 ←[1;36md←[0m -> ←[1;34m

/sys/kernel/debug←[0m

drwxrwx--x	1 1000	 1000		  2048 Jul  4 08:39 ←[1;34mdata←[0m

-rw-r--r--	1 501	  20			 118 Jun 30 18:21 ←[0;0mdefault.prop←[0m

drwxr-xr-x   13 0		0			 1440 Jul  4 22:03 ←[1;34mdev←[0m

lrwxrwxrwx	1 0		0			   11 Jul  4 22:03 ←[1;36metc←[0m -> ←[1;3

4m/system/etc←[0m

-rwxr-x---	1 501	  20		  107536 Jun 30 18:21 ←[1;32minit←[0m

-rwxr-x---	1 501	  20			1677 Jun 30 18:21 ←[1;32minit.goldfish.rc

←[0m

-rwxr-x---	1 501	  20			3331 Jun 30 18:21 ←[1;32minit.hero.rc←[0m


-rwxr-x---	1 501	  20		   14788 Jun 30 18:22 ←[1;32minit.rc←[0m

-rw-r--r--	1 501	  20		   11336 Jun 30 18:21 ←[0;0mlogo.rle←[0m

dr-xr-xr-x   85 0		0				0 Jan  1  1970 ←[1;34mproc←[0m

drwx------	2 0		0				0 May 26 16:18 ←[1;34mroot←[0m

drwxr-x---	2 501	  20			   0 Jun 30 18:21 ←[1;34msbin←[0m

d---rwxr-x   47 1000	 1015		  4096 Jan  1  1970 ←[1;34msdcard←[0m

drwxrwxrwt	2 0		0			   40 Jul  6 17:57 ←[1;34msqlite_stmt_jour

nals←[0m

drwxr-xr-x   16 0		0				0 Jan  1  1970 ←[1;34msys←[0m

drwxr-xr-x	1 0		0			 2048 Jul  4 22:03 ←[1;34msystem←[0m

Any ideas about my troubles ? :)

Thanks a lot by advance.

Good job Paul ! :D

Regards,

Share this post


Link to post
Share on other sites
@Paul: there will be any a2sd prebaked rom?

I'll include that in the next round of prebakes.

P

Share this post


Link to post
Share on other sites
I requested beebplayer on the r5 kitchen, but can't find it anywhere on my phone. How do I get it?

Did you wipe AFTER flashing the ROM?

P

Share this post


Link to post
Share on other sites
Hi,

I've just upgraded my HTC Hero 1.5 (offical 1.76.405.6) to 2.1 (modaco r5 with additions with radio image 3.32.405.1). I restored my SMS datas, HTC Mail datas and all user apps/data with Titanium Backup.

I have 3 troubles :

- The standard "Manage application" force close when it is loaded from the Android menu. It loads well when it loaded from Titanium Backup but force close when I change the sort type.

- A2SD seems to not work. I created the ext2 partition, then converted it to ext3 with Amon Ra recovery.

- The ADB command return strange caracters :

adb shell ls -l /

drwxrwx--x	1 1000	 2001		  2048 Jul  5 16:57 ←[1;34mcache←[0m

dr-x------	2 0		0				0 Jul  4 22:03 ←[1;34mconfig←[0m

lrwxrwxrwx	1 0		0			   17 Jul  4 22:03 ←[1;36md←[0m -> ←[1;34m

/sys/kernel/debug←[0m

drwxrwx--x	1 1000	 1000		  2048 Jul  4 08:39 ←[1;34mdata←[0m

-rw-r--r--	1 501	  20			 118 Jun 30 18:21 ←[0;0mdefault.prop←[0m

drwxr-xr-x   13 0		0			 1440 Jul  4 22:03 ←[1;34mdev←[0m

lrwxrwxrwx	1 0		0			   11 Jul  4 22:03 ←[1;36metc←[0m -> ←[1;3

4m/system/etc←[0m

-rwxr-x---	1 501	  20		  107536 Jun 30 18:21 ←[1;32minit←[0m

-rwxr-x---	1 501	  20			1677 Jun 30 18:21 ←[1;32minit.goldfish.rc

←[0m

-rwxr-x---	1 501	  20			3331 Jun 30 18:21 ←[1;32minit.hero.rc←[0m


-rwxr-x---	1 501	  20		   14788 Jun 30 18:22 ←[1;32minit.rc←[0m

-rw-r--r--	1 501	  20		   11336 Jun 30 18:21 ←[0;0mlogo.rle←[0m

dr-xr-xr-x   85 0		0				0 Jan  1  1970 ←[1;34mproc←[0m

drwx------	2 0		0				0 May 26 16:18 ←[1;34mroot←[0m

drwxr-x---	2 501	  20			   0 Jun 30 18:21 ←[1;34msbin←[0m

d---rwxr-x   47 1000	 1015		  4096 Jan  1  1970 ←[1;34msdcard←[0m

drwxrwxrwt	2 0		0			   40 Jul  6 17:57 ←[1;34msqlite_stmt_jour

nals←[0m

drwxr-xr-x   16 0		0				0 Jan  1  1970 ←[1;34msys←[0m

drwxr-xr-x	1 0		0			 2048 Jul  4 22:03 ←[1;34msystem←[0m

Any ideas about my troubles ? :)

Thanks a lot by advance.

Good job Paul ! :D

Regards,

You can get rid of those funny characters by entering:

alias ls='ls --color=none'

Cheers,

Dan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.