Jump to content
jdwis

Is phone gone bad or the whole file system corrupted?

Recommended Posts

Hi

I have no idea but there is something wrong with my phone.

About phone – HTC Hero, rooted, MCR 3.2, apps2SD working, 8GB sdcard, partitions – SWAP-0, ext3-512, rest fat32, recovery img - recovery-RA-hero-v1.5.2.img

I have nearly 80 apps installed, some Utilities, some system apps like uninstaller, Titanium etc and rest all games for kids.

Yesterday night phone battery was almost discharged so I put it on charge, forgot to remove it when fully charged, so removed it today morning when I woke up.

A friend called, though phone was on ringing mode it didn’t ring but just vibrated – surprised.

Just after that phone got lagging problem, whatever you do, there is a long delay, got irritated so switched off & back on the phone. It then went in the loop at start of the android screen where 2 pops up with sound, it just remained in the loop.

Couldnt get out of it, so removed the battery, tried again and it booted after long delay but it was as fresh as just installing the MCR 3.2, none of my installed applications were there. All my apps were missing.

So I thought to do Nandroid restore which I took couple of days ago with EXT data.

Booted in recover, wiped Ext-partition, Dalvic-cache, and the system data. Put it in USB mode, copied Radio ROM ver - 63.18.55.06JU_6.35.09.26 and Nandroid Restore files.

Then first I restored nandroid backup, booted the phone, out of surprise, few applications were missing which were there at the time of backup.

I installed radio rom and still the apps remained missing...

Again I went into recovering mode, wiped everything again, ext partition, dalvic-cache & system data, installed nandroid restore, booted the phone, and this time some different applications were missing which were there in previous try.

I assume nandroid should restore everything properly but then why the applications keeps missing everytime,

I have this problem since I tried Villain ROM just for trying it out.

What is the solution, I m just scared to reboot the phone if anytime required because it gives me a feeling that after reboot I will miss many applications.

This problem is very unusual, is phone gone bad or its OS or anything else???

Share this post


Link to post
Share on other sites

I guess no one knows the answer....

at least people could have thought of some possible answers and replied... it would have helped...

thanks

Share this post


Link to post
Share on other sites
adb logcat?

Uh. Of what? It doesn't magically detect where it's going wrong, at what point in time, as a result of what action, and logcat that process.

To OP, just do a full wipe and set everything up manually. It sounds like the majority of your applications are junk which doesn't need its data restored, at worst you'll have to start a few games again. If you continue getting problems after using no kind of restore tool whatsoever then flash a stock ROM and take it to HTC.

Share this post


Link to post
Share on other sites

Um, if your problems are with apps stored on your sd card, maybe the card is faulty? Try reformatting the ext partition. If that doesn't help try a different sd card.

Share this post


Link to post
Share on other sites
Um, if your problems are with apps stored on your sd card, maybe the card is faulty? Try reformatting the ext partition. If that doesn't help try a different sd card.

I have a phone with same config as you, 8GB Class 6 card, lots of apps, including Co pilot V8, no problems, so it must be either a faulty sd card or some filesystem corruption on the phone itself. If you still have issues after a full wipe (thats everything including EXT), then you have a faulty handset and it will need restoring back to HTC former glory and sending back under warranty. :D

PS If you do the restore back to stock using an RUU, use an early one....but be mindful, HTC may return the phone with the latest stock rom, and it so far has proved to be unrootable....although there are one or two claims to have rooted this stock version. :lol:

HTH,

Carl.

Share this post


Link to post
Share on other sites

thanks guys for all the help and directions i could go...

will see what comes next, will try to change the card, a complete format, full wipe, and reinstall everything

and see if it still works or gooone...

thanks again

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.