Jump to content
Sign in to follow this  
Davey IJzermans

[solved] Can't cook in kitchen WITH Ad-Free pack

Recommended Posts


I've made this same a topic earlier today, but I posted it in the wrong subforum, and it got deleted. Sorry for that, so here goes again.

I've recently bought an Ad-Free pack to access the kitchen. But since yesterday, the ads have come back and I can't cook ROMs anymore. My subscription page in my control panel still says that I have an Ad-Free pack - as I should have, as I bought it three days ago - but I can't access the extra features anymore.

I've already tried clearing ny caches/cookies, using a different browser and computer, but to no avail. Something is wrong on the server side I think.

Thanks in advance,

Davey IJzermans.


Edited by Davey IJzermans

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.