Jump to content
urphonesux

INSTANT GPS LOCKS FOR ALL

Recommended Posts

OK

Couldn't find Samsung gps hardware in my settings- the rest of the dword's are in HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers , but I have a lot of changes done with sashimi, I'm HR now and will try it . No way that I know of can make our GPS better as far as I know I wish it will work. I'll update in 10

Edit:

GpsModDriver reg set:

Windows Registry Editor Version 5.00


[HKEY_LOCAL_MACHINE\Software\Mach2003\GpsModDriver]

"PortConfig"=hex:00,00,00,00,05,01,00,00,00,00,00,00,02,63,00,00,00,00,00,00,00,00,00,\

  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,05,02,00,00,00,\

  00,00,00,00,00,00,00

"GpsidOutputBuffer"=dword:00000200

"GpsidInputBuffer"=dword:00000200

"GpsidSleep"=dword:00000000

"ComTimeOut"=dword:00000000

"SleepTime"=dword:00000190

"Profile2Name"="Walking"

"Profile1Name"="Driving"

"ActiveDriver"="Drivers\\Active\\23"

"Uninstall"=dword:00000000

"GpsComPort"=dword:00000008

"CurrentProfile"=dword:00000001

"GpsidPoll"=dword:00000064

"KeepAlive"=dword:00003A98

"EnableAltSep"=dword:00000001

"EnableScan"=dword:00000000

"EnableTrack"=dword:00000000

"EnableLogs"=dword:00000000

"EnableSmooth"=dword:00000001

"OrigOutputBufferSize"=dword:00000200

"OrigInpputBufferSize"=dword:00000200

"OrigSleepOnNoData"=dword:00000000

"OrigPollInterval"=dword:000001F4



[HKEY_LOCAL_MACHINE\Software\Mach2003\GpsModDriver\Profile2]

"EnableCompass"=dword:00000001

"MagLand"=dword:00000000

"MagVal"=dword:00000000

"LagAdvance"=dword:000003E8

"EnableSpeed"=dword:00000002

"EnableCourse"=dword:00000002

"EnableDop"=dword:00000001

"DeltaTime"=dword:00000BB8

"MinSpeed"=dword:0000000A

"DeltaSpeed"=dword:00000064

"DeltaDistance"=dword:0000001E



[HKEY_LOCAL_MACHINE\Software\Mach2003\GpsModDriver\Profile1]

"EnableCompass"=dword:00000000

"MagLand"=dword:00000000

"MagVal"=dword:00000000

"LagAdvance"=dword:000003E8

"EnableSpeed"=dword:00000002

"EnableCourse"=dword:00000002

"EnableDop"=dword:00000001

"DeltaTime"=dword:00000BB8

"MinSpeed"=dword:0000000A

"DeltaSpeed"=dword:00000064

"DeltaDistance"=dword:0000001E
GPS Intermedia Driver Settings:
Windows Registry Editor Version 5.00


[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver]

"OldLogFile"=""

"CurrentLogFile"=""

"IsEnabled"=dword:00000001



[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers]

"OutputBufferSize"=dword:00000200

"InputBufferSize"=dword:00000200

"SleepOnNoData"=dword:00000000

"RetryWaitOnError"=dword:00000003

"CurrentDriver"="GPSOneDevice"



[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\GPSOneDevice]

"PollInterval"=dword:00000064

"OutputBufferSize"=dword:00000200

"InputBufferSize"=dword:00000200

"SleepOnNoData"=dword:00000000

"Version"=dword:00000001

"DriverName"="TAI"

"FriendlyName"="QualComm GpsOne Card, version 0.0"

"InterfaceType"="POLL"



[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\GPSOneEmulate]

"Filex"="\\windows\\GPSOneFileSimulation.txt"

"FriendlyName"="QualComm GpsOne File, version 0.0"

"InterfaceType"="File"



[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\GPSOnePort]

"CommPort"="COM1:"

"FriendlyName"="QualComm GpsOne Card, version 0.0"

"InterfaceType"="COMM"



[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer]

"MaxBufferSize"=dword:00000400

"DriverInterface"="COM8:"



[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer\ActiveDevice]

"Index"=dword:00000008

"Prefix"="COM"

"Context"=dword:12344160

"Flags"=dword:00000002

"Keep"=dword:00000001

"Dll"="GPSID.dll"

It gets an instant lock on 1 sat, however, I am NOT in eastern Europe. @urphonesux, I've set it up as posted and plz feel free to check my .reg maybe I missed something

screen03e.jpgscreen04np.jpgscreen05aj.jpg

However, my GPS was running a little crazy today (maybe my poor i910 is finally dead?) and so I'll cab all of the files and post them for someone else to try

Edit2: Not enough time to make the .cab, so I'm attaching the .reg files and the cab file. Testers: Please install the cab file to device memory, and extract the zip and import the 2 reg files to your directory. My GPS seems to be dead but who knows it's raining and cloudy here in Miami right now, so plz try it out and post your findings here.

Edit 3 still testing :angry:

GpsModDriver_316.CAB

Edited by lioryte

Share this post


Link to post
Share on other sites

hadnt heard of that issue lyorite

can you run sktools search for invalid reg entries and values and then do a reg optimization and post back?

those are the exact same settings i have setup with

can you also test in google maps and any other software

thanks

Edited by urphonesux

Share this post


Link to post
Share on other sites
hadnt heard of that issue lyorite

can you run sktools search for invalid reg entries and values and then do a reg optimization and post back?

those are the exact same settings i have setup with

can you also test in google maps and any other software

thanks

NP, btw middle image is from google maps, and I did a HR before inserting reg and installing cab on it. Now, since the ROM you are running/showing is mine...

I would love for another tester to try it out, maybe my GPS has an issue GPS is working fine (pheww...)

Edited by lioryte

Share this post


Link to post
Share on other sites

ooops my mistake i copy pasted the keys to change the correct location for input/output buffer settings and sleep on no data is

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers

the max buffer size dword should be made at

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer

ive posted this to all of the omnia sites and havent had any response yet except at the hub from a user that is having no issues at all either

Edited by urphonesux

Share this post


Link to post
Share on other sites
ooops my mistake i copy pasted the keys to change the correct location for input/output buffer settings and sleep on no data is

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers

the max buffer size dword should be made at

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer

ive posted this to all of the omnia sites and havent had any response yet except at the hub from a user that is having no issues at all either

Taken from the reg. file I've posted

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer]

"MaxBufferSize"=dword:00000400

"DriverInterface"="COM8:"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers]

"OutputBufferSize"=dword:00000200

"InputBufferSize"=dword:00000200

"SleepOnNoData"=dword:00000000

"RetryWaitOnError"=dword:00000003

"CurrentDriver"="GPSOneDevice"

So again I ask I see some downloads- please try and let us know if working for you

Share this post


Link to post
Share on other sites

i see you have some wrong settings:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver]

"OldLogFile"=""

"CurrentLogFile"=""

"IsEnabled"=dword:00000001

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers]

"OutputBufferSize"=dword:00000200

"InputBufferSize"=dword:00000200 BOTH SHOULD BE 512

"SleepOnNoData"=dword:00000000

"RetryWaitOnError"=dword:00000003

"CurrentDriver"="GPSOneDevice"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\GPSOneDevice]

"PollInterval"=dword:00000064

"OutputBufferSize"=dword:00000200

"InputBufferSize"=dword:00000200 BOTH SHOULD BE 512

"SleepOnNoData"=dword:00000000

"Version"=dword:00000001

"DriverName"="TAI"

"FriendlyName"="QualComm GpsOne Card, version 0.0"

"InterfaceType"="POLL"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\GPSOneEmulate]

"Filex"="\\windows\\GPSOneFileSimulation.txt"

"FriendlyName"="QualComm GpsOne File, version 0.0"

"InterfaceType"="File"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\GPSOnePort]

"CommPort"="COM1:"

"FriendlyName"="QualComm GpsOne Card, version 0.0"

"InterfaceType"="COMM"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer]

"MaxBufferSize"=dword:00000400 SHOULD BE 1024

"DriverInterface"="COM8:"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer\ActiveDevice]

"Index"=dword:00000008

"Prefix"="COM"

"Context"=dword:12344160

"Flags"=dword:00000002

"Keep"=dword:00000001

"Dll"="GPSID.dll"

Edited by urphonesux

Share this post


Link to post
Share on other sites
i see you have some wrong settings:

PM ur way

Edited by lioryte

Share this post


Link to post
Share on other sites

sorry i thought i posted this earlier try it this way

double check your location on settings

make sure you have this cab installed

(no offense i just havent tried lyorite's cab)

http://www.4shared.com/file/zSW04Fh5/GpsModDriver_316.html

then run this reg file on your phone

http://www.4shared.com/file/UWWll57n/GPS_I...ate_Driver.html

i got a instant lock after a fresh flash earlier doing it just like that

if that doesnt work i would try on any rom you used previously on phone that had working gps

Edited by urphonesux

Share this post


Link to post
Share on other sites
I get an instant lock but it puts me in England. I dont drive on the left side of the road.

Surprise surprise :angry:- Our GPS chip can't get an instant lock. Something similar was tried back around May 09 with Adrynalyne's ROM. The i910 has 2 major flaws that we can't fix- A shitty GPS chip and a lousy resistive screen.

Share this post


Link to post
Share on other sites
sorry it doesnt work for you guys but i also have reports of this working on the samsung saga also

???

This fix might also work on the i9000 and the iphone for all I care. This doesn't work on the i910. We (Chefs) were at this for a long time. Let me summarize it: Our GPS chip (qualcomm gpsone- most likely) is the issue. No matter what drivers you will install- our phone (i910) is not supporting of an instant lock without enabling AGPS. The thread you took your info from is "Permanent GPS fix for Samsung i900 & i8000 Omnia ". Not i910- Can you change your default COM? Stating that you get instant cold locks (maybe you do- I get them every now and than, like 1/50 after flashing, but I flash about 5-10 times/day) will be like me stating I got our screen to be capacitive by tweaking registry and installing drivers, or saying I got TouchFlo3D to work on our phone. We don't have the hardware for it, just let it go.

Share this post


Link to post
Share on other sites
???

This fix might also work on the i9000 and the iphone for all I care. This doesn't work on the i910. We (Chefs) were at this for a long time. Let me summarize it: Our GPS chip (qualcomm gpsone- most likely) is the issue. No matter what drivers you will install- our phone (i910) is not supporting of an instant lock without enabling AGPS. The thread you took your info from is "Permanent GPS fix for Samsung i900 & i8000 Omnia ". Not i910- Can you change your default COM? Stating that you get instant cold locks (maybe you do- I get them every now and than, like 1/50 after flashing, but I flash about 5-10 times/day) will be like me stating I got our screen to be capacitive by tweaking registry and installing drivers, or saying I got TouchFlo3D to work on our phone. We don't have the hardware for it, just let it go.

again i am sorry it doesnt work for you

also i havent had to change my default com

Edited by urphonesux

Share this post


Link to post
Share on other sites

would someone please add a reg file to revert back too original settings. this does not work got my needs. from tom tom it never locks.

worth a try though.thanks for your effort

Share this post


Link to post
Share on other sites
would someone please add a reg file to revert back too original settings. this does not work got my needs. from tom tom it never locks.

worth a try though.thanks for your effort

have you gotten past the gpsonwarn screen when you reboot the phone after switching to location on?

Share this post


Link to post
Share on other sites
have you gotten past the gpsonwarn screen when you reboot the phone after switching to location on?

ok no errors on reboot after gps mod install. not 100% sure the reg file is working, what are you using to open the reg file? turning location on? what do you mean, what application or where do i find this option?

would still appreciate a reg file to return everything to default please. just in case u cant get this working. as i see another post for a permanent fix

Share this post


Link to post
Share on other sites

after installing sktools by default my file explorer CAN open reg files.

Location on is in setting/personal/services/gps (must be done first for the phone to create the neccesary gps keys for the reg file to edit)

I know that Garmin mobile has that screen, Igo 8/Primo also.

it works fine on my phone. I built 8 different roms from the ground up over the weekend and was able to successfully get the gps fix working in all of them.

I always use google maps to get it started though because the cellid function boost gpsmods ability.

1 install gpsmod

2 double check location on

3 open google maps then exit

4 run reg file

5 open gps mod and go to menu/ system/internal gps (the bottom section) make sure both internal input buffer are at 512

6 under that make sure that com 8 is enabled (default)

7 open google maps (i have it installed to my storage) again

8 set google maps to use gps managed by windows

If your phone beeps when a gps app is started then gpsmod is functioning correctly, if not SOFT reset until it beeps when you open google maps

Once started it will be fine everytime

Edited by urphonesux

Share this post


Link to post
Share on other sites
after installing sktools by default my file explorer can not open reg files.

Location on is in setting/personal/services/gps (must be done first for the phone to create the neccesary gps keys for the reg file to edit)

I know that Garmin mobile has that screen, Igo 8/Primo also.

it works fine on my phone. I built 8 different roms from the ground up over the weekend and was able to successfully get the gps fix working in all of them.

I always use google maps to get it started though because the cellid function boost gpsmods ability.

1 install gpsmod

2 double check location on

3 open google maps then exit

4 run reg file

5 open gps mod and go to menu/ system/internal gps (the bottom section) make sure both internal input buffer are at 512

6 under that make sure that com 8 is enabled (default)

7 open google maps (i have it installed to my storage) again

8 set google maps to use gps managed by windows

If your phone beeps when a gps app is started then gpsmod is functioning correctly, if not SOFT reset until it beeps when you open google maps

Once started it will be fine everytime

as for location on. do you mean the HTC location app? if not i dont have anything in personal settings relating to location on. p.s. im using i900

Share this post


Link to post
Share on other sites
as for location on. do you mean the HTC location app? if not i dont have anything in personal settings relating to location on. p.s. im using i900

Boss, urphonesux's post is for the i910. YOU need to go to where he got it from which is the original i900 GPS thread (Permanent GPS fix for Samsung i900 & i8000 Omnia) -HERE. Follow the instructions on first post. GPS settings are not the same for the i900 and i910, i910 was crippled by VZ so there is no fix for it only a constant GPS ON apps will work and only once the GPS gets an initial lock.

Share this post


Link to post
Share on other sites

oops thats supposed to say

after installing sktools by default my file explorer CAN open reg files.

No i use titanium but yes this will work for you if you have a samsung windows mobile phone such as the omnia.

Share this post


Link to post
Share on other sites

sorry i thought i posted this earlier try it this way

double check your location on settings

make sure you have this cab installed

(no offense i just havent tried lyorite's cab)

http://www.4shared.com/file/zSW04Fh5/GpsModDriver_316.html

then run this reg file on your phone

http://www.4shared.com/file/UWWll57n/GPS_I...ate_Driver.html

i got a instant lock after a fresh flash earlier doing it just like that

if that doesnt work i would try on any rom you used previously on phone that had working gps

WELL I TRIED THIS PIECE OF CRAP AND NOW MY GPS ON THE OMNIA DOESN'T WORK AT ALL!!!

tHANKS FOR NOTHING

Edited by Dorothydix

Share this post


Link to post
Share on other sites
WELL I TRIED THIS PIECE OF CRAP AND NOW MY GPS ON THE OMNIA DOESN'T WORK AT ALL!!!

tHANKS FOR NOTHING

Did you do this with an i900??.....

good day.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.