Jump to content
PaulOBrien

MCR r8 development archive

Recommended Posts

Well I've just had my first ever ROM Install FAIL with this Bake...

I have a little bit of a feeling why...

Before Installing the ROM, in the past, on all versions of r8 prior to the RC, I first open the actual zip folder myself, and add in MY OWN bootanimation.zip file - as mine is the larger Nexus Lighting Arrows one.

When trying to flash my ROM today however, I get a:

"Can't symlink /system/customize/resource/bootanimation.zip"

Error.

I suspect Paul has changed something, as there was indeed no existing bootanimation.zip file in the usual place, in this ROM bake, but if so, it was a late time to change the behaviour that had applied all through r8, and more to the point, in order to get things to work, what do I now need to do please folks.

Bear in mind i know nothing about Linux, and use a Win7 machine etc.

Thanks in advance...

Share this post


Link to post
Share on other sites

Have you tried just to install the rom without meddeling with the zip file and put your custom bootscreen in afterwards through disc drive mode? according to paul the symlink is in place.

Share this post


Link to post
Share on other sites
is the R8 RC for paid members only?

As long as stuff is in the kitchen it´s for paid members only, once it´s stable enough for the public release paul will release a "standard" version of the rom that can just be downloaded weather your paid or free member, but you have no customization options.

Share this post


Link to post
Share on other sites
As long as stuff is in the kitchen it´s for paid members only, once it´s stable enough for the public release paul will release a "standard" version of the rom that can just be downloaded weather your paid or free member, but you have no customization options.

yeah I know that but as Paul says RC1 is the final release of R8 and no more additions will be made that it will be available for free members.

Share this post


Link to post
Share on other sites
Have you tried just to install the rom without meddeling with the zip file and put your custom bootscreen in afterwards through disc drive mode? according to paul the symlink is in place.

I don't do it this way, as I don't seem to be able to acces the system folder due to write protection etc, via the phone direct.

So I have (as per my post) always just modded the ROM zip before applying.

And this has always worked perfectly fine until now.

I am currently doing a new ROM bake, with a CUSTOM boot selected, in case that is the issue, but in the meantime, can anyone help me...

My phone appears "stuck" on the HTC logo screen, following this error message and attempted restart.

Is my phone just taking a long time to bootup after Flash Failure, or do I need to do something special to get it to Flash with a good ROM zip now...?

It's been much longer than a normal Flash so I suspect there's a problem...

Share this post


Link to post
Share on other sites

My guess is it´s here super soon as soon as Paul is satisfied that theres no more significant bugs in the rom that hasen´t been eliminated already.

Share this post


Link to post
Share on other sites
I don't do it this way, as I don't seem to be able to acces the system folder due to write protection etc, via the phone direct.

Yes. But now Paul has symlinked the file to a place where you DO have write access. :D

Share this post


Link to post
Share on other sites

Seems the LOCATION for bootanimation.zip has changed from sys to data/local

In the meantime, can anyone tell me how to reflash with a corrected ROM zip, if my phone is just stuck on the HTC logo screen..?

Share this post


Link to post
Share on other sites
Yes. But now Paul has symlinked the file to a place where you DO have write access. :D

Ha yes - just realised the hard way, as per my immediate prior post.

*lol*

Share this post


Link to post
Share on other sites

P,

first and foremost, thanks a lot for a fantastic rom, my phone would not have been a phone without it, and it just keeps getting better and better.

would anyone happen to know why my APNs are wiped after adding the Smooth Sense Icons ?

klutsh offers a workaround here but i'd rather have it work automagically without workarounds.. :D

i know for sure that it is the smooth sense icons that kills the apns, been trying different stuff, so i'm not going to bother telling that i'm using r8 rc1 after full wipe and all that jazz..

i'm not able to get mms working even when adding the details manually using details from an earlier working setup..

much love to devs and testers making this what it is :D

/e

Edited by einaw

Share this post


Link to post
Share on other sites
afaik, lets you cache maps so less data usage, and i think nav works in unsupported (official) countries

gotcha, thanks.

Share this post


Link to post
Share on other sites
Seems the LOCATION for bootanimation.zip has changed from sys to data/local

In the meantime, can anyone tell me how to reflash with a corrected ROM zip, if my phone is just stuck on the HTC logo screen..?

You have to remove your battery to make it stop. :D

If you have clockworkmod fake-flash "installed". Do this:

* Turn on your device with 'volume down' pressed and select 'Recovery' using the volume buttons. Power works like enter. :D

* When the exclamation mark appears, press and hold 'volume up' then press 'power'

* Select the second option, 'Apply sdcard:update.zip' (and again, use power to apply).

* That's it, ClockworkMod recovery should launch!

There you can mount your SD-card from the partition menu and transfer your new rom to your card.

Edited by Nicke

Share this post


Link to post
Share on other sites

Both on the last R8 WIP and this latest ROM From yesterday, I can not play any flash files that are posted on facebook. I can not play them via the facebook app, m.facebook.com nor via touch.facebook.com.

I always get the sorry this video can not be played error. I tried Dolphin HD, Skyfire, the built-in browser, nothing. I wiped, re-flashed, still nothing.

Anyone has any suggestions?

Share this post


Link to post
Share on other sites
Well I've just had my first ever ROM Install FAIL with this Bake...

I have a little bit of a feeling why...

Before Installing the ROM, in the past, on all versions of r8 prior to the RC, I first open the actual zip folder myself, and add in MY OWN bootanimation.zip file - as mine is the larger Nexus Lighting Arrows one.

When trying to flash my ROM today however, I get a:

"Can't symlink /system/customize/resource/bootanimation.zip"

Error.

I suspect Paul has changed something, as there was indeed no existing bootanimation.zip file in the usual place, in this ROM bake, but if so, it was a late time to change the behaviour that had applied all through r8, and more to the point, in order to get things to work, what do I now need to do please folks.

Bear in mind i know nothing about Linux, and use a Win7 machine etc.

Thanks in advance...

Yeah, it's moved! :D

If you can't boot, power on with 'volume down' held and use volume keys and power to select recovery.

P

Share this post


Link to post
Share on other sites
You have to remove your battery to make it stop. :D

If you have clockworkmod fake-flash "installed". Do this:

* Turn on your device with 'volume down' pressed and select 'Recovery' using the volume buttons. Power works like enter. :D

* When the exclamation mark appears, press and hold 'volume up' then press 'power'

* Select the second option, 'Apply sdcard:update.zip' (and again, use power to apply).

* That's it, ClockworkMod recovery should launch!

There you can mount your SD-card from the partition menu and transfer your new rom to your card.

I have ROM Manager installed/was what I was using.

As a result, it's telling me there's a:

Signature verification Failed

Installation aborted issue, when trying to apply update.zip

(For reference I renamed Paul's ROM zip to update.zip using a card reader, anticipating something like this, but alas to no avail...)

Share this post


Link to post
Share on other sites
I have ROM Manager installed/was what I was using.

As a result, it's telling me there's a:

Signature verification Failed

Installation aborted issue, when trying to apply update.zip

(For reference I renamed Paul's ROM zip to update.zip using a card reader, anticipating something like this, but alas to no avail...)

So your Going:

Boot >> Hold Back Key+Power >> BootLoader >> Recovery >> Volume Up+Power >> Install update.zip (This should be the one RomManager placed on your SD >> Flash Zip File from SD Card >> Choose Zip file >>Flash (recheck signature check off course).

And Welcome back to the land of the living, i only started using RomManager this week so was used to CW-Recovery.

Share this post


Link to post
Share on other sites
I have ROM Manager installed/was what I was using.

As a result, it's telling me there's a:

Signature verification Failed

Installation aborted issue, when trying to apply update.zip

(For reference I renamed Paul's ROM zip to update.zip using a card reader, anticipating something like this, but alas to no avail...)

Ah. You cant do that. :D

You'll need to replace your update.zip with the "clockworkmod recovery"-one.

Here's the file: http://koush.tandtgaming.com/recoveries/re...kwork-bravo.zip

Rename to update.zip and place in root of your SD-card.

Then launch recovery again.

Edit: Copy your rom to the card too. You don't need to rename the file.

Edited by Nicke

Share this post


Link to post
Share on other sites
Ah. You cant do that. :D

You'll need to replace your update.zip with the "clockworkmod recovery"-one.

Here's the file: http://koush.tandtgaming.com/recoveries/re...kwork-bravo.zip

Rename to update.zip and place in root of your SD-card.

Then launch recovery again.

Edit: Copy your rom to the card too. You don't need to rename the file.

Your file and help worked great, right until I got to "Install zip from SD card..."

At which point my screen just went blank, and that's where I'm at now.

Will give it another go...

EDIT - my bad...

I forgot that by this point, power goes back to being a POWER button *lol*

I needed to press the trackpad.

So it's chugging along now - will report back.

Thanks for all your help folks.

And a million curses to that O'Brien bloke for changing things and causing this for me...

Grins at Paul!

Edited by shadamehr

Share this post


Link to post
Share on other sites
Your file and help worked great, right until I got to "Install zip from SD card..."

At which point my screen just went blank, and that's where I'm at now.

Will give it another go...

EDIT - my bad...

I forgot that by this point, power goes back to being a POWER button *lol*

I needed to press the trackpad.

So it's chugging along now - will report back.

Thanks for all your help folks.

And a million curses to that O'Brien bloke for changing things and causing this for me...

Grins at Paul!

Lol. Saw your edit in the quote when i was replying. :D

You got it. Power in HTC recovery and trackpad in Clockworkmod. I used to do the same in the beginning. "Wtf! Why did the screen go blank?" :D

Share this post


Link to post
Share on other sites
Please see my post earlier in this thread, you have to wipe the app data for HTC Sense and they will appear, even after restoring with Titanium:

"I had the same problem after restoring with Titanium Backup - no extra widget available.

I found a workaround, just clear the data for "HTC Sense" in Setting, Applications. All short-cuts of the desktop are lost, but at least the widgets are working now."

BR Robert

Any solution to make this widgets work without lose my Sense Theme?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.