Jump to content
PaulOBrien

MCR r8 development archive

Recommended Posts

I left the box unticked for Disable menu button unlock.

But the phone does not unlock using the menu button. Any ideas?

Share this post


Link to post
Share on other sites
re: odexing the build in the kitchen, the biggest problem with this so far is an odexed build takes up more space on /system than an unodexed build and things are pretty tight for space. :D

P

Can someone tell me what's the benefit of odex-ing a ROM besides the faster initial boot? What do I get for the extra space that's used up in /system?

Share this post


Link to post
Share on other sites

Facebook for Sense causes hard battery drain because it trys nonstop sync.

After deactivating the Facebook for Sense account the problem is solved.

Share this post


Link to post
Share on other sites

I've been using these ROMs on my Desire for an age, convinced my mate to root and go onto it, ROM works great apart from mobile data. If I look in the settings Mobile Data is greyed out and says 'Turning on...' but then moves to 'Failed'. Latest radio, full wipe and current ROM. Any thoughts?

UPDATE

Also it's randomly rebooting. Bootloops a few times on the HTC screen and then eventually boots in. SD card isn't partioned in any way.

Edited by munkimatt

Share this post


Link to post
Share on other sites
I've been using these ROMs on my Desire for an age, convinced my mate to root and go onto it, ROM works great apart from mobile data. If I look in the settings Mobile Data is greyed out and says 'Turning on...' but then moves to 'Failed'. Latest radio, full wipe and current ROM. Any thoughts?

UPDATE

Also it's randomly rebooting. Bootloops a few times on the HTC screen and then eventually boots in. SD card isn't partioned in any way.

The mobile data problem is probably related to using the wrong APN. Menu-Settings-Wireless and networks-mobile networks-Access Point Names. Try putting a tick in the circle beside different APNs and see if you get connected. Other than a backup the only thing you can try is searching for the correct APN for your network on the net.

Random boots could be caused by not doing a full wipe before installing the rom.

Share this post


Link to post
Share on other sites

Thanks all for your help earlier on.

All back up and running now, on RC1 with all my apps set up again.

REMINDER TO ALL THOUGH>>>

If you Use a screen-lock pattern, and you flash a ROM, and then use Titanium Backup to restore settings... DO A TEST.

Try locking your phone, then unlocking it using a WRONG screen-lock pattern.

Chances are, it will LET YOU IN.

REMEMBER this from now on folks - it does this every time after a Titanium Restore.

The fix is simple - just go into settings, and re-set up your proper lock pattern.

.

Share this post


Link to post
Share on other sites
No issues here...

browserpage.png

Paul, did you notice that although the page didn't crash the browser for you, it complained about Flash?

Look at the text under the picture...

I've not flashed r8 yet to check again as I've been keeping an eye on my battery, trying to see how long it will last.

Currently 51hrs since charged and still 36% left so I'll probably flash on Friday :D

Aaron

Share this post


Link to post
Share on other sites
The mobile data problem is probably related to using the wrong APN. Menu-Settings-Wireless and networks-mobile networks-Access Point Names. Try putting a tick in the circle beside different APNs and see if you get connected. Other than a backup the only thing you can try is searching for the correct APN for your network on the net.

Random boots could be caused by not doing a full wipe before installing the rom.

I've checked both them off prior to posting, APN is ticked and full wipes have been done twice now.

Share this post


Link to post
Share on other sites
Again problem with "[MOD][18th-Aug] Super Circle Battery with %" - when install this - lost all apn , and restore /system/etc/apns-conf.xml with clear cache is not working. May be some know how it can be fixed?

Thanks in advance.

I had all my APN's vanish as well I did not realise it was after the Circle battery mode which i installed as well.

I just manually added my APN back but it is weird.

Share this post


Link to post
Share on other sites

One way to get the new sense widgets to work (without doing a full wipe) is to use Titanium Backup to

1) firstly backup the widgets that you can't see/use.

2) uninstall the widget

3) restore it back again

If should then appear in the widget list.

This worked for me, I hope it works for other people too.

Share this post


Link to post
Share on other sites
Can someone tell me what's the benefit of odex-ing a ROM besides the faster initial boot? What do I get for the extra space that's used up in /system?

Odexing puts .odex files under /system instead of .dex files under /data/dalvik-cache. So if you want more space under /data (if you don't want to use A2SD, for example) it's a good thing. But if you baked all of the options into your ROM, /system might be too full to odex everything.

Share this post


Link to post
Share on other sites
I had all my APN's vanish as well I did not realise it was after the Circle battery mode which i installed as well.

I just manually added my APN back but it is weird.

Once I am "reasonably" sure Paul has finished messing around :D updating the rom, I will do a new version of the fancy colored %mod nonsense, I think the apn conf xml gets whacked.

You could of course just use apk manager and diy. Takes about 5 minutes.

Share this post


Link to post
Share on other sites

Have finally baked and it is looking good thanks Paul

I've noticed that the Facebook photos have gone from the People app (apart from my own that is). All appear to be linked correctly

Any ideas?

Share this post


Link to post
Share on other sites
I've checked both them off prior to posting, APN is ticked and full wipes have been done twice now.

Can't help thinking you should have more than 2 APNs. I have seven showing with four I can put the tick against. When I flashed R8 about an hour ago I then used APN backup to restore my APN list from R7. It told me there were 504 APNs!

Share this post


Link to post
Share on other sites

Is the facebook for HTC sync option not available any more? I don't see it in the kitchen settings, and its not available in the Add account list.

The official facebook app seems to have stopped syncing altogether for me.

Share this post


Link to post
Share on other sites

ROM size limit...

Is there any definition as to the maximum size of a ROM to be flashed. We know the Desire has 512MB ROM but how much of that is actually writable with a new ROM?

A friend has just generated a zip of 230MB (298MB unzipped) - I don't think it will work but can't find anything to specify any limits.

TIA

Aaron

Share this post


Link to post
Share on other sites

Yup indeed adding/installing circle battery mod removes APN.

Id did not do this in previous R8 versions.

I tried the "reboot at least Once solution", but to no avail.

I think now that i have added APN mannually it prop won't show up for me again.

But it's still weird as i did not have this before R8RC

Share this post


Link to post
Share on other sites
Yup indeed adding/installing circle battery mod removes APN.

Id did not do this in previous R8 versions.

I tried the "reboot at least Once solution", but to no avail.

I think now that i have added APN mannually it prop won't show up for me again.

But it's still weird as i did not have this before R8RC

I installed the attached Circle Battery mod on a bake from Friday and the APNs survived.

Not tried it on RC1 yet.

YMMV!

Cheers

Aaron

framework_res.r8.zip

Share this post


Link to post
Share on other sites
Yes, my SD card is partitioned for a2sd (512 mb / 64 mb swap, created with ROM Manager, if that makes any difference)

I cannot tell you if logcat told me anything, since I was not able to boot my phone. (to the other guy that told me to just wait, I waited a long time. And in case I didn't make it clear earlier, it kept REPEATING the boot screen. It came on, it started "writing" quietly brilliant, froze for a few sec, then went black for like half a sec, then picture came back, and the animation started again... Over and over and over and....

I baked a new r8rc1 with stock boot screen, instead of the modaco one, same same.

Any other info I need to provide?

I am currently back on r8wip, which works like a charm.

I have had that REPEATING issue, only when instaling battery mods (ie super circle etc) BEFORE doing a full reboot after a flash... so if you are using supercircle, do a full reboot then install it.. (and dont include it in the kitchen)

if this helps, WooHoo! ...if not sorry!

Warmly, Marty

Share this post


Link to post
Share on other sites
I left the box unticked for Disable menu button unlock.

But the phone does not unlock using the menu button. Any ideas?

anyone???

Share this post


Link to post
Share on other sites
Can't help thinking you should have more than 2 APNs. I have seven showing with four I can put the tick against. When I flashed R8 about an hour ago I then used APN backup to restore my APN list from R7. It told me there were 504 APNs!

I did edit my APN-list from APN backup to only contain the APNs from my operator, went from 594 or so APNs to only 2. Works fine.

Share this post


Link to post
Share on other sites

I just got a 404 message from http://delia.romraid.com/cache/1282173174/...a72c4b6843d.zip, then it started redirecting to www.modaco.com after a few attempted refreshes. also, menu unlock button is no longer working... as an aside to that, is there any possibility of the trackpad wake and unlock as a few of us have requested? even if it does only end up in r9, that'd still be great.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

By using this site, you agree to our Terms of Use.