Jump to content
Tom G

CyanogenMod 6 port for Pulse

Recommended Posts

Only because FLB-Mod 2 was based on Toms froyo port and he's now focusing on CM6 as it's much easier to work with. So I pretty much agree. It's the best solution for us :)

By the way!!!

If Tom managed to port all of the cyanogen mod 6 maybe we can join the cyanogenmod community?!!

It'll be very nice if we could see a cm7 for pulse for example!

For some new future releases of android.

Gingerbread for example?!!

Edited by totiadrenalin

Share this post


Link to post
Share on other sites
darktremmor`s a2sd is working but Tom said he would try to make froyo a2sd work.

+1

if this works?

Well really darktremmor a2sd will be useful for dalvik-cache2sd

And swapp.

But maybe darktremmor could include /data/data2sd

it's very easy to be included.

just a simple commands.

And with fast sdcard it'll resoult with even more free internal data space, and better experience.

Edited by totiadrenalin

Share this post


Link to post
Share on other sites
+1

if this works?

Well really darktremmor a2sd will be useful for dalvik-cache2sd

And swapp.

But maybe darktremmor could include /data/data2sd

it's very easy to be included.

just a simple commands.

And with fast sdcard it'll resoult with even more free internal data space, and better experience.

Sad but trouth!

Share this post


Link to post
Share on other sites

We all knew the pulse wouldn't be able to handle any more updates, the minimum requirements will be to much for our pulse to handle.

Share this post


Link to post
Share on other sites
We all knew the pulse wouldn't be able to handle any more updates, the minimum requirements will be to much for our pulse to handle.

SO we are slowly but surly getting closer to the end of our pulse updates.

:)

That's sad and happy ending.

Because we will get our ultimate pulse fast and stable for using but outdated.

:)

Share this post


Link to post
Share on other sites

Finally decided to give Froyo a try, flashed this awesomeness via fastboot, used the boot_flb_0_20.img and Darktremor 2.7.5.2. Everything works, everything that's supposed to work that is :) The speed is amazing, the CM rom is amazing, the options are just.. it's all... just WOW!

Great work Tom, you did something completely unexpected and utterly brilliant. I salute you :)

Just one question, the option for compcache is irrelevant for us since we don't have the support in the kernel, right? Cheers!

Share this post


Link to post
Share on other sites
Finally decided to give Froyo a try, flashed this awesomeness via fastboot, used the boot_flb_0_20.img and Darktremor 2.7.5.2. Everything works, everything that's supposed to work that is :) The speed is amazing, the CM rom is amazing, the options are just.. it's all... just WOW!

Great work Tom, you did something completely unexpected and utterly brilliant. I salute you :)

Just one question, the option for compcache is irrelevant for us since we don't have the support in the kernel, right? Cheers!

I have also flashed the boot_flb_0_20.img and Darktremor 2.7.5.2. OC, swap and A2SD were fine working. However, the Wifi does not work

(Wifi is work after a wipe of all data and settings. Great work TomG!!)

Edited by pk0102

Share this post


Link to post
Share on other sites
I have also flashed the boot_flb_0_20.img and Darktremor 2.7.5.2. OC, swap and A2SD were fine working. However, the Wifi does not work

honestly ... now I'm completely lost with CM6 versions :)

I downloaded cm6-rc0-pulse-flash.zip from one of the flib's post and CM6.1-RC0-Pulse-beta-0.20.zip from first page of this thread...and installed the CM6.1 version since it has files from 10.10.2010 and cm6-rc0 has them from 9.10 ... but now I see that I don't have a2sd, no oc, no nothing :) can I just flash flib's ZIP from recovery or do I have to do it all over again from scratch :)

I even saw one or two posts mentioning 0.40 version!? what's that about :D a said ... a bit lost currently ...

EDIT: Hm ... is CM6 from flib's ZIP 2.2 froyo and CM6.1 is 2.2.1 froyo (with newer kernel)?

Edited by naniteboy

Share this post


Link to post
Share on other sites
honestly ... now I'm completely lost with CM6 versions :)

I downloaded cm6-rc0-pulse-flash.zip from one of the flib's post and CM6.1-RC0-Pulse-beta-0.20.zip from first page of this thread...and installed the CM6.1 version since it has files from 10.10.2010 and cm6-rc0 has them from 9.10 ... but now I see that I don't have a2sd, no oc, no nothing :) can I just flash flib's ZIP from recovery or do I have to do it all over again from scratch :)

I even saw one or two posts mentioning 0.40 version!? what's that about :D a said ... a bit lost currently ...

EDIT: Hm ... is CM6 from flib's ZIP 2.2 froyo and CM6.1 is 2.2.1 froyo (with newer kernel)?

To have the latest CM6 port version + OC + Swap + A2sd you should:

- Download CM6 0.20 from the first post (later fastboot flash all images)

- Then Download flibs boot image from two or three pages ago "boot_flb_0_20" (fastboot flash it)

- Then download "dtapps2sd-2.7.5.2-signed" and flash it thru recovery mode.

EDIT: Wow 500th!

Edited by MarcusHenrique

Share this post


Link to post
Share on other sites
To have the latest CM6 port version + OC + Swap + A2sd you should:

- Download CM6 0.20 from the first post (later fastboot flash all images)

- Then Download flibs boot image from two or three pages ago "boot_flb_0_20" (fastboot flash it)

- Then download "dtapps2sd-2.7.5.2-signed" and flash it thru recovery mode.

EDIT: Wow 500th!

Great - thank you :) 1st point already done!

And congrats on 500 :)

Edited by naniteboy

Share this post


Link to post
Share on other sites

i cant get a2sd work what am i doing wrong i part sd with 512 ext and 64 swap i flashed cm with fastboot and oc then i flash a2sd it says in adb segmatation failed

Share this post


Link to post
Share on other sites
I'm also having problems with wifi (using alex12335 upload - boot_flb_0_20.zip). It doesn't pass the acquiring IP phase.

Just a guess, but you router is probably set to only allow certain MAC addresses. The MAC on the wifi interface is set incorrectly. It is a known bug.

Froyo doesn't come with a file manager

But the previous version of CM6 did. I'm not sure where it has gone. Maybe I need to set something for it to be included.

I still think that porting the CM6 kernel will lead to fixing the last issues that we have on opur pulse.

We have the .29 kernel source for pulse from huawei.

So it'll be much easyer to take the huawei modifications and drivers for our pulse and port them in the CM6 .32 kernel source.

Then starting from scratch without the .29 kernel source.

Several of the problems are from the old kernel.

The vold problem (which is already fixed), the sd apps problem and usb tethering all appear to be kernel related.

Wouldn't it be easier to port the .29 CM kernel, then go onto the .3x kernel?

Huawei butchered the kernel, so its hard to do anything with it (but would probably help if I knew what I was doing).

camera works, taking more then one picture makes it FC every now and then

What are people experiencing with the camera? For me it always dies if I take more that one pic (the same with more than one vid) and needs a reboot to fix it.

Just one question, the option for compcache is irrelevant for us since we don't have the support in the kernel, right? Cheers!

You are probably right. I think compcache needs swap support. It should work with a kernel with swap support.

Share this post


Link to post
Share on other sites

i have a problems with gapps, when i install gapps full, i have market but not maps. and when i try gapps tiny, i have maps but not market? can't understand this pro, Any one have same problems? Helps me plzz. ( I try go to m.google.com/maps and next to market search: com.google.maps, result is not found)

Edited by TonyDigi

Share this post


Link to post
Share on other sites
WiFi isn't working for me either, it won't connect to the router, and there's no MAC filtering set.

It works with previous flbmod_v2.0alpha3 froyo, here's a log of what's happening:

http://pastebin.com/MeNRUkxB

I managed to get Wifi working by flashing the img from Toms zip through fastboot and then boot_flb_0_20.zip, dtapps2sd-2.7.5.2-signed and gapps through recovery. Wifi didnt work using fibbles CM6.1-RC0-Pulse-beta-0.20.zip

Share this post


Link to post
Share on other sites
I managed to get Wifi working by flashing the img from Toms zip through fastboot and then boot_flb_0_20.zip, dtapps2sd-2.7.5.2-signed and gapps through recovery. Wifi didnt work using fibbles CM6.1-RC0-Pulse-beta-0.20.zip

Yeah TomG fixed wifi in the latest build, it wasn't working in previous CM6 builds, but for some reason it still isn't working for me...

Anyone know how to fix busybox commands, I can't use rm, and Rom Manager fix permissions option is having an error while attempting to run privileged commands...

Share this post


Link to post
Share on other sites
I never actaully checked it got a position. I will look into it.

GPS works fine here. Found my position in 5 sec. with AGPS off :)

Share this post


Link to post
Share on other sites
- Then download "dtapps2sd-2.7.5.2-signed" and flash it thru recovery mode.

EDIT: Wow 500th!

Where is this file? I've searched through this post but can't seem to find it! Or is it the one Dan Wilson put up?

Share this post


Link to post
Share on other sites
GPS works fine here. Found my position in 5 sec. with AGPS off :)

???

How to turn off AGPS? In Location & Sec Setting only Wireless N_etworks and GPS Satellites options available :)

Checked the iGO navigaton and with the old version (FroYo 2.2, not CM6) i got my position to my house number. Now with the CM6 the navi place me somewhere in my street.

Share this post


Link to post
Share on other sites
???

How to turn off AGPS? In Location & Sec Setting only Wireless N_etworks and GPS Satellites options available :)

Checked the iGO navigaton and with the old version (FroYo 2.2, not CM6) i got my position to my house number. Now with the CM6 the navi place me somewhere in my street.

Wireless Networks is AGPS :)

Share this post


Link to post
Share on other sites
Where is this file? I've searched through this post but can't seem to find it! Or is it the one Dan Wilson put up?

I used the one that Dan put up yes ... but with this img wifi isn't working for me :) It worked without that img though ...

EDIT: LOL - tried now for 6th time and it worked :) connected to home wifi ... yeah! :)

Edited by naniteboy

Share this post


Link to post
Share on other sites

I have flashed Toms latest build, then the OC boot image, then pulse gapps, then dta2sd-2.7.5.2 and everything seemed ok until i did a2sd check, a2sd is working but it says that swap cannot start due to the swapon or swapoff command not implemented? I issued a2sd reswap and it seemed to find the partition then but when i do a2sd swapspace it returns with 0 kb? Swapper2 doesnt work also.

It sees to work now, swapspace returns with 64 Mb :) Well if anyone is experiencing the same symptoms i think they will be solved when we have froyo a2sd :)

cheers

Edited by flip360

Share this post


Link to post
Share on other sites
GPS works fine here. Found my position in 5 sec. with AGPS off :)

It looks like it works sometimes. It work fine for me once but now won't work.

PS. FileManger and CMstats should still be there. They are still in the repo manifest but for some reason won't download. There are no errors, it just doesn't pull them from git.

Edited by Tom G

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.