Jump to content
doktorko

performance issues from time to time

Recommended Posts

Hi, i have been using r9 for already some time. What occasionaly happens is, that whole device gets very slow. The onky thing helping is rebooting, then it is perfect quick again. No cache clearing, no process killing helps. I tried to diagnose it with quick system info and autostarts, however i did not notice anything abnormal.

Please give me any ideas of:

- similar experience, eventualy solution :-)

- how to diagnose it even better, application, or which log to check

Thanks

Share this post


Link to post
Share on other sites

+1

Have you tried any other ROM's to see if you get similar issues?

Are you using the CPU Governor additions?

I am going to try a different ROM for a few days and see if I have similar problems or not... I'll report back.

Share this post


Link to post
Share on other sites
+1

Have you tried any other ROM's to see if you get similar issues?

Are you using the CPU Governor additions?

I am going to try a different ROM for a few days and see if I have similar problems or not... I'll report back.

thanks for reply Daddy :)

- no, I have not yet - good idea, I will probably try (wipe is scaring me :))

- yes, I chose disable perflock, governor settings, and I use SetCPU, but it did before I had SetCPU

- my radio is 32.47.00.32U - what about yours?

Strange on the thing is, that it is occuring 2-3 times a week, even not everyday. After reboot, everything fine

Share this post


Link to post
Share on other sites
thanks for reply Daddy :)

- no, I have not yet - good idea, I will probably try (wipe is scaring me :))

- yes, I chose disable perflock, governor settings, and I use SetCPU, but it did before I had SetCPU

- my radio is 32.47.00.32U - what about yours?

Strange on the thing is, that it is occuring 2-3 times a week, even not everyday. After reboot, everything fine

- I have the same radio

- I'm not using SetCPU, just disable perflock and governor settings

- have you added any new apps recently that might be hogging background processes? I've recently installed Skype which always seems to be running even when I've ended the task... Other than that a few things but mostly games.

I'm trying LeeDroid out for a few days, but not going to wipe if I can avoid it...

Share this post


Link to post
Share on other sites

You should definitely wipe if you're switching ROM completely. Backup everything with Titanium Backup and you'll be fine.

Share this post


Link to post
Share on other sites

Don't use the "Custom governor settings".

Very often it takes longer than one would want for the CPU to speed back up after turning on the screen, during which the slowness is extremely annoying. I don't see any significant battery life gain with the "custom governor settings" anyway, it's not worth it.

Share this post


Link to post
Share on other sites
Don't use the "Custom governor settings".

Very often it takes longer than one would want for the CPU to speed back up after turning on the screen, during which the slowness is extremely annoying. I don't see any significant battery life gain with the "custom governor settings" anyway, it's not worth it.

+1 .... kinda... Battery is a bit better with the governor, but I agree it's a bit annoying.

Share this post


Link to post
Share on other sites

+1

Same issue.

For me it started with one of my r9 updates. First I tried a r9 version with perflock disabled and custom governors included in the ROM - did not like how the custom governors work - the device would be sluggish for like 10 secs every time when coming out of sleep and I did not see that much of a battery life improvement. The way I understand how the custom governors work is that if the phone spends extended periods of time in sleep mode, one would see considerable difference in battery life, but my usage pattern is quite different - frequent wake ups, etc.

So I baked a version of the ROM with perflock on and no custom power governors. Sluggishness at startup disappeared but started having the type of behaviour the OP describes. At that time the r9 ROM was updated every other day (look at the change log) however.

Then I baked a new r9 ROM - no custom governors and no custom IO, thinking this would be another possible cause. No. Same issue.

I would not suppose Paul is tinkering with any other settings and not disclosing them in the change log - as far as I know he takes a stock ROM as an input and applies a list of optimizations, that, in his experience, help with the performance of the phone. The rest is just include this app and exclude that one - something the kitchen does OK. But with the 'initial release' all optimizations must have been already there...

Looking at the change log from r8 (the happiest I've been with any ROM) the only change that is not just an update to a newer version of some app is:

20/Sep 17:00 BST

Phase 1 of later versions merge. This includes the majority of changes from 2.10. More to follow from other new versions. Note that this update also suppresses the OTA update warning.

What might have happened is some parts of the 2.10 update did not like Paul's optimizations but he did not have time to test extensively. Remember, what we complain about only happens from time to time - not all the time.

I am running a newer radio BTW - the 32.48.00.32U_5.11.05.14 with the RILs from the 32.47...radio - works fine and the RILs were not available as an update.zip at the time I got the radio, so I did not bother installing them afterwards when they became available.

Hm! Another thing - is everybody running A2SD/A2SD+

Share this post


Link to post
Share on other sites
Don't use the "Custom governor settings".

Very often it takes longer than one would want for the CPU to speed back up after turning on the screen, during which the slowness is extremely annoying. I don't see any significant battery life gain with the "custom governor settings" anyway, it's not worth it.

I've been using the latest LeeDroid which also has custom governor settings and so far I've not had any of the performance issues I was experiencing with MCR r9... though it's only been 24 hours... battery life seems on par, except for some commute time Angry Birds drainage :)

I'll keep using this ROM for a few days, then switch back to r9 and see if the performance issues come back again.

nb. flashed LeeDroid with no wipe and I had no problems.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.