Jump to content
flibblesan

[ROM][OLED+TFT] FLB-Froyo G2 for ZTE Blade

Recommended Posts

thx v much.

however....when i put the space in, i get 'can't stat 'ContactsProvider.app' : No such file or directory' same with second suggestion

when i try it as before i get

BusyBox

Usage

Copy

Options

driving me mad....thx tho.

Make sure ContactsProvider.apk is on your sdcard.

In terminal type :

busybox mount -o rw,remount /system

cp /sdcard/ContactsProvider.apk /system/app

Double check the spelling and case of all the commands you write.

John.

Share this post


Link to post
Share on other sites

I have a problem where Dolphin Browser HD sometimes force closes on me - I open it and get a black screen and then FCs. I dont know if that is a ROM thing or just the app

Share this post


Link to post
Share on other sites

i am curious why the comparison table for all roms say, that flb-rom has Launcher2 while all others use the Stock launcher or launcher pro. I dont find much about launcher 2 on the net, only what it was first used with android1.6 and it was the extraced launcher from android2.0 with more screens... and i dont see any difference to the launcher used by other 2.2 custom roms for the blade!?

http://android.modaco.com/content/zte-blad...and-other-roms/

Share this post


Link to post
Share on other sites
i am curious why the comparison table for all roms say, that flb-rom has Launcher2 while all others use the Stock launcher or launcher pro. I dont find much about launcher 2 on the net, only what it was first used with android1.6 and it was the extraced launcher from android2.0 with more screens... and i dont see any difference to the launcher used by other 2.2 custom roms for the blade!?

http://android.modaco.com/content/zte-blad...and-other-roms/

Launcher2 is the stock launcher :D

Share this post


Link to post
Share on other sites
Make sure ContactsProvider.apk is on your sdcard.

In terminal type :

busybox mount -o rw,remount /system

cp /sdcard/ContactsProvider.apk /system/app

Double check the spelling and case of all the commands you write.

John.

thx.

am getting same 'can't stat' message. it's definitely on the card. i'll keep trying....until i implode. thx again

Share this post


Link to post
Share on other sites

I do not know if this has been asked but I have several must-have apps which I usually put into system/apps to got them installed during first boot.

This is what I've done with this excellent ROM but many (none?) of them got installed, however, when I install them one by one they work as designed. Can anyone help me?

Share this post


Link to post
Share on other sites
Launcher2 is the stock launcher :D

because it is the stock launcher for all roms >2.0 ? but why the table state it as launcher2 and all other roms are named with the stock launcher?

Share this post


Link to post
Share on other sites
thx.

am getting same 'can't stat' message. it's definitely on the card. i'll keep trying....until i implode. thx again

If you have adb installed then you could try connecting to your phone like that and issuing the commands

adb shell

su

mount -o remount,rw -t yaffs2 /dev/block/mtdblk3 /system

cp /sdcard/ContactsProvider.apk /system/app

reboot

If that doesn't work then it might be worth re-downloading the ContactsProvider.apk again and making sure the download is complete :D

Edited by Qwertzycoatl

Share this post


Link to post
Share on other sites

Touchpal can be fixed using the touchpal.apk that is linked in the "Touchpal is gone" thread on the main Blade page....

I find this touchpal version a lot better than the one on the market. The market one doesn't seem to allow you to cut a word short - It autofills its word choice and I couldn't find a way of fixing that.

So thats touchpal and contacts fixed. Next!

Edited by Malkatraz

Share this post


Link to post
Share on other sites

If replace an apk file from r6 rom (for contacts bugfix) what should be the compression method.

I tried once and flashed but it didn't work.

Can someone upload the r6 with fixed Contacts. Some people have already done this so they can post it.

Share this post


Link to post
Share on other sites

Damn. Touchpal was working but I installed the Gingerbread theme and a couple of other things and then it didn't. Maybe from the restart or something to do with the installs? I have reinstalled and working again.

Share this post


Link to post
Share on other sites
Damn. Touchpal was working but I installed the Gingerbread theme and a couple of other things and then it didn't. Maybe from the restart or something to do with the installs? I have reinstalled and working again.

Looks like a particular file is overwritten then somewhere by the theme perhaps? (I doubt that though :P)

Good to know it is fixable though :D

If replace an apk file from r6 rom (for contacts bugfix) what should be the compression method.

I tried once and flashed but it didn't work.

I believe you use the "Store" option when recompressing (although you should just be able to drag and drop the apk into the rom zip file)

Share this post


Link to post
Share on other sites
but one issue left for me:

AGPs isn't working as accurate as it was on r2a. WiFi on/3G off = 200meters // WiFi off/3G on = 2000meters

GPS (navigation) is OK so far, but was also better in r2a

can anyone confirm oder deny this? :D

Share this post


Link to post
Share on other sites
can anyone confirm oder deny this? :D

Just tried this without 3G enabled just using standard GPS and was accurate to 100 metres

With wireless enabled I got accuracy to 70 metres :P

Share this post


Link to post
Share on other sites
So thats touchpal and contacts fixed. Next!

How about this one then...

'Phone is SIM Network Subset Locked' is displayed when waking phone from standby

When using the pattern-lock screen, when the lock is on, and before you enter the pattern to unlock the phone the message "Phone is SIM Network Subset Locked" is displayed. Using a Vodafone PAYG sim on an obviously unlocked SanFran OLED.

Share this post


Link to post
Share on other sites
Can someone upload the r6 with fixed Contacts. Some people have already done this so they can post it.

Is there likely to be an r7 soon, with the contacts fix and the wifi improvement, among other things? (Something to do with wifi "supplicant", but can't find the post now).

Share this post


Link to post
Share on other sites
How about this one then...

'Phone is SIM Network Subset Locked' is displayed when waking phone from standby

When using the pattern-lock screen, when the lock is on, and before you enter the pattern to unlock the phone the message "Phone is SIM Network Subset Locked" is displayed. Using a Vodafone PAYG sim on an obviously unlocked SanFran OLED.

Can you try taking off the security pattern and see if you get the same error message?

Perhaps try a PIN number instead and see if the issue still occurs :D

Share this post


Link to post
Share on other sites
Yeah i know i really can't get my head around it. I've done a diff on the styles.xml and there is nothing else i can change between mine and the 2.1 version. That's why i provided most with white menu's to help readability. The black ones are not quite right but people still wanted them.

thanks for trying to solve this. I see (on your other thread) the other themers have also had a go at it. The problem is that this only happens on your gingerbread black menu ones that renders these app background/text this way. When I load the same gingerbread theme that FLB put out with his rls6 rom it is fine. The difference between the two themes (besides this issue) is yours has the circle battery, which I find very useful.

Share this post


Link to post
Share on other sites
How about this one then...

'Phone is SIM Network Subset Locked' is displayed when waking phone from standby

When using the pattern-lock screen, when the lock is on, and before you enter the pattern to unlock the phone the message "Phone is SIM Network Subset Locked" is displayed. Using a Vodafone PAYG sim on an obviously unlocked SanFran OLED.

It's a bug in the framework showing that message. It's meant to say "Phone is locked" or something like that. It's only showing the message because you have enabled password or pin lock. I'll see about changing it.

If the framework is decoded that it can be found in /res/values/strings.xml

<string name="lockscreen_sim_network_subset_locked_message">Phone is SIM Network Subset locked</string>

If I just edit this to say "Phone is locked" would that be better for people?

Edited by flibblesan

Share this post


Link to post
Share on other sites
It's a bug in the framework showing that message. It's meant to say "Phone is locked" or something like that. It's only showing the message because you have enabled password or pin lock. I'll see about changing it.

If the framework is decoded that it can be found in /res/values/strings.xml

<string name="lockscreen_sim_network_subset_locked_message">Phone is SIM Network Subset locked</string>

If I just edit this to say "Phone is locked" would that be better for people?

Noooooooooooo... this means i will have to do this for all my themes :D

Share this post


Link to post
Share on other sites
thanks for trying to solve this. I see (on your other thread) the other themers have also had a go at it. The problem is that this only happens on your gingerbread black menu ones that renders these app background/text this way. When I load the same gingerbread theme that FLB put out with his rls6 rom it is fine. The difference between the two themes (besides this issue) is yours has the circle battery, which I find very useful.

Wait...are you saying that Flibs Gingerbread theme has black menu's in Root Explorer etc?????

EDIT: Seems if that is true i just have a dodgy image somewhere maybe...

Edited by Frankish

Share this post


Link to post
Share on other sites
Noooooooooooo... this means i will have to do this for all my themes :D

LOL. takes a couple of minutes using apktool :P

Share this post


Link to post
Share on other sites
Wait...are you saying that Flibs Gingerbread theme has black menu's in Root Explorer etc?????

EDIT: Seems if that is true i just have a dodgy image somewhere maybe...

Nope. Mine kept the grey backgrounds. And I'm glad I didn't try to change them since you've had problems :D

Share this post


Link to post
Share on other sites
Nope. Mine kept the grey backgrounds. And I'm glad I didn't try to change them since you've had problems :D

Ahhh right fair enough.

Share this post


Link to post
Share on other sites
If you have adb installed then you could try connecting to your phone like that and issuing the commands

adb shell

su

mount -o remount,rw -t yaffs2 /dev/block/mtdblk3 /system

cp /sdcard/ContactsProvider.apk /system/app

reboot

If that doesn't work then it might be worth re-downloading the ContactsProvider.apk again and making sure the download is complete :D

:P

thx ever so much for your help, guys. it was something quite blindingly obvious...winzip had ever so nicely packed it away under its own guise and was thus ContactsProvider.zip. Took it out of folder and all working straight away.

Thx for this ROM, too. I'll say it again! It's markedly smoother and, well, just nicer to use.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

By using this site, you agree to our Terms of Use.