Jump to content
PaulOBrien

Advent Vega kernel source code now available!

Recommended Posts

bccmd and hciattach can be made from source. nv_hciattach is just wrapper for them.

refer https://github.com/n...er/hciattach.sh

this script do same thing as nv_hciattach.

bluecore6.psr should have MAC address. P10AN01's stock rom generate MAC address from wifi MAC address on boot.

refer https://github.com/n...ster/makepsr.sh

I don't know where wifi mac address is stored on .36 kernel. just for reference :)

EDIT: my p10an01 repo is just for my personal purpose and almost obsolete. nothing is useful other than above ;)

CM7 gets it mac address for BT from a script in /system/etc/bluetooth.sh ..

http://pastebin.com/ci4anj9V

Similar or most likely the same could be replicated for 3,2 .. we should just have to copy Bluetooth.sh across...

Share this post


Link to post
Share on other sites

bccmd and hciattach can be made from source. nv_hciattach is just wrapper for them.

refer https://github.com/n...er/hciattach.sh

this script do same thing as nv_hciattach.

bluecore6.psr should have MAC address. P10AN01's stock rom generate MAC address from wifi MAC address on boot.

refer https://github.com/n...ster/makepsr.sh

I don't know where wifi mac address is stored on .36 kernel. just for reference :)

EDIT: my p10an01 repo is just for my personal purpose and almost obsolete. nothing is useful other than above ;)

bluez can be built from source as long as it has this patch

https://github.com/C...64ddda577b5b012

and a simple shell script like your makepsr.sh run at startup to append a correctly formatted wifi mac address to the beginning of the bluecore6.psr file is needed but as with you I do not know where the wifi mac address can be parsed in the .36 kernel. can anyone help here?

Yes Cass the only thing that needs changing in that shell script to reflect the .36 kernel is:

ADDR=`cat /sys/devices/platform/tegra-sdhci.0/mmc_host/mmc0/mmc0:0001/mmc0:0001:1/net/wlan0/address'

I couldnt get it to return anything but I was tired and may have miss typed something

Edited by wooshy1

Share this post


Link to post
Share on other sites

bluez can be built from source as long as it has this patch

https://github.com/C...64ddda577b5b012

and a simple shell script like your makepsr.sh run at startup to append a correctly formatted wifi mac address to the beginning of the bluecore6.psr file is needed but as with you I do not know where the wifi mac address can be parsed in the .36 kernel. can anyone help here?

Yes Cass the only thing that needs changing in that shell script to reflect the .36 kernel is:

ADDR=`cat /sys/devices/platform/tegra-sdhci.0/mmc_host/mmc0/mmc0:0001/mmc0:0001:1/net/wlan0/address'

I couldnt get it to return anything but I was tired and may have miss typed something

I think when I experimented with the BT, i found out that on the new kernel (HC3.2b5) its sdhci-tegra.0, but the net directory was not there

Share this post


Link to post
Share on other sites

bluez can be built from source as long as it has this patch

https://github.com/C...64ddda577b5b012

and a simple shell script like your makepsr.sh run at startup to append a correctly formatted wifi mac address to the beginning of the bluecore6.psr file is needed but as with you I do not know where the wifi mac address can be parsed in the .36 kernel. can anyone help here?

Yes Cass the only thing that needs changing in that shell script to reflect the .36 kernel is:

ADDR=`cat /sys/devices/platform/tegra-sdhci.0/mmc_host/mmc0/mmc0:0001/mmc0:0001:1/net/wlan0/address'

I couldnt get it to return anything but I was tired and may have miss typed something

Got to say Wooshy, absolutely amazing work, great job! This fix will be integrated in to the next version of VegaComb. I hope those in the community who were eagerly awaiting working bluetooth thank you as you deserve!

newbe5

  • Upvote 1

Share this post


Link to post
Share on other sites

Just to let everyone know I've made a thread to collaborate the bugs people are coming up with and free up the main thread a bit. I don't have time to learn kernel dev atm (though I'm dying to) and I can't afford to donate, so I wanted to do something to help, lol.

I've done a google docs spreadsheet now to make it easier for everyone, which links into the forum for more info.

http://tabletroms.com/forums/vega-rom-development/2139-vegacomb-3-2-known-bug-thread.html

I'm assuming you're handling the build releases Newbie? Could do with getting one or two peoples e-mails to give them access so they can edit the spreadsheet when fixes are ready to be put in builds or when they've been released. It's probably best to limit access to just a couple of people though.

Cheers, Jimmy

  • Upvote 1

Share this post


Link to post
Share on other sites

Just to let everyone know I've made a thread to collaborate the bugs people are coming up with and free up the main thread a bit. I don't have time to learn kernel dev atm (though I'm dying to) and I can't afford to donate, so I wanted to do something to help, lol.

I've done a google docs spreadsheet now to make it easier for everyone, which links into the forum for more info.

http://tabletroms.co...bug-thread.html

I'm assuming you're handling the build releases Newbie? Could do with getting one or two peoples e-mails to give them access so they can edit the spreadsheet when fixes are ready to be put in builds or when they've been released. It's probably best to limit access to just a couple of people though.

Cheers, Jimmy

Cracking work! Just sent you a PM RE: This ;)

  • Upvote 1

Share this post


Link to post
Share on other sites

Got to say Wooshy, absolutely amazing work, great job! This fix will be integrated in to the next version of VegaComb. I hope those in the community who were eagerly awaiting working bluetooth thank you as you deserve!

newbe5

No thanks required, glad I could help plus its one less thing for the more accomplished devs to waste time on. I must say I am amazed by the work put in by everyone, considering we have no source just shows the quality of the devs here and what can be done when you get a good community working together on a project.

good work eveyone o/

ps cant wait for the next vc build ;)

Edited by wooshy1
  • Upvote 1

Share this post


Link to post
Share on other sites

Hi all,

I've some news about the camera... :-)

I've been able to implement the first version of the V4L2 camera for our great device... :-)

Please try it and let me know if it works for you...

Best Regars,

Kamil

camera.zip

Share this post


Link to post
Share on other sites

Since upgrading from build 5 to 7 -> 8 update I can't download from the market and keep getting the following every few minutes in the logcat. You think it's an install problem, or a bug in the update?

08-28 17:01:08.910: ERROR/TelephonyManager(270): Hidden constructor called more than once per process!

08-28 17:01:08.910: ERROR/TelephonyManager(270): Original: com.google.android.location, new: com.google.android.gsf

08-28 17:01:08.910: INFO/CheckinService(270): Preparing to send checkin request

08-28 17:01:08.910: INFO/EventLogService(270): Accumulating logs since 1314547093502

08-28 17:01:09.030: DEBUG/dalvikvm(270): GC_CONCURRENT freed 517K, 12% free 6079K/6855K, paused 3ms+4ms

08-28 17:01:09.030: INFO/CheckinTask(270): Sending checkin request (2102 bytes)

08-28 17:01:09.220: WARN/DefaultRequestDirector(270): Authentication error: Unable to respond to any of these challenges: {}

08-28 17:01:09.240: ERROR/CheckinTask(270): Checkin failed: https://android.clients.google.com/checkin (request #0)

08-28 17:01:09.240: ERROR/CheckinTask(270): java.io.IOException: Rejected response from server: HTTP/1.1 401 bad security token

08-28 17:01:09.240: ERROR/CheckinTask(270): at com.google.android.gsf.checkin.CheckinTask.parseResponse(CheckinTask.java:345)

08-28 17:01:09.240: ERROR/CheckinTask(270): at com.google.android.gsf.checkin.CheckinTask.sendRequest(CheckinTask.java:293)

08-28 17:01:09.240: ERROR/CheckinTask(270): at com.google.android.gsf.checkin.CheckinTask.doInBackground(CheckinTask.java:155)

08-28 17:01:09.240: ERROR/CheckinTask(270): at com.google.android.gsf.checkin.CheckinService$1.doInBackground(CheckinService.java:235)

08-28 17:01:09.240: ERROR/CheckinTask(270): at com.google.android.gsf.checkin.CheckinService$1.doInBackground(CheckinService.java:225)

08-28 17:01:09.240: ERROR/CheckinTask(270): at android.os.AsyncTask$2.call(AsyncTask.java:252)

08-28 17:01:09.240: ERROR/CheckinTask(270): at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:305)

08-28 17:01:09.240: ERROR/CheckinTask(270): at java.util.concurrent.FutureTask.run(FutureTask.java:137)

08-28 17:01:09.240: ERROR/CheckinTask(270): at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1081)

08-28 17:01:09.240: ERROR/CheckinTask(270): at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:574)

08-28 17:01:09.240: ERROR/CheckinTask(270): at java.lang.Thread.run(Thread.java:1020)

Share this post


Link to post
Share on other sites

Since upgrading from build 5 to 7 -> 8 update I can't download from the market and keep getting the following every few minutes in the logcat. You think it's an install problem, or a bug in the update?

Please, clear all market data and try it again, Build8 market runs fine here.

rebel1

Share this post


Link to post
Share on other sites

Please, clear all market data and try it again, Build8 market runs fine here.

rebel1

Tried that, must be an install problem with titanium or something, someone else had same problem with last build. I cleared data, cleared cache, made a new account and switched, deleted old account and tried again.

Deleted the market app and trying gapps from CM7 now cos too lazy to do full re-install, lol. :D

Seems like BT+Wifi is still broke though, when you turn Bluetooth off it kills the Wifi until reboot.

Share this post


Link to post
Share on other sites

Since upgrading from build 5 to 7 -> 8 update I can't download from the market and keep getting the following every few minutes in the logcat. You think it's an install problem, or a bug in the update?

Jimmy,

This line is the most worrying for me:

08-28 17:01:09.220: WARN/DefaultRequestDirector(270): Authentication error: Unable to respond to any of these challenges: {}

It looks lick you haven't set-up what ever networking accounts to allow the "checkin" process. You may want to either as suggested do a complete wipe and start again or go into the settings and remove existing accounts and manually rebuild list.

Good luck.

Billy..

Share this post


Link to post
Share on other sites

Jimmy,

This line is the most worrying for me:

08-28 17:01:09.220: WARN/DefaultRequestDirector(270): Authentication error: Unable to respond to any of these challenges: {}

It looks lick you haven't set-up what ever networking accounts to allow the "checkin" process. You may want to either as suggested do a complete wipe and start again or go into the settings and remove existing accounts and manually rebuild list.

Good luck.

Billy..

Yeah, I was kinda worried too, but I think it's a corruption issue with titanium backup. Both instances this has occoured Titanium has been used, thinking about it, it actually worked fine before I restored my backup as I had to download Titanium.

Share this post


Link to post
Share on other sites

Hi all,

I've some news about the camera... :-)

I've been able to implement the first version of the V4L2 camera for our great device... :-)

Please try it and let me know if it works for you...

Best Regars,

Kamil

Hi Kamil,

This lib / apk on its own FC's .. is there any other dependent libs i should be using ? Like some of the Eduardo libs etc ...

http://pastebin.com/40WXKerZ

Been using so many diff libs recently its hard to keep track ...

Cheers

Cass

Share this post


Link to post
Share on other sites

Hi Cass,

this is probably a bug in camera application, please try this original asus transformer camera apk (it works fine for me):

ASUS Transformer camera application

If you will have problems with installing (like me), then copy the camera apk directly into the /system/app/ and then clear dalvik cache...

Let me know if it helps...

Kamil

Edit: You can also try the newer version of the libcamera.so, first one is compiled with "CAMERA_FACING_FRONT" and second one is compiled with the "CAMERA_FACING_BACK". The second one should work with the older version of camera apk...

libcamera facing back

libcamera facing front

Edited by redscorpion

Share this post


Link to post
Share on other sites

Hi Cass,

this is probably a bug in camera application, please try this original asus transformer camera apk (it works fine for me):

ASUS Transformer camera application

If you will have problems with installing (like me), then copy the camera apk directly into the /system/app/ and then clear dalvik cache...

Let me know if it helps...

Kamil

FSCK ME , IT WORKS !!!!!!! nice work chap :)

On first install it seems not to do anything camera app never appears (fresh install of OS), resigned the app etc .. nothing , then after a reboot it works great, app appears and starts fine .. just took a picture of myself, nearly broke my camera doing that .. LOL :)

REALLY REALLY NICE WORK MAN ... THANKS !!!!

http://pastebin.com/vPUD5Yhk

Cass

Edited by Cass67

Share this post


Link to post
Share on other sites

Really nice work man. With the Transformer apk it works really good.

Hmm, now we need only to add usb host mode and maybe fix the choppy bt. rolleyes.gif

Share this post


Link to post
Share on other sites

Hi Cass,

this is probably a bug in camera application, please try this original asus transformer camera apk (it works fine for me):

ASUS Transformer camera application

If you will have problems with installing (like me), then copy the camera apk directly into the /system/app/ and then clear dalvik cache...

Let me know if it helps...

Kamil

Edit: You can also try the newer version of the libcamera.so, first one is compiled with "CAMERA_FACING_FRONT" and second one is compiled with the "CAMERA_FACING_BACK". The second one should work with the older version of camera apk...

libcamera facing back

libcamera facing front

Oh my gosh... you and Ed are legends, I don't think you could be ever thanked enough. Now you will find your work pushed into so many ROMS in the coming weeks.

I'll have go tomorrow to get this part of VegaComb. Newbe5 will be pleased with this late birthday present.

I can't wait to see it working.

Billy..

Share this post


Link to post
Share on other sites

Edit: You can also try the newer version of the libcamera.so, first one is compiled with "CAMERA_FACING_FRONT" and second one is compiled with the "CAMERA_FACING_BACK". The second one should work with the older version of camera apk...

libcamera facing back

libcamera facing front

ffront and any apk seems fail for me ...

fback and default VegaComb T1 apk and Stock camera apk works well ...

My preference to stick with is the initial libcamera.so and the transformer apk you provided before the edit ..

Thanks man .. one more hurdle knocked over !!

EDIT : -- NO !!, saying that .. i should prefer now the fback lib and the stock camera app as with the transformer app it provides a way to rotate the camera, hitting that button makes the app FC.. The stock camera has none of that but the sound on video sounds a bit low... :)

One for the chaps to think about methinks, or we just edit the apk to remove the rotate icon ;

Edited by Cass67

Share this post


Link to post
Share on other sites

Hi Cass,

this is probably a bug in camera application, please try this original asus transformer camera apk (it works fine for me):

ASUS Transformer camera application

If you will have problems with installing (like me), then copy the camera apk directly into the /system/app/ and then clear dalvik cache...

Let me know if it helps...

Kamil

Edit: You can also try the newer version of the libcamera.so, first one is compiled with "CAMERA_FACING_FRONT" and second one is compiled with the "CAMERA_FACING_BACK". The second one should work with the older version of camera apk...

libcamera facing back

libcamera facing front

Hey, excellent work! - I was also working on this, but i had several problems ... so, i didnt finish my version yet... But, i tried yours, and it works very well... One thing i would suggest, is to, when you init the default preview and capture parameters, add several extra keys/value pairs. Those extra keys will greatly improve compatibility with a lot of existing programs.

What i did in my initDefaultParameters() was:

CameraParameters p;

int i;

int pw = MIN_WIDTH;

int ph = MIN_HEIGHT;

int pfps = 30;

int fw = MIN_WIDTH;

int fh = MIN_HEIGHT;

SortedVector<SurfaceSize> avSizes; // List of possible sizes

SortedVector<int> avFps; // list of possible Frames per second

///

fill in all data here

///

// Convert the sizes to text

String8 szs("");

for (i = 0; i < avSizes.size(); i++)

{

char descr[32];

SurfaceSize ss = avSizes;

sprintf(descr,"%dx%d",ss.getWidth(),ss.getHeight());

szs.append(descr);

if (i < avSizes.size() - 1)

{

szs.append(",");

}

}

// Convert the fps to text

String8 fps("");

for (i = 0; i < avFps.size(); i++)

{

char descr[32];

int ss = avFps;

sprintf(descr,"(%d,%d)",ss,ss);

fps.append(descr);

if (i < avFps.size() - 1)

{

fps.append(",");

}

}

LOGI("Default preview size: (%d x %d), fps:%d\n",pw,ph,pfps);

LOGI("All available formats: %s",(const char*)szs);

LOGI("All available fps: %s",(const char*)fps);

LOGI("Default picture size: (%d x %d)\n",fw,fh);

// Now store the data

p.set(CameraParameters::KEY_SUPPORTED_ANTIBANDING,"auto");

p.set(CameraParameters::KEY_ANTIBANDING,"auto");

p.set(CameraParameters::KEY_SUPPORTED_EFFECTS,"none"); // "none,mono,sepia,negative,solarize"

p.set(CameraParameters::KEY_EFFECT,"none");

p.set(CameraParameters::KEY_SUPPORTED_FLASH_MODES,"off");

p.set(CameraParameters::KEY_FLASH_MODE,"off");

p.set(CameraParameters::KEY_SUPPORTED_FOCUS_MODES,"fixed");

p.set(CameraParameters::KEY_FOCUS_MODE,"fixed");

#if 0

p.set(CameraParameters::KEY_JPEG_THUMBNAIL_HEIGHT,"0"); // no thumbnail

p.set(CameraParameters::KEY_JPEG_THUMBNAIL_QUALITY,"75");

p.set(CameraParameters::KEY_SUPPORTED_JPEG_THUMBNAIL_SIZES,"0x0"); // no thumbnail

p.set("jpeg-thumbnail-size","0x0"); // no thumbnail

p.set(CameraParameters::KEY_JPEG_THUMBNAIL_WIDTH,"0"); // no thumbnail

#endif

p.set(CameraParameters::KEY_JPEG_QUALITY,"85"); // KEY_JPEG_QUALITY

p.set(CameraParameters::KEY_SUPPORTED_PICTURE_FORMATS,"jpeg");

p.setPictureFormat("jpeg"); // [p.set("picture-format","jpeg")] KEY_PICTURE_FORMAT

p.set(CameraParameters::KEY_SUPPORTED_PICTURE_SIZES, szs); // KEY_SUPPORTED_PICTURE_SIZES

p.setPictureSize(fw,fh); // [p.set("picture-size","2048x1536")] KEY_PICTURE_SIZE

p.set(CameraParameters::KEY_SUPPORTED_PREVIEW_FORMATS,"yuv422sp");

p.setPreviewFormat("yuv422sp"); // [p.set("preview-format","yuv420sp")] KEY_PREVIEW_FORMAT

p.set(CameraParameters::KEY_SUPPORTED_PREVIEW_FPS_RANGE,fps);

p.setPreviewFrameRate( pfps ); // [p.set("preview-frame-rate","24")] KEY_PREVIEW_FRAME_RATE

p.set(CameraParameters::KEY_SUPPORTED_PREVIEW_SIZES, szs);

p.setPreviewSize(pw,ph); // [p.set("preview-size","320x240")] KEY_PREVIEW_SIZE

p.set("rotation-values","0");

p.set(CameraParameters::KEY_ROTATION,"0");

p.set(CameraParameters::KEY_SUPPORTED_SCENE_MODES,"auto");

p.set(CameraParameters::KEY_SCENE_MODE,"auto");

p.set(CameraParameters::KEY_SUPPORTED_WHITE_BALANCE,"auto");

p.set(CameraParameters::KEY_WHITE_BALANCE,"auto");

p.set(CameraParameters::KEY_SMOOTH_ZOOM_SUPPORTED,"false");

p.set("max-video-continuous-zoom","0");

p.set(CameraParameters::KEY_MAX_ZOOM,"0");

p.set(CameraParameters::KEY_ZOOM_RATIOS,"100");

p.set(CameraParameters::KEY_ZOOM_SUPPORTED,"false");

p.set(CameraParameters::KEY_ZOOM,"0");

if (setParameters(p) != NO_ERROR) {

LOGE("Failed to set default parameters?!");

}

Try, for example, the following apps:

"Retro Camera"

"demotival camera"

"Photalf"

to see what i am talking about ;)

Hope it helps,

Eduardo

PD: I have attached the sources i was working on. Even if we don-t use them, i'd suggest you should take a look at some parts of them, specially the color converter routines... yuyv_to_rgb565 was optimized quite a bit.

The other routine of interest (though i dont know if it works) is the JPEG save function, that instead of reconverting yuyv to RGB and using a temporary file, does it in memory... Those are the most significant and interesting parts ;)

PD2: And another thing that would be really nice, would be to enable and disable the camera, to save power... Right now, the camera is always on... you can control it through /sys/platform/devices/shuttle-pm-camera/power_on ...

uvc2.rar

Edited by ejtagle

Share this post


Link to post
Share on other sites

Hi Eduardo,

thanks, but it would be impossible to do it without your excelent reverse engineering skills!

I've started (probably as like you) from the Andromidian V4L2 camera patch, but I've had only a lot of crashes before you have posted the new virtual table and interface for the new honeycomb CameraHardwareInterface...

...so BIG THANKS to you!!!

I've concentrated only to "make it work" with the one specific camera application, and with the vega specific camera.... That means so your code is much more generic and it will be great if you will be able to finish it... Feel free to look at the sources and use what you want (if there will be something interesting for you - I'm a Java developer so please be patient... ;-) )... I'm already using some parts (mainly the Convertor to yuv420p and CameraHardwareInterface) from your sources so it should be a not problem to combine them...

In meantime I'll try to add the thinks which you mentioned...

Have a nice day!

Kamil

CameraHardware.zip

Share this post


Link to post
Share on other sites

Hi Eduardo,

thanks, but it would be impossible to do it without your excelent reverse engineering skills!

I've started (probably as like you) from the Andromidian V4L2 camera patch, but I've had only a lot of crashes before you have posted the new virtual table and interface for the new honeycomb CameraHardwareInterface...

...so BIG THANKS to you!!!

I've concentrated only to "make it work" with the one specific camera application, and with the vega specific camera.... That means so your code is much more generic and it will be great if you will be able to finish it... Feel free to look at the sources and use what you want (if there will be something interesting for you - I'm a Java developer so please be patient... ;-) )... I'm already using some parts (mainly the Convertor to yuv420p and CameraHardwareInterface) from your sources so it should be a not problem to combine them...

In meantime I'll try to add the thinks which you mentioned...

Have a nice day!

Kamil

I'll try to do a reverse merge of my mods into your source .. I was experiencing crashes in the lubrary, but i do suspect they are caused by an improper handling of events, as i fail to find bugs in the code. So, instead of trying to fix my code, ill try to add the improvements to yours. There is no need to make the libcamera as generic as mine, but it would be nice at least to support the higher resolutions the camera can deliver... ,)

Trust me, your working cameralib is an invaluable resource here. I will keep exactly the flow and call sequences of you code, as it seems to be the only way to make this work... And, as we don't have documentation or source code of HC3.2 .. ;)

After this whole thing, the next thing will be host mode. And i do suspect that to make it work it is just a matter of changing some flags int the USB platform data ;)

Eduardo

Share this post


Link to post
Share on other sites

Is there a reason that r10 source has not been released? the linux people definately need to make their kernel source license much more restrictive to vendors because they should be providing full source with instructions for how to build a working image that can be deployed onto the advent vega device!

Thanks Paul for working with the dev's to host the code, is there a guide to requirements for compiling and deploying on a vega without custom firmware (I have actually put honeycomb for vega on without clockworkmod or rooting the vega so I know it can be done stock) I would really like to have a go at developing for my tab!

Share this post


Link to post
Share on other sites

Hi All,

here is a new version of the v4l camera.

No big changes:

- added resolution 172x144 into supported resolutions for preview and picture and this low resolution it's now set as default to be more compatible with older android apps.

- experimental support for the RGBX_8888 and RGBA_8888 preview surface (not tested)

- disabled support for camera rotation & zoom because our camera hardware doesn't support it

- support for the camera hardware power management (automatic power on/power off), but it doesn't work because the camera process doesn't have enought privileges to open the "power_on" file for writing :-( Also there is probably a bug (in kernel?), because when I'm (manualy) trying to power on the camera after power off then it doesn't work and camera is still not responding... :-(

I've also tried to add support for 1024x768 picture resolution, but the taken picture is corrupted. So 640x480 is still a maximum.

Have a nice day!

Kamil

Edit: it seems that recording is not working with this version. I'll look at this tomorrow....

libcamera.zip

Edited by redscorpion

Share this post


Link to post
Share on other sites

Hi All,

here is a new version of the v4l camera.

No big changes:

- added resolution 172x144 into supported resolutions for preview and picture and this low resolution it's now set as default to be more compatible with older android apps.

- experimental support for the RGBX_8888 and RGBA_8888 preview surface (not tested)

- disabled support for camera rotation & zoom because our camera hardware doesn't support it

- support for the camera hardware power management (automatic power on/power off), but it doesn't work because the camera process doesn't have enought privileges to open the "power_on" file for writing :-( Also there is probably a bug (in kernel?), because when I'm (manualy) trying to power on the camera after power off then it doesn't work and camera is still not responding... :-(

I've also tried to add support for 1024x768 picture resolution, but the taken picture is corrupted. So 640x480 is still a maximum.

Have a nice day!

Kamil

There is a bug? in the kernel USB support that, when a new USB device is plugged in, sometimes, it does not enumerate it ... Turning off the camera, and then on, perhaps is triggering that bug... I think that when we figure out the cause, then all things related to USB will work as expected (i suspect it is related to the fact that Shuttle uses an internal USB hub to "split" usb1 into 3 ports: Internal Camera, Internal GPS and ... perhaps the docking station...

BTW, i am still working on the merging... Psss... a little tip: The camera does not support 1024x768. It supports higher resolutions, such as 12xxx 960 and 12xx x 1024... To be sure,. video formats should be enumerated. That is what i have done ;) - And, another tip... You can use Tegra2 to scale the preview surface! -- Change the Geometry of the preview surface, keeping the pixel format, and then, the android composer will stretch the surface to the real size :)

Regards,

Eduardo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.