Jump to content
PaulOBrien

28 Jul Fr19: MoDaCo Custom ROM for the LG Optimus 2X with Online Kitchen (new: custom kernel)

Recommended Posts

Paul, a small detail: the french translation of the "Close" button, in the smileys of LG keyboard, should be "Fermer" instead of "Proche".

If it ever happens that you don't know what to do for a minute or two, please could you fix that? ^^

Noted.

P

Share this post


Link to post
Share on other sites
I can confirm it happens if you use PimpMyCpu to force it to use the lowest processor speed in screen-off. Turn that off and you'll be fine.

::Trym

cool thank you... i will give it a try :P

Share this post


Link to post
Share on other sites
Either way, if there's not a no or nb translation, there's not much I can do about that. Why don't you make one? :P

P

It used to be there, so we could put our collective heads together and find out where it's gone. But you're right, I'll make one. I take this as a hint to not report any missing localisations or bugs from now on.

::Trym

Share this post


Link to post
Share on other sites
Yes and no. I had them, but fixed it.

Open Hidden menu and select GPS test.

MOLR Protocol: User Plane

SULP -> SLP Server Setting:

Select Google and click Menu button -> Edit.

Remove text in the last field and uncheck TLS.

Use the GPS Test app from Market to check it. It might take a little while the first time because it has to update the GPS assistance data from the SLP server.

If it still doesn't lock on, go back into the same SLP Server Setting and Add a new entry:

Name: Nokia or whatever

slp address: supl.nokia.com

port: 7275

blank cert field

TLS unchecked.

Try GPS Test again.

Thanks a million :P the Nokia part helped and GPS is running smooth now!

Share this post


Link to post
Share on other sites

With Fr17 I had some random reboots and today a black screen of death and it went very hot (I had to wait about ten minutes to let it cool before it can bootup again) :\

I'm the only one?

I'll try another wipe, but I have the same apps/config I used to have in Fr15 with no issues...

And, as I posted a couple of days ago, Alarmdroid don't work after a full night in plane mode (It starts to sound when I turn the screen on)

btw, is the 64MB hack MCK available to flash via update.zip/adb? I want to give it a try, even if I doubt it can solve this kind of issues...

thanks!

Share this post


Link to post
Share on other sites
Either way, if there's not a no or nb translation, there's not much I can do about that. Why don't you make one? :P

P

Turns out I didn't have to. Found this post over at XDA: http://forum.xda-developers.com/showthread.php?t=775007

Contains all the missing localisations. Seems to be a bit older, as you have to specify whether you're creating a pop, imap or exchange account, but it's working.

::Trym

Share this post


Link to post
Share on other sites

Regarding the phone dieing, well I got a log, I don't know if it will help.

My phone just turns off all of the time now (Fr17+Fr18) - never did before. I've full wipe/flashed a number of times.

It happens so often now that it's easy to log, I just put the phone on the couch, ran logcat and watched a TV show. By the time the show ended my phone was off.

Here's the log: http://pastebin.com/XgrmydA8

Hopefully it will get some traction.

Edit: that's from boot to the last line logged before shutdown...

Edit 2: No GPS lock with any settings including faster GPS fix and even more interesting, using Vodafone's internal (private) supl server - still no fix, and that's always worked for me (staff APN).

Edited by djmcnz

Share this post


Link to post
Share on other sites
Turns out I didn't have to. Found this post over at XDA: http://forum.xda-developers.com/showthread.php?t=775007

Contains all the missing localisations. Seems to be a bit older, as you have to specify whether you're creating a pop, imap or exchange account, but it's working.

::Trym

So it's definitely the apk then... are you sure it's a regression since a prior Fr? You didn't happen to be using different apks than the kitchen apks when you experienced it working properly for you? No additional zip or perhaps some files left over from a no-wipe? If it's a regression then it's absolutely worth Paul looking at but if not, then I think you've found the best solution already.

Share this post


Link to post
Share on other sites
Regarding the phone dieing, well I got a log, I don't know if it will help.

My phone just turns off all of the time now (Fr17+Fr18) - never did before. I've full wipe/flashed a number of times.

It happens so often now that it's easy to log, I just put the phone on the couch, ran logcat and watched a TV show. By the time the show ended my phone was off.

Here's the log: http://pastebin.com/XgrmydA8

Hopefully it will get some traction.

Edit: that's from boot to the last line logged before shutdown...

Edit 2: No GPS lock with any settings including faster GPS fix and even more interesting, using Vodafone's internal (private) supl server - still no fix, and that's always worked for me (staff APN).

Oh great... that crash totally screwed my entire phone - basically created a half factory reset (Welcome Wizard appeared) and now 95% of my apps fc and I have lost all of my app configuration... great.

Here's the result of a reboot - total disaster - http://pastebin.com/ru5JnyBF

Not much fun at all. :P

What's up Paul?

Share this post


Link to post
Share on other sites
Oh great... that crash totally screwed my entire phone - basically created a half factory reset (Welcome Wizard appeared) and now 95% of my apps fc and I have lost all of my app configuration... great.

Here's the result of a reboot - total disaster - http://pastebin.com/ru5JnyBF

Not much fun at all. :P

What's up Paul?

are you using the sqlite mod/hack?

Share this post


Link to post
Share on other sites
Oh great... that crash totally screwed my entire phone - basically created a half factory reset (Welcome Wizard appeared) and now 95% of my apps fc and I have lost all of my app configuration... great.

Here's the result of a reboot - total disaster - http://pastebin.com/ru5JnyBF

Not much fun at all. :P

What's up Paul?

I have experienced the same on FR18, without the sqlite hack.

Share this post


Link to post
Share on other sites
So it's definitely the apk then... are you sure it's a regression since a prior Fr?

Well, that's a little problem, I cannot be 100% positively certain about that. I used LGEmail.apk until FR16 when I suddenly realized (due to trying CM7 Nightly) that EMailGoogle.apk had working push-mail and multiple accounts. I've deleted all MCRs prior to FR14, and even those don't have the EMailGoogle.apk in them, so I cannot find proof. I think I remember it localised (when setting lang to nb) from a bake when I was still trying things out.

So the answer is: No, I cannot be sure.

I'm pretty sure that somebody else (perhaps someone who has a bake with FR12 lying around?) can find out though. All they need to do is to unzip the rom, rename system/app/EMailGoogle.apk to EMailGoogle.zip, unzip it and take a look at then contents of the resources.arsc-file. It's a compiled resource-file, so there will be "garbage" in it, but you should be able to see the strings in any ordinary text-editor.

Whatever the reason, I couldn't really care less if my phone is in English or Norwegian (apart from the OCD-part of me which likes everything to be in the same language, whichever it is.) My main reason for bringing this up was that I thought a mistake had been made at some point. As of now, with aosp-components, only a few languages are supported. If that's intentional, fine. If not, I'm sure we collectively could find sources and compile new packages with extended language support.

I will not bring this up again - as I said, I really don't care one way or the other - though others might.

::Trym

Edited by Trym Hansen

Share this post


Link to post
Share on other sites
are you using the sqlite mod/hack?

No, this is a "test" Rom. I baked it as close to stock as is possible in the kitchen, all tweaks off.

Share this post


Link to post
Share on other sites
Oh great... that crash totally screwed my entire phone - basically created a half factory reset (Welcome Wizard appeared) and now 95% of my apps fc and I have lost all of my app configuration... great.

Had something similar, but for me "Fix Permission" in Rom Manager solved it.. Maybe not exactly the same, but you can try!

Spike

Share this post


Link to post
Share on other sites
I love the new batterylife - it actually charges itself!

This image is from tonight. I went to bed, played a little angry birds, then turned off pretty much everything, ie. sound, wifi-fi, rotation-sensors etc. As you can see I "gained" a little power during the night, the battery reading was exactly the same when I woke up as when I went to sleep. Now that's efficient.

This is 3 full charge-cycles since a batterystats.bin removal.

::Trym

Mine did the same today. From 29% back to 30% and then 31%. It´s autocharging!! :P

.

Share this post


Link to post
Share on other sites
With Fr17 I had some random reboots and today a black screen of death and it went very hot (I had to wait about ten minutes to let it cool before it can bootup again) :\

I'm the only one?

I'll try another wipe, but I have the same apps/config I used to have in Fr15 with no issues...

And, as I posted a couple of days ago, Alarmdroid don't work after a full night in plane mode (It starts to sound when I turn the screen on)

btw, is the 64MB hack MCK available to flash via update.zip/adb? I want to give it a try, even if I doubt it can solve this kind of issues...

thanks!

You're not the only one. It's a general issue with this shait. I was sitting on the bus to work today, looking out the window with the empty look only a Monday morning can provoke. Suddenly it felt like my jeans pocket was about to burst info flames. Lo and behold, my phone was melting! Okay, okay, it wasn't melting (did I get you just a little?). The back around the camera was as warm as if the phone had been in direct sunlight for a while, and obiously it wasn't responding. Battery cover off, battery out/in and it boots as if nothing happened. I put it back in my pocket and it's been fine for the whole day. It's not the first time though, more like the hundreth or so. Getting tired of it. Gonna get me a proper Android tab soon and go back to my trustworthy, rock-solid Nexus One instead. Or get a Galaxy S II *drool*. Google! Please make me a Nexus 3, and kick LG off the team!

Share this post


Link to post
Share on other sites

For the record, I ran Fr10 for the whole period up to Fr16 (did not update once) and I didn't have a single issue, no hot phone, no reboots. I had experienced them prior to Fr10 and on stock. So, for about 2 weeks my phone was perfect.

Upgrading to Fr16 was such a sweet experience though performance-wise I had to stick with it.

It may be a coincidence but I also upgraded my radio to 05-APR at the same time I moved to Fr16. I can't recall problems with Fr16 but Fr17 and Fr18 are terrible on my phone. I'd love the stability of Fr10 and the performance of Fr18... I'm sure it's possible, Paul has that power!

NB: I also have hot pocket syndrome.

Share this post


Link to post
Share on other sites
You're not the only one. It's a general issue with this shait. I was sitting on the bus to work today, looking out the window with the empty look only a Monday morning can provoke. Suddenly it felt like my jeans pocket was about to burst info flames. Lo and behold, my phone was melting! Okay, okay, it wasn't melting (did I get you just a little?). The back around the camera was as warm as if the phone had been in direct sunlight for a while, and obiously it wasn't responding. Battery cover off, battery out/in and it boots as if nothing happened. I put it back in my pocket and it's been fine for the whole day. It's not the first time though, more like the hundreth or so. Getting tired of it. Gonna get me a proper Android tab soon and go back to my trustworthy, rock-solid Nexus One instead. Or get a Galaxy S II *drool*. Google! Please make me a Nexus 3, and kick LG off the team!

Mine was hot like the heat-skin of a cpu! It was so hot that it can't boot (overheat protection, I think...)

Share this post


Link to post
Share on other sites
Mine was hot like the heat-skin of a cpu! It was so hot that it can't boot (overheat protection, I think...)

skin = sink

That's funny - and *not* a criticism! :P

I only speak one language (English obviously) and live in Netherlands... it's embarrassing only knowing one language - living next door is a little girl of 6 years - 3 languages already (NL,EN,FR)...

Edited by djmcnz

Share this post


Link to post
Share on other sites

I have the same ovverheating issue with every firmware trom stock to fr17. Today i fixed it by entering airplane mode. So maybe there are problems with the radio

Share this post


Link to post
Share on other sites
I have the same ovverheating issue with every firmware trom stock to fr17. Today i fixed it by entering airplane mode. So maybe there are problems with the radio

I haven't had any heating issues with any of the fr roms, and I can't remember having any reboots or black screens either since I made the leap from stock to modaco (Maybe there were some with the couple first, but I don't remember them). Maybe it's some specific software you got and I don't but... Oh yeah, maybe it doesn't matter, but my original baseband was 1035.21_20110223 (I've upgraded to 0405)

Share this post


Link to post
Share on other sites

Hi, Paul.

I'm still on FR17, I think it's b3.

I want to report some little issues, I had with that rom:

1. Sometimes during an incoming call, I see the stock receive call screen, which looks like the stock lockscreen, instead of the LG one. Could this have happened during the dialer optimizations, you have done?

2. I can't enter my searches in the stock browsers address bar anymore. When I type something there, I get a google search-url, whichseems to be corrupted in some way, so that the main google page is loaded. Here I have to reenter my search in the google search bar to get the results. When I change my search provider to bing, everything works fine.

Share this post


Link to post
Share on other sites

Hi, Paul.

I'm still on FR17, I think it's b3.

I want to report some little issues, I had with that rom:

1. Sometimes during an incoming call, I see the stock receive call screen, which looks like the stock lockscreen, instead of the LG one. Could this have happened during the dialer optimizations, you have done?

OMG this is normal in ALL android phones

Share this post


Link to post
Share on other sites

Hi Paul,

I dont know if it was reported before.

My gtalk application is not working as it should.

Sometimes, and not always, the talk shows all my message to the bottom, and the other person to the top. Which its very annoying.

I couldn´t find a patron to know when exactly this happens.

Share this post


Link to post
Share on other sites
It used to be there, so we could put our collective heads together and find out where it's gone. But you're right, I'll make one. I take this as a hint to not report any missing localisations or bugs from now on.

::Trym

Not at all, I didn't realise it used to be there, I thought it was always missing. :P

P

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.