Jump to content
PaulOBrien

28 Jul Fr19: MoDaCo Custom ROM for the LG Optimus 2X with Online Kitchen (new: custom kernel)

Recommended Posts

Here's a riddle for the tech-guys out there:

The other day I flashed Europe open 10C (downloaded from XDA) just to check out some stuff, and the corresponding baseband (actually the same as I had before, 0405), using SmartFlash, not NVFlash. I found out what I needed to know, and reflashed MCR FR18b2.

Up until that point, when running the LGMobile update program, it always showed my phone as having 10B installed.

Now it always shows 10C.

I did NOT run the LGMobile program while 10C was installed, so the information is not cached locally or remotely.

So... is there a partition somewhere which is untouched by MCR/CM7 which contains this information? Is anything else of importance stored there?

Any information welcome.

::Trym

Edited by Trym Hansen

Share this post


Link to post
Share on other sites
+1

Someone probably just manipulated that video... Seems weird there should be a secret button on the phone, only to be used for launching hidden menu in a secret way, instead of the ordinary way :P

I thought of that too... yes if you set up a LauncherPro swipe gesture to the Hidden Menu you can emulate that video. I'm not saying it's fake, just that you could fake it if you wanted to.

Share this post


Link to post
Share on other sites
The other day I flashed Europe open 10C (downloaded from XDA) just to check out some stuff, and the corresponding baseband (actually the same as I had before, 0405), using SmartFlash, not NVFlash. I found out what I needed to know, and reflashed MCR FR18b2.

::Trym

Do you have the link for it?

Share this post


Link to post
Share on other sites
not working for me either :P

LMAO all that dude has done is set up a swipe gesture action in launcher pro and linked it to the activity for the lg hidden menu - just done it my self, it has nowt to do with putting your finger between the back and search buttons.

Share this post


Link to post
Share on other sites

Had a reboot today, however this one was different to the rest...

I lost all of my app settings/data!! :rolleyes: :P

It's basically as if the internal database got completely corrupted. When the phone rebooted it asked me which Launcher I wanted, and that was followed by about 20 FC boxes as every app that was trying to start up crashed. Tried a restart but to no avail.

So good job I had updated to FR17 in the last week and had a nandroid backup I could restore. But I thought that FR17 didn't have the SQL hack applied by default and therefore should have been safe against this?

FWIW, I've also identified a repeatable pattern for my phone rebooting itself - it's when the wifi gets switched back on (automatically via Timeriffic in my case at 5PM) and if the phone is warm enough - like my pocket, warm car, etc. It pretty much does this every day now, and even gets in a boot loop sometimes until you force the screen to stay awake.

Share this post


Link to post
Share on other sites
Had a reboot today, however this one was different to the rest...

I lost all of my app settings/data!! :rolleyes: :P

It's basically as if the internal database got completely corrupted. When the phone rebooted it asked me which Launcher I wanted, and that was followed by about 20 FC boxes as every app that was trying to start up crashed. Tried a restart but to no avail.

So good job I had updated to FR17 in the last week and had a nandroid backup I could restore. But I thought that FR17 didn't have the SQL hack applied by default and therefore should have been safe against this?

FWIW, I've also identified a repeatable pattern for my phone rebooting itself - it's when the wifi gets switched back on (automatically via Timeriffic in my case at 5PM) and if the phone is warm enough - like my pocket, warm car, etc. It pretty much does this every day now, and even gets in a boot loop sometimes until you force the screen to stay awake.

Yeah, see a few pages back about the corruption. Sucks... <_<

Share this post


Link to post
Share on other sites
Had a reboot today, however this one was different to the rest...

I lost all of my app settings/data!! :rolleyes: :P

It's basically as if the internal database got completely corrupted. When the phone rebooted it asked me which Launcher I wanted, and that was followed by about 20 FC boxes as every app that was trying to start up crashed. Tried a restart but to no avail.

I've had this before and it was for fr12. It looks like something either (1) corrupted the permissions so you don't have write access to the /data partition or (2) the user account was reset and you therefore don't have write access to /data as it belongs to someone else or (3) something had mounted the /data partition as read only and the phone couldn't remount it as write. Could find no fix for it - each reboot did the same and logcat was filled with "unable to write to a readonly database".

I don't think the sql fix is anything to do with it as my issue was before Paul released the sql fix. The messages in the logcat as well indicated that all write access to the /data partition was broken, not just database.

Even a recovery format of /data had *no* effect and left the /data partition exactly as it was. Repeated restores of backups had *no* effect either. The only fix was to use the nvflash and do a full and complete revert to stock.

Personally, I don't think it's anything to do with the mcr roms and it's a weakness in the lg kernel somewhere that is either corrupting part of the /data partition or badly dismounting it.

HTH.

Share this post


Link to post
Share on other sites
I've had this before and it was for fr12. It looks like something either (1) corrupted the permissions so you don't have write access to the /data partition or (2) the user account was reset and you therefore don't have write access to /data as it belongs to someone else or (3) something had mounted the /data partition as read only and the phone couldn't remount it as write. Could find no fix for it - each reboot did the same and logcat was filled with "unable to write to a readonly database".

I don't think the sql fix is anything to do with it as my issue was before Paul released the sql fix. The messages in the logcat as well indicated that all write access to the /data partition was broken, not just database.

Even a recovery format of /data had *no* effect and left the /data partition exactly as it was. Repeated restores of backups had *no* effect either. The only fix was to use the nvflash and do a full and complete revert to stock.

Or "fix permissions" with Rom Manager ?

LMAO all that dude has done is set up a swipe gesture action in launcher pro and linked it to the activity for the lg hidden menu - just done it my self, it has nowt to do with putting your finger between the back and search buttons.

He says it works with LG launcher too... (video ?)

Edited by PhilNelwyn

Share this post


Link to post
Share on other sites

i have a problem with the stock browser. when i use the adressbar to search like clear adress and type "modaco android" and hit enter it will resolve the request into a google search adress but it wont open the google search results in browser. does anyone else have this? when i go to google website and use the search field in browser it works fine.

Share this post


Link to post
Share on other sites

Is anybody else having problems with the APN, just upgraded to FR17 Vanilla and it is constantly forgetting what the default APN is and consequently my internet access keeps disappeaing. when going back into APN's and selecting the right one again it takes about 3 attempts to get it to stick and have any form of browsing.

this never happened before and its driving me mad, its like that its forgetting on lock. does anybody know how to remove all the APNs so i can just have the one to try and reslove the issue? or is anybody else having this?

Share this post


Link to post
Share on other sites
Is anybody else having problems with the APN, just upgraded to FR17 Vanilla and it is constantly forgetting what the default APN is and consequently my internet access keeps disappeaing. when going back into APN's and selecting the right one again it takes about 3 attempts to get it to stick and have any form of browsing.

this never happened before and its driving me mad, its like that its forgetting on lock. does anybody know how to remove all the APNs so i can just have the one to try and reslove the issue? or is anybody else having this?

Try APN Manager.

Share this post


Link to post
Share on other sites
Regarding the phone dieing, well I got a log, I don't know if it will help.

My phone just turns off all of the time now (Fr17+Fr18) - never did before. I've full wipe/flashed a number of times.

It happens so often now that it's easy to log, I just put the phone on the couch, ran logcat and watched a TV show. By the time the show ended my phone was off.

Here's the log: http://pastebin.com/XgrmydA8

Hopefully it will get some traction.

Edit: that's from boot to the last line logged before shutdown...

Edit 2: No GPS lock with any settings including faster GPS fix and even more interesting, using Vodafone's internal (private) supl server - still no fix, and that's always worked for me (staff APN).

Oh great... that crash totally screwed my entire phone - basically created a half factory reset (Welcome Wizard appeared) and now 95% of my apps fc and I have lost all of my app configuration... great.

Here's the result of a reboot - total disaster - http://pastebin.com/ru5JnyBF

Not much fun at all. :P

What's up Paul?

Reboots

So I've been doing some more testing and have determined that I can reliably get my phone to reboot now under certain circumstances. I live in the centre of Amsterdam and if I do the following I can force a reboot.

  • Sit at home, WiFi on, GPS off
  • Start music (I do this so I can tell immediately when the phone reboots)
  • Start logcat in Terminal (logcat > /data/local/my.log)
  • Leave house, WiFi turns off, GPS turns on automatically (Settings Profile)
  • Walk around my block - bang! reboot!

I can't help but think it's radio or GPS related or something perhaps to do with the kernel? Either way GPS is borked in Fr18.

So, again here's a log from a fresh reboot to an "automatic" reboot, every line included.

Full log: http://pastebin.com/MsbSFMRn

@Paul - since I can now seem to reproduce this at will, can you provide any insight or perhaps a debugging kernel I can run to get more data? This is 100% a regression from previous Fr's so I really hope you consider it "in scope" to investigate.

Oh, and does the absence of this file suggest a reason for broken GPS?

I want to test this and help solve it because as of now I'm being forced back to Fr10... :rolleyes:

@ Paul:

Do you have a view on this? Will there be an effort to resolve or should we invest our time and testing in the CM release?

Share this post


Link to post
Share on other sites
i have a problem with the stock browser. when i use the adressbar to search like clear adress and type "modaco android" and hit enter it will resolve the request into a google search adress but it wont open the google search results in browser. does anyone else have this? when i go to google website and use the search field in browser it works fine.

Same for me. Use a pre FR17 browser.apk. Seems like something has gone wrong during norwegian localization.

As you are from Germany too, it seems this only occurs when language is set to german.

Share this post


Link to post
Share on other sites
Same for me. Use a pre FR17 browser.apk. Seems like something has gone wrong during norwegian localization.

As you are from Germany too, it seems this only occurs when language is set to german.

Thanks for reply!

i totally forgot to write what rom i use -.-

FR18B2 MCK14 without ram hack, with sql hack. German vodafone sim

Share this post


Link to post
Share on other sites
Reboots

So I've been doing some more testing and have determined that I can reliably get my phone to reboot now under certain circumstances. I live in the centre of Amsterdam and if I do the following I can force a reboot.

  • Sit at home, WiFi on, GPS off
  • Start music (I do this so I can tell immediately when the phone reboots)
  • Start logcat in Terminal (logcat > /data/local/my.log)
  • Leave house, WiFi turns off, GPS turns on automatically (Settings Profile)
  • Walk around my block - bang! reboot!

I can't help but think it's radio or GPS related or something perhaps to do with the kernel? Either way GPS is borked in Fr18.

So, again here's a log from a fresh reboot to an "automatic" reboot, every line included.

Full log: http://pastebin.com/MsbSFMRn

@Paul - since I can now seem to reproduce this at will, can you provide any insight or perhaps a debugging kernel I can run to get more data? This is 100% a regression from previous Fr's so I really hope you consider it "in scope" to investigate.

Oh, and does the absence of this file suggest a reason for broken GPS?

I want to test this and help solve it because as of now I'm being forced back to Fr10... :P

Not sure if this is related, BUT

Couple of times I've had really weird issues with toggling GPS/AutoSync (from the power control widget), where sometimes disabling GPS would also disabled syncing or when enabling sync the GPS wouldn't be actually turned on even tho it shows active in the widget (need to toggle it off and on again to get it working). I have just ended up rebooting my phone, which has fixed it for me. I did have JD running at least one time when this happened, so might be there's actually no problem with the rom itself.

Share this post


Link to post
Share on other sites
Guest

Anyone else with this problem on the lock screen? Have had it since at least FR16. And did a full wipe between 17 and the 18 betas....

20110526074235.png

Share this post


Link to post
Share on other sites
Hi. I baked ROM with Hidden menu, but i can't find it anywhere... What do i do wrong?

You didn't use the search function in this forum or the internet, that's what. :P

Share this post


Link to post
Share on other sites
Hi. I baked ROM with Hidden menu, but i can't find it anywhere... What do i do wrong?

It's not called "Hidden menu" for nothing :P

You can type 1809#*990# in the dialer, or make a shortcut to the activity if you're using Launcher Pro or ADW.

Edited by PhilNelwyn

Share this post


Link to post
Share on other sites
It's not called "Hidden menu" for nothing :P

You can type 1809#*990# in the dialer, or make a shortcut to the activity if you're using Launcher Pro or ADW.

Hi, i flashed the fr18 b2 with the stock google launcher and w/o the hidden menu, installed with the external zip (page #156) but dialiang 1809#*990# nothing appear :rolleyes:

Any suggestions ? Rom is perfect but i need menu to fix gps <_<

Thanks

Edited by Homer314

Share this post


Link to post
Share on other sites
Hi, i flashed the fr18 b2 with the stock google launcher and w/o the hidden menu, installed with the external zip (page #156) but dialiang 1809#*990# nothing appear :P

Any suggestions ? Rom is perfect but i need menu to fix gps :rolleyes:

Thanks

So you baked without hidden menu and expect it to magically appear anyway?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.