Jump to content
PaulOBrien

28 Jul Fr19: MoDaCo Custom ROM for the LG Optimus 2X with Online Kitchen (new: custom kernel)

Recommended Posts

one question, i use fr17 per default and i think its much better than stock lg. sometimes i like to test out cm7 nightlies, and i always make a nandroid backup in cwm recovery beforehand, but when i want to go back i have to reflash and loose all my settings because if i just restore the backup my device gets stuck in a reboot loop. what am i doing wrong, or have i got the whole nandroid backup thing wrong?

You're not on your own with this, I have also noticed that a nandroid restore never ever works, i've given up on flashing rom's completely for the time being until this is somehow resolved. Getting totally fed up with having to nvflash and then re set everything back up by hand lol. I'm really not sure whether its me having not read something on here or if its just us, (perhaps someone can enlighten if it's us being dim).

I've tried going back from r18 beta 2, and that resulted in a freeze on the LG logo, even after using ext4backto3 zip, as i was sure that would have been the problem, but no. Then today I got the bug to try cm7 out, did a backup and tried it for a bit, then tried to go back and hit the same issue. (pretty sure cm7 does not alter the filesystem to ext4 too)

What I have now resorted to doing, is using stock 10b, rooting, adding a gps fix, flashing cwm via rom mannager, then flashing SQlite via cwm, and sticking with that as it gives me a reasonably speedy rom with no stability issues at all. Would love to know why it keeps hanging tho when restoring???

Share this post


Link to post
Share on other sites

this is the reason :

http://forum.xda-developers.com/showpost.p...mp;postcount=16

it's just because /boot is not mounted during restore so you stuck with CM boot... and CM boot not compatible with your stock rom backup :P

and it's why we can't go back from CM to stock rom nandroid backup coz /boot stay with the CM boot and in this way stock restore can't be full ( including /boot ) .

Edited by ilos

Share this post


Link to post
Share on other sites
You're not on your own with this, I have also noticed that a nandroid restore never ever works, i've given up on flashing rom's completely for the time being until this is somehow resolved. Getting totally fed up with having to nvflash and then re set everything back up by hand lol. I'm really not sure whether its me having not read something on here or if its just us, (perhaps someone can enlighten if it's us being dim).

I've tried going back from r18 beta 2, and that resulted in a freeze on the LG logo, even after using ext4backto3 zip, as i was sure that would have been the problem, but no. Then today I got the bug to try cm7 out, did a backup and tried it for a bit, then tried to go back and hit the same issue. (pretty sure cm7 does not alter the filesystem to ext4 too)

What I have now resorted to doing, is using stock 10b, rooting, adding a gps fix, flashing cwm via rom mannager, then flashing SQlite via cwm, and sticking with that as it gives me a reasonably speedy rom with no stability issues at all. Would love to know why it keeps hanging tho when restoring???

This is quite simply a bug in CWM 3.0.2.8. It doesn't restore correctly. It does backup correctly however. Install 3.0.1.4 before restoring (as I think I read somewhere you need 3.0.2.8 to flash CM7 correctly.)

I just now, literally 60 seconds ago, came back from trying it out. Took a backup with 3.0.2.8 (of a stock rom with my own mods.). Rebooted. Back to CWM. Restored. Phone wouldn't boot.

NVFlashed, installed 3.0.1.4, restored backup, and I'm good to go again. Definitely a bug in CWM 3.0.2.8

::Trym

Share this post


Link to post
Share on other sites
This is quite simply a bug in CWM 3.0.2.8. It doesn't restore correctly. It does backup correctly however. Install 3.0.1.4 before restoring (as I think I read somewhere you need 3.0.2.8 to flash CM7 correctly.)

I just now, literally 60 seconds ago, came back from trying it out. Took a backup with 3.0.2.8 (of a stock rom with my own mods.). Rebooted. Back to CWM. Restored. Phone wouldn't boot.

NVFlashed, installed 3.0.1.4, restored backup, and I'm good to go again. Definitely a bug in CWM 3.0.2.8

::Trym

Excellent, thanks for that, gonna go track down 3.0.1.4 now, handy to know that is, you never know what you are missing out on if you don't try the odd ROM out or two :-)

Share this post


Link to post
Share on other sites
Excellent, thanks for that, gonna go track down 3.0.1.4 now, handy to know that is, you never know what you are missing out on if you don't try the odd ROM out or two :-)

check my previous post, i'm not sure to try another CWM will solve the mount problem...

Share this post


Link to post
Share on other sites

Possibly, but I'm not really quite clever enough to know ;-) I think I might just wait till a cm7 rc or stable comes out then make the switch. From what I saw today, its nearly there now, however, I'm going off topic, but thanks for you're replies.

Share this post


Link to post
Share on other sites
Possibly, but I'm not really quite clever enough to know ;-) I think I might just wait till a cm7 rc or stable comes out then make the switch. From what I saw today, its nearly there now, however, I'm going off topic, but thanks for you're replies.

Did some more testing. CWM 3.2.0.0 is out. You can find it here: http://forum.xda-developers.com/showthread.php?t=1098001

It's a bit scary the first time, because it actually says "Error mounting /boot!" when restoring.

But then it restores the boot-image anyway.

I've now:

o Installed CM7

o Taken a Backup

o Restored my stock backup

o Booted succesfully into stock.

o Rebooted into CMW again, restored the CM7 backup

o Booted succesfully into CM7.

So basically, using 3.2.0.0 you can go back and forth at will. Things just got a bit more interesting ;-)....

::Trym

Edited by Trym Hansen

Share this post


Link to post
Share on other sites
I've tried FR 17 and FR 18 beta, but they are unstable and the phone often reboots by itself.

I am using vorkKernel v5 with it.

I've also tried CM7 nightlies (up to build 31) ant those are much stabler.

Any reason why Modaco FR 17 may not be stable? Does it not work together with mentioned kernel?

UPDATE: I found out vorkKernel is specifically designed for CM7,

so thats probably the reason of the problems...

no clue how CM7 is stable for you and FR17 is not.

I'm using FR17 since it came out and never had a reboot, freeze, power off, huge lag, battery drain.

I installed CM7 #30 once and reboots happen, camera hangs, browser freezes etc.

I think you're a special person :P

Share this post


Link to post
Share on other sites
one question, i use fr17 per default and i think its much better than stock lg. sometimes i like to test out cm7 nightlies, and i always make a nandroid backup in cwm recovery beforehand, but when i want to go back i have to reflash and loose all my settings because if i just restore the backup my device gets stuck in a reboot loop. what am i doing wrong, or have i got the whole nandroid backup thing wrong?

if you test out a CM7 and wanna come back to a FR17 backup:

do a full wipe + dalvik cache

install the original FR17

restore your FR17 backup

reboot your phone.

because CM7 uses ext3 and if you restore your FR17 backup, the partition remains ext3 and FR17 needs ext4

that's why you install the original FR17 first so it converts your partition, then restore your backup.

Share this post


Link to post
Share on other sites
So basically, using 3.2.0.0 you can go back and forth at will. Things just got a bit more interesting ;-)....

::Trym

So this version of CWM doesnt bootloop your device on restore?

Share this post


Link to post
Share on other sites
Has Paul stopped working on the mod? There have been no updates for a long time!

The title of this thread is "20 May Fr18 Beta 2" and you only posted this 7 days later. 1 week is hardly "a long time", even if it feels like it :P

If you crave frequent updates why not try Cyanogenmods ROM, its updated nightly! :rolleyes:

Paul works on a number of devices at any one time.... if you follow him on twitter you will see he is currently doing a lot of stuff with the HTC Flyer, Transformer and SG SII to name but a few.

The LG Optimus is just one of his many devices (the lucky..... <_< ) so be patient, he has never let us down before!!

Zippyioa

Share this post


Link to post
Share on other sites

There was a rumor on xda that Paul's version of CWM to Optimus 2x identified the device as 999(or something), not 990, and could cause reboots when restoring. They recommended flashing CWM from Rom-manager.

Don't know if this is true, but I thought you should know...

Share this post


Link to post
Share on other sites
There was a rumor on xda that Paul's version of CWM to Optimus 2x identified the device as 999(or something), not 990, and could cause reboots when restoring. They recommended flashing CWM from Rom-manager.

Don't know if this is true, but I thought you should know...

And yet installing Rom manager and updating cwm means i can't restore backups since my phone bootloops ;-). And Pauls version worked, so imo they should either pipe down or make sure that the version they recommend is working first :-p

Share this post


Link to post
Share on other sites
because CM7 uses ext3 and if you restore your FR17 backup, the partition remains ext3 and FR17 needs ext4

that's why you install the original FR17 first so it converts your partition, then restore your backup.

Wrong?

When I tested CM7 (twice), I did a back-up of MCR, installed CWM recovery via Rom Manager, flashed CM7, noticed it was not good enough yet, and then simply restored MCR.

(For information, I'm still using MCR 16 with default kernel)

[edit] using CWM recovery 3.0.2.8, I just restored my very first nandroid back-up, stock rom, without any problem.

No need of any "back-to-ext3" method, and isn't it logical ? Doesn't restoring overwrite partitions ?

Edited by PhilNelwyn

Share this post


Link to post
Share on other sites

I need some help...

I have been trying to install your Custom rom for two days now, without any luck..

no matter what i do and how i try to install this Rom it just hangs on the LG LOGO.. first i thought that there was something wrong with my phone.

But then i tried installing CyanogenMod 7 and BlazingDragon 1.8 from XDA they both work perfekt..

can anybody help me, what is wrong. ???

I have even tryed making a clean flash with NVflash and started all over still no go :-(

You guys would make my day, if you could help

Thanks

Share this post


Link to post
Share on other sites
Did some more testing. CWM 3.2.0.0 is out. You can find it here: http://forum.xda-developers.com/showthread.php?t=1098001

It's a bit scary the first time, because it actually says "Error mounting /boot!" when restoring.

But then it restores the boot-image anyway.

I've now:

o Installed CM7

o Taken a Backup

o Restored my stock backup

o Booted succesfully into stock.

o Rebooted into CMW again, restored the CM7 backup

o Booted succesfully into CM7.

So basically, using 3.2.0.0 you can go back and forth at will. Things just got a bit more interesting ;-)....

::Trym

Well, you're reply has tempted me to once again, have a go at restoring backups. I just tried it with a cm7 backup I had and it has worked just fine, that wouldn't work at all yesterday. For the record, the cwm i was previously using was the one downloaded from rom manager, not pauls one.

Now am attempting to go back to stock via nandroid..................And, it works :P

Thanks muchly

Share this post


Link to post
Share on other sites
I have been trying to install your Custom rom for two days now, without any luck..

But then i tried installing CyanogenMod 7 and BlazingDragon 1.8 from XDA they both work perfekt..

can anybody help me, what is wrong. ???

BlazingDragon 1.8 *is* FR17, so if one works the other should as well.

You don't give enough details to actually get help in any way. So here's some general advice:

Remember to WIPE!

Read post #1 very thoroughly.

Read the last 20 pages.

Don't do the same thing over and over - you'll get the same result. Switch things around. Try another usb-port, another cable, another baseband, and so on...

Lastly: When asking for help, you need to provide useful information. In this case it would be a step-by-step description of what you have done so far. You can't go to a doctor and say "I'm sick, give me some medicine!". (Well, you can, but you won't get any.)

Anyway, good luck.

::Trym

Share this post


Link to post
Share on other sites

Fr18B2 (default)

after install one app => 5-30 sec system is very slow and freeze

in stock => installation of multiple (3-5) app => system is Ok

Share this post


Link to post
Share on other sites
Fr18B2 (default)

after install one app => 5-30 sec system is very slow and freeze

in stock => installation of multiple (3-5) app => system is Ok

Not true. I'm running stock and my LG lags when i install some apps even if it just a single one.

Share this post


Link to post
Share on other sites
Not true. I'm running stock and my LG lags when i install some apps even if it just a single one.

mmm... Fr15 is installed - Ok

Think (imho) - SQLite: slow database write (after install app -> write info to databases)

Share this post


Link to post
Share on other sites

sorry for posting such a noob question but i cant seem to find any help regarding this, "Based on the 1303220460 (19/04/2011) release" i cant find this release anywhere? Im probably wrong but isnt it best to have the same baseband as what the rom is based on, i can only seem to find 405 and some others but not the 460.

Any help with this would be appreciated! My signal is crap, same as voice quality

Share this post


Link to post
Share on other sites

My personal favorite is:

post-620895-1306693282_thumb.png

Its german and the popup says follwing:

Connect battery charger

Battery almost empty.

90% or less left.

:D:D

Share this post


Link to post
Share on other sites
I never saw such a bad battery and power management .... I spent one day using this phone ( few messages, pictures, gps apps, google apps ) and this s....t was empty after about 6 ou7 hours ....

this phone should be sold with external battery backup like this one :

http://www.amazon.com/Energizer-XP4001-Uni...5153&sr=8-1

dude if you have fr18b2 installed do a battery stats wipe. i rarely need more than 50% of battery a day since this great rom and a battery wipe. 2 hours of gps logging (34km with my bike) took about 22%. i use twitter, facebook and mails a lot and do play some games and have some calls every day. today i have 60% left and i have no idea how to get it low to 0% because i would like to charge the battery this night because tomorrow i wanna bicycle with gps on and i dont know how long i will ride. last time it worked for me to watch simpsons on youtube in android browser :D but that was für about 30% and it took a long time :D

EDIT: btw my last post ... this picture is kind of ironic but true

Edited by ben1th

Share this post


Link to post
Share on other sites

I'm running the [ROM][19/05-11]TK-ROM Vanilla + LG = true. v1.2 (Fr17)

a modified Fr17 version but there's no resident program running, wifi is off and data is off 90% of the time ( because of roaming reasons )

I hope that that battery stats rip will improve the battery life

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.